summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2007-08-01 21:44:23 +0000
committerDaniel Black <dragonheart@gentoo.org>2007-08-01 21:44:23 +0000
commit50ebed925fca32c678ec8d7fe99184d739cf46fe (patch)
tree890e810d0a24a5454f0a06b90d5f83f96bc761c7 /net-ftp
parentrefresh 24_libparted_1_8_7.patch (diff)
downloadgentoo-2-50ebed925fca32c678ec8d7fe99184d739cf46fe.tar.gz
gentoo-2-50ebed925fca32c678ec8d7fe99184d739cf46fe.tar.bz2
gentoo-2-50ebed925fca32c678ec8d7fe99184d739cf46fe.zip
version bump thanks to Elias Pipping- bug #186787
(Portage version: 2.1.2.9)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog7
-rw-r--r--net-ftp/lftp/files/digest-lftp-3.5.123
-rw-r--r--net-ftp/lftp/lftp-3.5.12.ebuild56
3 files changed, 65 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index b943af0fb3fc..e3dfa9083228 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/lftp
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.135 2007/07/17 11:39:51 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.136 2007/08/01 21:44:23 dragonheart Exp $
+
+*lftp-3.5.12 (01 Aug 2007)
+
+ 01 Aug 2007; Daniel Black <dragonheart@gentoo.org> +lftp-3.5.12.ebuild:
+ version bump thanks to Elias Pipping- bug #186787
17 Jul 2007; Daniel Black <dragonheart@gentoo.org>
-files/lftp-3.4.6-nossl.patch, -lftp-3.4.6.ebuild, lftp-3.5.11.ebuild:
diff --git a/net-ftp/lftp/files/digest-lftp-3.5.12 b/net-ftp/lftp/files/digest-lftp-3.5.12
new file mode 100644
index 000000000000..f3bddda59a55
--- /dev/null
+++ b/net-ftp/lftp/files/digest-lftp-3.5.12
@@ -0,0 +1,3 @@
+MD5 08c8d03cfd93d1d49122654bedad16d1 lftp-3.5.12.tar.bz2 1330058
+RMD160 3d2e0db1b7af6011a849f4ea60a200b9e125b667 lftp-3.5.12.tar.bz2 1330058
+SHA256 080f6a48b6c771f93915e9b4588d44ad12ddab8000b9399993bfc07d99910ff0 lftp-3.5.12.tar.bz2 1330058
diff --git a/net-ftp/lftp/lftp-3.5.12.ebuild b/net-ftp/lftp/lftp-3.5.12.ebuild
new file mode 100644
index 000000000000..d70c11030dce
--- /dev/null
+++ b/net-ftp/lftp/lftp-3.5.12.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-3.5.12.ebuild,v 1.1 2007/08/01 21:44:23 dragonheart Exp $
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+SRC_URI="http://ftp.yars.free.net/pub/source/lftp/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="ssl gnutls socks5 nls"
+
+RDEPEND=">=sys-libs/ncurses-5.1
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ virtual/libc
+ >=sys-libs/readline-5.1"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-lang/perl"
+
+src_compile() {
+ local myconf="$(use_enable nls) --enable-packager-mode"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --with-modules \
+ ${myconf} || die "econf failed"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc BUGS ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}