summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-05-19 21:09:43 +0000
committerJeroen Roovers <jer@gentoo.org>2014-05-19 21:09:43 +0000
commita7fb69528bbfad37bda3e085ceb90aaa30771b87 (patch)
treef6af8d9c731f7b7fb1433cef80b4c8d074a88829 /net-ftp
parentMarked ~hppa (bug #510340). (diff)
downloadgentoo-2-a7fb69528bbfad37bda3e085ceb90aaa30771b87.tar.gz
gentoo-2-a7fb69528bbfad37bda3e085ceb90aaa30771b87.tar.bz2
gentoo-2-a7fb69528bbfad37bda3e085ceb90aaa30771b87.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog7
-rw-r--r--net-ftp/lftp/lftp-4.4.99.20140519.ebuild84
2 files changed, 90 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index 37d5c74f5145..6e9937a8dfeb 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/lftp
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.469 2014/05/08 11:52:19 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.470 2014/05/19 21:09:43 jer Exp $
+
+*lftp-4.4.99.20140519 (19 May 2014)
+
+ 19 May 2014; Jeroen Roovers <jer@gentoo.org> +lftp-4.4.99.20140519.ebuild:
+ Version bump.
*lftp-4.4.16 (08 May 2014)
diff --git a/net-ftp/lftp/lftp-4.4.99.20140519.ebuild b/net-ftp/lftp/lftp-4.4.99.20140519.ebuild
new file mode 100644
index 000000000000..7d15b9206fa8
--- /dev/null
+++ b/net-ftp/lftp/lftp-4.4.99.20140519.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-4.4.99.20140519.ebuild,v 1.1 2014/05/19 21:09:43 jer Exp $
+
+EAPI=5
+inherit autotools eutils libtool
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+SRC_URI="http://${PN}.yar.ru/ftp/devel/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+
+IUSE="convert-mozilla-cookies +gnutls nls openssl socks5 +ssl verify-file"
+LFTP_LINGUAS=( cs de es fr it ja ko pl pt_BR ru zh_CN zh_HK zh_TW )
+IUSE+=" ${LFTP_LINGUAS[@]/#/linguas_}"
+
+REQUIRED_USE="
+ ssl? ( ^^ ( openssl gnutls ) )
+"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/readline-5.1
+ dev-libs/expat
+ sys-libs/zlib
+ convert-mozilla-cookies? ( dev-perl/DBI )
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam
+ )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ openssl? ( >=dev-libs/openssl-0.9.6 )
+ )
+ verify-file? (
+ dev-perl/string-crc32
+ virtual/perl-Digest-MD5
+ )
+"
+
+DEPEND="
+ ${RDEPEND}
+ =sys-devel/libtool-2*
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+DOCS=(
+ BUGS ChangeLog FAQ FEATURES MIRRORS NEWS README README.debug-levels
+ README.dnssec README.modules THANKS TODO
+)
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${PN}-4.0.2.91-lafile.patch" \
+ "${FILESDIR}/${PN}-4.3.5-autopoint.patch" \
+ "${FILESDIR}/${PN}-4.3.8-gets.patch"
+ sed -i configure.ac -e 's|^AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
+ eautoreconf
+ elibtoolize # for Darwin bundles
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with gnutls) \
+ $(use_with openssl openssl "${EPREFIX}"/usr) \
+ $(use_with socks5 socksdante "${EPREFIX}"/usr) \
+ --enable-packager-mode \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --with-modules \
+ --without-included-regex
+}
+
+src_install() {
+ default
+ local script
+ for script in {convert-mozilla-cookies,verify-file}; do
+ use ${script} || { rm "${ED}"/usr/share/${PN}/${script} || die ;}
+ done
+}