summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-02-03 00:08:59 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-02-03 00:08:59 +0000
commite6113acb63dfa86ffdd0a4dc78030e89fce1b803 (patch)
treee3350aab5f90639052c3c8ddeef738f6f4fd62cf /net-ftp
parentmedia-sound/fapg: 0.42 (diff)
downloadgentoo-2-e6113acb63dfa86ffdd0a4dc78030e89fce1b803.tar.gz
gentoo-2-e6113acb63dfa86ffdd0a4dc78030e89fce1b803.tar.bz2
gentoo-2-e6113acb63dfa86ffdd0a4dc78030e89fce1b803.zip
Version bump, bug #538530
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/filezilla/ChangeLog10
-rw-r--r--net-ftp/filezilla/filezilla-3.10.1.1.ebuild68
2 files changed, 76 insertions, 2 deletions
diff --git a/net-ftp/filezilla/ChangeLog b/net-ftp/filezilla/ChangeLog
index 5e24f74ad959..deb8cc9d0dfd 100644
--- a/net-ftp/filezilla/ChangeLog
+++ b/net-ftp/filezilla/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/filezilla
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.119 2014/10/20 08:54:22 voyageur Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.120 2015/02/03 00:08:59 voyageur Exp $
+
+*filezilla-3.10.1.1 (02 Feb 2015)
+
+ 02 Feb 2015; Bernard Cafarelli <voyageur@gentoo.org>
+ +filezilla-3.10.1.1.ebuild:
+ Version bump, bug #538530
*filezilla-3.9.0.6 (20 Oct 2014)
diff --git a/net-ftp/filezilla/filezilla-3.10.1.1.ebuild b/net-ftp/filezilla/filezilla-3.10.1.1.ebuild
new file mode 100644
index 000000000000..7861fb8095e7
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.10.1.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/filezilla-3.10.1.1.ebuild,v 1.1 2015/02/03 00:08:59 voyageur Exp $
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+
+inherit autotools eutils flag-o-matic multilib wxwidgets
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="http://filezilla-project.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+IUSE="aqua dbus nls test"
+
+RDEPEND=">=app-admin/eselect-wxwidgets-0.7-r1
+ >=dev-db/sqlite-3.7
+ >=dev-libs/tinyxml-2.6.1-r1[stl]
+ net-dns/libidn
+ >=net-libs/gnutls-3.1.12
+ aqua? ( >=x11-libs/wxGTK-3.0.2.0-r1:3.0[aqua] )
+ !aqua? ( >=x11-libs/wxGTK-3.0.2.0-r1:3.0[X] x11-misc/xdg-utils )
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/libtool-1.4
+ nls? ( >=sys-devel/gettext-0.11 )
+ test? ( dev-util/cppunit )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.7.4-debug.patch
+ append-cppflags -DTIXML_USE_STL
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with dbus) $(use_enable nls locales) \
+ --with-tinyxml=system \
+ --disable-autoupdatecheck
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ doicon src/interface/resources/48x48/${PN}.png
+
+ dodoc AUTHORS ChangeLog NEWS
+
+ if use aqua ; then
+ cat > "${T}/${PN}" <<-EOF
+ #!${EPREFIX}/bin/bash
+ open "${EPREFIX}"/Applications/FileZilla.app
+ EOF
+ rm "${ED}/usr/bin/${PN}" || die
+ dobin "${T}/${PN}"
+ insinto /Applications
+ doins -r "${S}"/FileZilla.app
+ fi
+}