summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-12-12 16:43:49 +0000
committerAli Polatel <hawking@gentoo.org>2007-12-12 16:43:49 +0000
commiteaf9f71b678510e355cc97bb859719b1fb2eaf88 (patch)
tree80105ebbedd71895411fc110a2bc95d2b3e47d17 /net-ftp
parentStable on ppc64; bug #202008 (diff)
downloadgentoo-2-eaf9f71b678510e355cc97bb859719b1fb2eaf88.tar.gz
gentoo-2-eaf9f71b678510e355cc97bb859719b1fb2eaf88.tar.bz2
gentoo-2-eaf9f71b678510e355cc97bb859719b1fb2eaf88.zip
Revbump. Added patch to prevent running against other SLOTs of wxpython, #201314
(Portage version: 2.1.4_rc9)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/ftpcube/ChangeLog9
-rw-r--r--net-ftp/ftpcube/files/digest-ftpcube-0.5.1-r13
-rw-r--r--net-ftp/ftpcube/files/ftpcube-0.5.1-wxversion.patch22
-rw-r--r--net-ftp/ftpcube/ftpcube-0.5.1-r1.ebuild29
4 files changed, 62 insertions, 1 deletions
diff --git a/net-ftp/ftpcube/ChangeLog b/net-ftp/ftpcube/ChangeLog
index 168fef8629ed..5144a5e5d2ad 100644
--- a/net-ftp/ftpcube/ChangeLog
+++ b/net-ftp/ftpcube/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-ftp/ftpcube
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpcube/ChangeLog,v 1.36 2007/10/03 05:09:03 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpcube/ChangeLog,v 1.37 2007/12/12 16:43:48 hawking Exp $
+
+*ftpcube-0.5.1-r1 (12 Dec 2007)
+
+ 12 Dec 2007; Ali Polatel <hawking@gentoo.org>
+ +files/ftpcube-0.5.1-wxversion.patch, +ftpcube-0.5.1-r1.ebuild:
+ Revbump. Added patch to prevent running against other SLOTs of wxpython,
+ #201314
03 Oct 2007; Ryan Hill <dirtyepic@gentoo.org> ftpcube-0.5.1.ebuild:
Lock wxpython dependency.
diff --git a/net-ftp/ftpcube/files/digest-ftpcube-0.5.1-r1 b/net-ftp/ftpcube/files/digest-ftpcube-0.5.1-r1
new file mode 100644
index 000000000000..302584b55fd0
--- /dev/null
+++ b/net-ftp/ftpcube/files/digest-ftpcube-0.5.1-r1
@@ -0,0 +1,3 @@
+MD5 3eb93ae44fa552ec50a24b7882198dd1 ftpcube-0.5.1.tar.gz 136786
+RMD160 7f842212ede9a869a5820f210cbb862279b36c67 ftpcube-0.5.1.tar.gz 136786
+SHA256 1c2915acd1a5013aafdde1088d82e2b767a95327e8494fd23495fcce50409c67 ftpcube-0.5.1.tar.gz 136786
diff --git a/net-ftp/ftpcube/files/ftpcube-0.5.1-wxversion.patch b/net-ftp/ftpcube/files/ftpcube-0.5.1-wxversion.patch
new file mode 100644
index 000000000000..706790b83130
--- /dev/null
+++ b/net-ftp/ftpcube/files/ftpcube-0.5.1-wxversion.patch
@@ -0,0 +1,22 @@
+diff -Naur ftpcube-0.5.1-orig/libftpcube/__init__.py ftpcube-0.5.1/libftpcube/__init__.py
+--- ftpcube-0.5.1-orig/libftpcube/__init__.py 2007-01-07 16:10:35.000000000 -0600
++++ ftpcube-0.5.1/libftpcube/__init__.py 2007-12-04 20:07:55.000000000 -0600
+@@ -30,6 +30,11 @@
+
+ wx_failure = None
+ try:
++ import wxversion
++ wxversion.select("2.6")
++except Exception, strerror:
++ wx_failure = strerror
++try:
+ import wx
+ except ImportError, strerror:
+ wx_failure = strerror
+@@ -87,4 +92,4 @@
+ 'url',
+ 'utils',
+ 'version',
+-]
+\ No newline at end of file
++]
diff --git a/net-ftp/ftpcube/ftpcube-0.5.1-r1.ebuild b/net-ftp/ftpcube/ftpcube-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..d51975ae87d7
--- /dev/null
+++ b/net-ftp/ftpcube/ftpcube-0.5.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpcube/ftpcube-0.5.1-r1.ebuild,v 1.1 2007/12/12 16:43:48 hawking Exp $
+
+inherit distutils
+
+MY_P="${P/_beta/-b}"
+DESCRIPTION="Graphical FTP client using wxPython"
+SRC_URI="mirror://sourceforge/ftpcube/${MY_P}.tar.gz"
+HOMEPAGE="http://ftpcube.sourceforge.net/"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="Artistic"
+IUSE="sftp"
+
+DEPEND="=dev-python/wxpython-2.6*
+ sftp? ( dev-python/paramiko )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ distutils_src_unpack
+ epatch "${FILESDIR}/${P}-wxversion.patch"
+}
+
+src_install() {
+ distutils_src_install --install-scripts=/usr/bin
+}