summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2014-10-10 08:50:07 +0000
committerAlex Alexander <wired@gentoo.org>2014-10-10 08:50:07 +0000
commit8f8b308b5c17cf5a6afdece2a8e29131354dc6ab (patch)
treed1f43c36e09cf9fe5f7b1d7a1cfec045f93eb0e3 /net-im/bitlbee
parentFix subslot (diff)
downloadgentoo-2-8f8b308b5c17cf5a6afdece2a8e29131354dc6ab.tar.gz
gentoo-2-8f8b308b5c17cf5a6afdece2a8e29131354dc6ab.tar.bz2
gentoo-2-8f8b308b5c17cf5a6afdece2a8e29131354dc6ab.zip
version bump. libotr-4 and systemd support. bug #516918
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key EB9B4AFA)
Diffstat (limited to 'net-im/bitlbee')
-rw-r--r--net-im/bitlbee/ChangeLog7
-rw-r--r--net-im/bitlbee/bitlbee-3.2.2.ebuild180
2 files changed, 186 insertions, 1 deletions
diff --git a/net-im/bitlbee/ChangeLog b/net-im/bitlbee/ChangeLog
index 2dc92f92f161..6f8217fcdcb6 100644
--- a/net-im/bitlbee/ChangeLog
+++ b/net-im/bitlbee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/bitlbee
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/bitlbee/ChangeLog,v 1.172 2014/10/09 09:51:50 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/bitlbee/ChangeLog,v 1.173 2014/10/10 08:50:07 wired Exp $
+
+*bitlbee-3.2.2 (10 Oct 2014)
+
+ 10 Oct 2014; Alex Alexander <wired@gentoo.org> +bitlbee-3.2.2.ebuild:
+ version bump. libotr-4 and systemd support. bug #516918
*bitlbee-3.2.1-r2 (09 Oct 2014)
diff --git a/net-im/bitlbee/bitlbee-3.2.2.ebuild b/net-im/bitlbee/bitlbee-3.2.2.ebuild
new file mode 100644
index 000000000000..8c3f8dfd8ca1
--- /dev/null
+++ b/net-im/bitlbee/bitlbee-3.2.2.ebuild
@@ -0,0 +1,180 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/bitlbee/bitlbee-3.2.2.ebuild,v 1.1 2014/10/10 08:50:07 wired Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils multilib user python-single-r1 systemd
+
+DESCRIPTION="irc to IM gateway that support multiple IM protocols"
+HOMEPAGE="http://www.bitlbee.org/"
+SRC_URI="http://get.bitlbee.org/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="debug gnutls ipv6 +jabber libevent msn nss +oscar otr +plugins purple selinux
+skype ssl test twitter +yahoo xinetd"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.14
+ purple? ( net-im/pidgin )
+ libevent? ( dev-libs/libevent )
+ otr? ( >=net-libs/libotr-4 )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? (
+ nss? ( dev-libs/nss )
+ !nss? ( ssl? ( dev-libs/openssl ) )
+ )
+ selinux? ( sec-policy/selinux-bitlbee )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ skype? ( app-text/asciidoc )
+ test? ( dev-libs/check )"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/logger
+ skype? (
+ dev-python/skype4py[${PYTHON_USEDEP}]
+ net-im/skype
+ )
+ xinetd? ( sys-apps/xinetd )"
+
+REQUIRED_USE="|| ( purple jabber msn oscar yahoo )
+ msn? ( || ( gnutls nss ssl ) )
+ jabber? ( !nss )"
+
+pkg_setup() {
+ if use jabber && ! use gnutls && ! use ssl ; then
+ einfo
+ elog "You have enabled support for Jabber but do not have SSL"
+ elog "support enabled. This *will* prevent bitlbee from being"
+ elog "able to connect to SSL enabled Jabber servers. If you need to"
+ elog "connect to Jabber over SSL, enable ONE of the following use"
+ elog "flags: gnutls or ssl"
+ einfo
+ fi
+
+ use skype && python-single-r1_pkg_setup
+
+ enewgroup bitlbee
+ enewuser bitlbee -1 -1 /var/lib/bitlbee bitlbee
+}
+
+src_prepare() {
+ sed -i \
+ -e "s@/usr/local/sbin/bitlbee@/usr/sbin/bitlbee@" \
+ -e "s/nobody/bitlbee/" \
+ -e "s/}/ disable = yes\n}/" \
+ doc/bitlbee.xinetd || die "sed failed in xinetd"
+
+ sed -i \
+ -e "s@mozilla-nss@nss@g" \
+ configure || die "sed failed in configure"
+
+ use skype && python_fix_shebang protocols/skype/skyped.py
+
+ epatch "${FILESDIR}"/${PN}-3.2.1-configure.patch
+}
+
+src_configure() {
+ # setup plugins, protocol, ipv6 and debug
+ for flag in debug ipv6 msn jabber oscar plugins purple skype twitter yahoo ; do
+ if use ${flag} ; then
+ myconf="${myconf} --${flag}=1"
+ else
+ myconf="${myconf} --${flag}=0"
+ fi
+ done
+
+ # set otr
+ if use otr && use plugins ; then
+ myconf="${myconf} --otr=plugin"
+ else
+ if use otr ; then
+ ewarn "OTR support has been disabled automatically because it"
+ ewarn "requires the plugins USE flag."
+ fi
+ myconf="${myconf} --otr=0"
+ fi
+
+ # setup ssl use flags
+ if use gnutls ; then
+ myconf="${myconf} --ssl=gnutls"
+ einfo "Using gnutls for SSL support"
+ elif use ssl ; then
+ myconf="${myconf} --ssl=openssl"
+ einfo "Using openssl for SSL support"
+ elif use nss ; then
+ myconf="${myconf} --ssl=nss"
+ einfo "Using nss for SSL support"
+ else
+ myconf="${myconf} --ssl=bogus"
+ einfo "You will not have any encryption support enabled."
+ fi
+
+ # set event handler
+ if use libevent ; then
+ myconf="${myconf} --events=libevent"
+ else
+ myconf="${myconf} --events=glib"
+ fi
+
+ # NOTE: bitlbee's configure script is not an autotool creation,
+ # so that is why we don't use econf.
+ ./configure --prefix=/usr --datadir=/usr/share/bitlbee \
+ --etcdir=/etc/bitlbee --plugindir=/usr/$(get_libdir)/bitlbee \
+ --systemdsystemunitdir=$(systemd_get_unitdir) \
+ --strip=0 ${myconf} || die "econf failed"
+
+ sed -i \
+ -e "/^EFLAGS/s:=:&${LDFLAGS} :" \
+ Makefile.settings || die "sed failed"
+}
+
+src_install() {
+ emake install install-etc install-doc install-dev install-systemd DESTDIR="${D}"
+
+ keepdir /var/lib/bitlbee
+ fperms 700 /var/lib/bitlbee
+ fowners bitlbee:bitlbee /var/lib/bitlbee
+
+ dodoc doc/{AUTHORS,CHANGES,CREDITS,FAQ,README}
+ dodoc doc/user-guide/user-guide.txt
+ dohtml doc/user-guide/*.html
+
+ if use skype ; then
+ newdoc protocols/skype/NEWS NEWS-skype
+ newdoc protocols/skype/README README-skype
+ fi
+
+ doman doc/bitlbee.8 doc/bitlbee.conf.5
+
+ if use xinetd ; then
+ insinto /etc/xinetd.d
+ newins doc/bitlbee.xinetd bitlbee
+ fi
+
+ newinitd "${FILESDIR}"/bitlbee.initd-r1 bitlbee
+ newconfd "${FILESDIR}"/bitlbee.confd-r1 bitlbee
+
+ exeinto /usr/share/bitlbee
+ cd utils
+ doexe convert_purple.py bitlbee-ctl.pl
+}
+
+pkg_postinst() {
+ chown -R bitlbee:bitlbee "${ROOT}"/var/lib/bitlbee
+ [[ -d "${ROOT}"/var/run/bitlbee ]] &&
+ chown -R bitlbee:bitlbee "${ROOT}"/var/run/bitlbee
+
+ einfo
+ elog "The bitlbee init script will now attempt to stop all processes owned by the"
+ elog "bitlbee user, including per-client forks."
+ elog
+ elog "Tell the init script not to touch anything besides the main bitlbee process"
+ elog "by changing the BITLBEE_STOP_ALL variable in"
+ elog " /etc/conf.d/bitlbee"
+ einfo
+}