summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin McCarthy <signals@gentoo.org>2011-03-21 17:04:44 +0000
committerKevin McCarthy <signals@gentoo.org>2011-03-21 17:04:44 +0000
commit74d2cec97c5020a6c1d9a90258fac410b78cb494 (patch)
treefb9729d404fd6db09e8e73cff2dc7e4b7db81cdb /net-im/ekg
parentppc/ppc64 stable wrt #352532 (diff)
downloadgentoo-2-74d2cec97c5020a6c1d9a90258fac410b78cb494.tar.gz
gentoo-2-74d2cec97c5020a6c1d9a90258fac410b78cb494.tar.bz2
gentoo-2-74d2cec97c5020a6c1d9a90258fac410b78cb494.zip
Respect LDFLAGS #333797. Drop invalid threads use flag. Remove unrecognized configure flags. Use libgif instead of libungif. Add missing prototypes.
(Portage version: 2.2.0_alpha27/cvs/Linux x86_64)
Diffstat (limited to 'net-im/ekg')
-rw-r--r--net-im/ekg/ChangeLog9
-rw-r--r--net-im/ekg/ekg-1.8_rc1-r1.ebuild74
-rw-r--r--net-im/ekg/files/ekg-1.8_rc1-libgif.patch49
-rw-r--r--net-im/ekg/files/ekg-1.8_rc1-missing-prototypes.patch14
4 files changed, 145 insertions, 1 deletions
diff --git a/net-im/ekg/ChangeLog b/net-im/ekg/ChangeLog
index 90d84514eb77..798a1df61bfc 100644
--- a/net-im/ekg/ChangeLog
+++ b/net-im/ekg/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/ekg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ChangeLog,v 1.46 2011/03/02 19:54:53 signals Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ChangeLog,v 1.47 2011/03/21 17:04:44 signals Exp $
+
+*ekg-1.8_rc1-r1 (21 Mar 2011)
+
+ 21 Mar 2011; Kevin McCarthy <signals@gentoo.org> +ekg-1.8_rc1-r1.ebuild,
+ +files/ekg-1.8_rc1-libgif.patch, +files/ekg-1.8_rc1-missing-prototypes.patch:
+ Respect LDFLAGS #333797. Drop invalid threads use flag. Remove unrecognized
+ configure flags. Use libgif instead of libungif. Add missing prototypes.
02 Mar 2011; Kevin McCarthy <signals@gentoo.org> ekg-1.8_rc1.ebuild:
Slotted gtk+ depend and EAPI=2 bump to support it.
diff --git a/net-im/ekg/ekg-1.8_rc1-r1.ebuild b/net-im/ekg/ekg-1.8_rc1-r1.ebuild
new file mode 100644
index 000000000000..47f3732dafd7
--- /dev/null
+++ b/net-im/ekg/ekg-1.8_rc1-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ekg-1.8_rc1-r1.ebuild,v 1.1 2011/03/21 17:04:44 signals Exp $
+
+EAPI=2
+inherit autotools eutils
+
+IUSE="gif gtk jpeg ncurses python readline spell ssl zlib"
+
+DESCRIPTION="EKG (Eksperymentalny Klient Gadu-Gadu) - a text client for Polish instant messaging system Gadu-Gadu"
+HOMEPAGE="http://ekg.chmurka.net/"
+SRC_URI="http://ekg.chmurka.net/${P/_/}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+
+S="${WORKDIR}/${P/_/}"
+
+RDEPEND="net-libs/libgadu
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ ncurses? ( sys-libs/ncurses )
+ readline? ( sys-libs/readline )
+ zlib? ( sys-libs/zlib )
+ python? ( dev-lang/python )
+ spell? ( >=app-text/aspell-0.50.3 )
+ gif? ( media-libs/giflib )
+ jpeg? ( virtual/jpeg )
+ gtk? ( x11-libs/gtk+:2 )"
+
+DEPEND=">=sys-devel/automake-1.7
+ >=sys-devel/autoconf-2.50
+ ${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/"${P}-gtkutil-button-decl.patch \
+ "${FILESDIR}/"${P}-as-needed.patch \
+ "${FILESDIR}/"${P}-gtk.patch \
+ "${FILESDIR}/"${P}-libgif.patch \
+ "${FILESDIR}/"${P}-missing-prototypes.patch
+ sed -i -e 's/ioctld.c -o/$(LDFLAGS) ioctld.c -o/' \
+ src/Makefile.in || die #333797
+ eautoreconf
+}
+
+src_configure() {
+ local myconf="--enable-ioctld" # --disable-static --enable-dynamic"
+ if use ncurses; then
+ myconf="$myconf --enable-force-ncurses"
+ else
+ myconf="$myconf --disable-ui-ncurses"
+ fi
+ use readline && myconf="$myconf --enable-ui-readline"
+
+ econf ${myconf} \
+ `use_with python` \
+ `use_with jpeg libjpeg` \
+ `use_with zlib` \
+ `use_with gif libgif` \
+ `use_enable spell aspell` \
+ `use_with ssl openssl` \
+ `use_enable ssl openssl` \
+ `use_enable gtk ui-gtk` \
+ || die
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc docs/{*.txt,ULOTKA,TODO,README,FAQ}
+}
diff --git a/net-im/ekg/files/ekg-1.8_rc1-libgif.patch b/net-im/ekg/files/ekg-1.8_rc1-libgif.patch
new file mode 100644
index 000000000000..19ad65b9b0ee
--- /dev/null
+++ b/net-im/ekg/files/ekg-1.8_rc1-libgif.patch
@@ -0,0 +1,49 @@
+Use libgif instead of libungif
+
+Patch by Kevin McCarthy <signals@gentoo.org>
+
+--- configure.in
++++ configure.in
+@@ -286,20 +286,20 @@
+ fi
+
+ dnl
+-dnl Sprawdzamy libungif.so i <gif_lib.h>
++dnl Sprawdzamy libgif.so i <gif_lib.h>
+ dnl
+
+-AC_ARG_WITH(libungif,
+- [ --without-libungif Compile without GIF token support])
++AC_ARG_WITH(libgif,
++ [ --without-libgif Compile without GIF token support])
+
+-if test "x$with_libungif" != "xno"; then
+- AC_CHECK_LIB(ungif, DGifSlurp,
++if test "x$with_libgif" != "xno"; then
++ AC_CHECK_LIB(gif, DGifSlurp,
+ [
+ AC_CHECK_HEADERS(gif_lib.h,
+ [
+- AC_DEFINE(HAVE_LIBUNGIF, 1, [define if you have libungif])
+- LIBS="$LIBS -lungif"
+- have_libungif=yes
++ AC_DEFINE(HAVE_LIBUNGIF, 1, [define if you have libgif])
++ LIBS="$LIBS -lgif"
++ have_libgif=yes
+ ])
+ ])
+ fi
+@@ -478,10 +478,10 @@
+ echo " - zlib: disabled"
+ fi
+
+-if test "x$have_libungif" = "xyes"; then
+- echo " - libungif: enabled"
++if test "x$have_libgif" = "xyes"; then
++ echo " - libgif: enabled"
+ else
+- echo " - libungif: disabled"
++ echo " - libgif: disabled"
+ fi
+
+ if test "x$have_libjpeg" = "xyes"; then
diff --git a/net-im/ekg/files/ekg-1.8_rc1-missing-prototypes.patch b/net-im/ekg/files/ekg-1.8_rc1-missing-prototypes.patch
new file mode 100644
index 000000000000..796a61c653c5
--- /dev/null
+++ b/net-im/ekg/files/ekg-1.8_rc1-missing-prototypes.patch
@@ -0,0 +1,14 @@
+Add missing prototypes so compile doesn't complain.
+
+Patch by Kevin McCarthy <signals@gentoo.org>
+
+--- src/ui-gtk.h
++++ src/ui-gtk.h
+@@ -131,4 +131,7 @@
+
+ int key_handle_key_press(GtkWidget *wid, GdkEventKey *evt, window_t *sess);
+
++void mg_changui_new(window_t *sess, int tab, int focus);
++void fe_close_window(window_t *sess);
++
+ #endif