summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2006-07-08 01:00:04 +0000
committerGustavo Felisberto <humpback@gentoo.org>2006-07-08 01:00:04 +0000
commit3ef5fd32a6c94ed6803a3cbe7983518c45004a9a (patch)
tree9dff16b0964aec24474b4df4ed9749b37d41ab4c /net-im/gajim
parentmask net-wireless/aircrack, it is pending removal in favor of net-wireless/ai... (diff)
downloadgentoo-2-3ef5fd32a6c94ed6803a3cbe7983518c45004a9a.tar.gz
gentoo-2-3ef5fd32a6c94ed6803a3cbe7983518c45004a9a.tar.bz2
gentoo-2-3ef5fd32a6c94ed6803a3cbe7983518c45004a9a.zip
added makefile patch
(Portage version: 2.1.1_pre2-r4)
Diffstat (limited to 'net-im/gajim')
-rw-r--r--net-im/gajim/ChangeLog7
-rw-r--r--net-im/gajim/files/gajim-10.1-Makefile.patch13
-rw-r--r--net-im/gajim/gajim-0.10.1.ebuild16
3 files changed, 26 insertions, 10 deletions
diff --git a/net-im/gajim/ChangeLog b/net-im/gajim/ChangeLog
index 9974da6b9d7a..27bb7f6d6f9d 100644
--- a/net-im/gajim/ChangeLog
+++ b/net-im/gajim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/gajim
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.17 2006/07/07 05:46:39 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.18 2006/07/08 01:00:04 humpback Exp $
+
+ 08 Jul 2006; Gustavo Felisberto <humpback@gentoo.org>;
+ +files/gajim-10.1-Makefile.patch, gajim-0.10.1.ebuild:
+ Fixed problem with Makefile (thanks to Dimitur Kirov in bug #139446) and
+ removed psyco reference as gajim nolonger makes use of it.
07 Jul 2006; Michael Sterrett <mr_bones_@gentoo.org> gajim-0.10.1.ebuild:
fix dep typo
diff --git a/net-im/gajim/files/gajim-10.1-Makefile.patch b/net-im/gajim/files/gajim-10.1-Makefile.patch
new file mode 100644
index 000000000000..9fa724efe8b0
--- /dev/null
+++ b/net-im/gajim/files/gajim-10.1-Makefile.patch
@@ -0,0 +1,13 @@
+--- Makefile.orig 2006-07-07 12:35:52.000000000 +0300
++++ Makefile 2006-07-07 13:00:35.000000000 +0300
+@@ -87,7 +87,9 @@
+ mkdir -p "$(DESTDIR)$(PREFIX)/share/locale/$$d"; \
+ fi; \
+ done
+- ${MAKE} -C po install PREFIX=$(PREFIX)
++ if [[ -n $$(find po -name *.mo) ]]; then \
++ ${MAKE} -C po install PREFIX=$(PREFIX) ; \
++ fi
+ cp COPYING "$(DESTDIR)$(PREFIX)/share/gajim/";
+ cp THANKS "$(DESTDIR)$(PREFIX)/share/gajim/";
+ mkdir -p "$(DESTDIR)$(PREFIX)/share/pixmaps";
diff --git a/net-im/gajim/gajim-0.10.1.ebuild b/net-im/gajim/gajim-0.10.1.ebuild
index 46fc4f9edf11..83e3a5b31260 100644
--- a/net-im/gajim/gajim-0.10.1.ebuild
+++ b/net-im/gajim/gajim-0.10.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.10.1.ebuild,v 1.4 2006/07/07 05:46:39 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.10.1.ebuild,v 1.5 2006/07/08 01:00:04 humpback Exp $
inherit virtualx multilib eutils
@@ -37,6 +37,12 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gajim-10.1-Makefile.patch
+}
+
src_compile() {
targets="idle gajim.desktop"
! use gnome && targets="${targets} trayicon"
@@ -51,13 +57,6 @@ src_install() {
}
pkg_postinst() {
- if use x86; then
- einfo "If you want to make Gajim run faster,"
- einfo "emerge dev-python/psyco, an extension"
- einfo "module which can speed up the execution"
- einfo "of Python code."
- fi
-
if use amd64; then
ewarn
ewarn "Because of an unresolved segmentation fault,"
@@ -70,5 +69,4 @@ pkg_postinst() {
ewarn "Please see bug #109298."
ewarn
fi
-
}