summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-06-27 16:31:32 +0000
committerMichael Januszewski <spock@gentoo.org>2004-06-27 16:31:32 +0000
commita2871effafcfef05e60d1edeba0e591181586566 (patch)
tree335a8f5957ab8f0a19f0bbdb46b41d507f55256d /net-im/gnugadu
parentppc stable (Manifest recommit) (diff)
downloadgentoo-2-a2871effafcfef05e60d1edeba0e591181586566.tar.gz
gentoo-2-a2871effafcfef05e60d1edeba0e591181586566.tar.bz2
gentoo-2-a2871effafcfef05e60d1edeba0e591181586566.zip
Fixed borken arts support.
Diffstat (limited to 'net-im/gnugadu')
-rw-r--r--net-im/gnugadu/ChangeLog7
-rw-r--r--net-im/gnugadu/gnugadu-2.0.1.ebuild6
-rw-r--r--net-im/gnugadu/gnugadu-2.0.2.ebuild6
-rw-r--r--net-im/gnugadu/gnugadu-2.0.3.ebuild6
-rw-r--r--net-im/gnugadu/gnugadu-2.0.ebuild6
5 files changed, 26 insertions, 5 deletions
diff --git a/net-im/gnugadu/ChangeLog b/net-im/gnugadu/ChangeLog
index 6907fd1e7fa9..c5a83247a836 100644
--- a/net-im/gnugadu/ChangeLog
+++ b/net-im/gnugadu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/gnugadu
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/ChangeLog,v 1.13 2004/06/24 22:52:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/ChangeLog,v 1.14 2004/06/27 16:31:32 spock Exp $
+
+ 27 Jun 2004; Michal Januszewski <spock@gentoo.org> gnugadu-2.0.1.ebuild,
+ gnugadu-2.0.2.ebuild, gnugadu-2.0.3.ebuild, gnugadu-2.0.ebuild:
+ Fixed broken arts support. This closes bug #55161. Thanks to Marcin Kryczek
+ for the fix.
*gnugadu-2.0.3 (12 Jun 2004)
diff --git a/net-im/gnugadu/gnugadu-2.0.1.ebuild b/net-im/gnugadu/gnugadu-2.0.1.ebuild
index 55ae8e27fab1..66a91172c252 100644
--- a/net-im/gnugadu/gnugadu-2.0.1.ebuild
+++ b/net-im/gnugadu/gnugadu-2.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/gnugadu-2.0.1.ebuild,v 1.3 2004/06/24 22:52:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/gnugadu-2.0.1.ebuild,v 1.4 2004/06/27 16:31:32 spock Exp $
IUSE="debug tlen esd oss xosd arts jabber perl"
@@ -30,6 +30,10 @@ src_compile() {
myconf="--with-gui --with-gadu --with-remote --with-docklet_system_tray --with-docklet_dockapp --with-sms --with-update --with-external"
# use spell && myconf="${myconf} --with-gtkspell"
+ if [ `use arts` ]; then
+ myconf="${myconf} --with-arts --with-arts-prefix=`artsc-config --arts-prefix`"
+ fi
+
econf ${myconf} \
`use_enable debug` \
`use_with oss` \
diff --git a/net-im/gnugadu/gnugadu-2.0.2.ebuild b/net-im/gnugadu/gnugadu-2.0.2.ebuild
index 3ec40beceb5f..46a5f28ba0f1 100644
--- a/net-im/gnugadu/gnugadu-2.0.2.ebuild
+++ b/net-im/gnugadu/gnugadu-2.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/gnugadu-2.0.2.ebuild,v 1.2 2004/06/24 22:52:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/gnugadu-2.0.2.ebuild,v 1.3 2004/06/27 16:31:32 spock Exp $
IUSE="debug tlen esd oss xosd arts jabber perl"
@@ -30,6 +30,10 @@ src_compile() {
myconf="--with-gui --with-gadu --with-remote --with-docklet_system_tray --with-docklet_dockapp --with-sms --with-update --with-external"
# use spell && myconf="${myconf} --with-gtkspell"
+ if [ `use arts` ]; then
+ myconf="${myconf} --with-arts --with-arts-prefix=`artsc-config --arts-prefix`"
+ fi
+
econf ${myconf} \
`use_enable debug` \
`use_with oss` \
diff --git a/net-im/gnugadu/gnugadu-2.0.3.ebuild b/net-im/gnugadu/gnugadu-2.0.3.ebuild
index 7559e5910588..0727eeb46a77 100644
--- a/net-im/gnugadu/gnugadu-2.0.3.ebuild
+++ b/net-im/gnugadu/gnugadu-2.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/gnugadu-2.0.3.ebuild,v 1.2 2004/06/24 22:52:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/gnugadu-2.0.3.ebuild,v 1.3 2004/06/27 16:31:32 spock Exp $
IUSE="debug tlen esd oss xosd arts jabber perl"
@@ -30,6 +30,10 @@ src_compile() {
myconf="--with-gui --with-gadu --with-remote --with-docklet_system_tray --with-docklet_dockapp --with-sms --with-update --with-external"
# use spell && myconf="${myconf} --with-gtkspell"
+ if [ `use arts` ]; then
+ myconf="${myconf} --with-arts --with-arts-prefix=`artsc-config --arts-prefix`"
+ fi
+
econf ${myconf} \
`use_enable debug` \
`use_with oss` \
diff --git a/net-im/gnugadu/gnugadu-2.0.ebuild b/net-im/gnugadu/gnugadu-2.0.ebuild
index 26b7d562ba6d..dc8d48799835 100644
--- a/net-im/gnugadu/gnugadu-2.0.ebuild
+++ b/net-im/gnugadu/gnugadu-2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/gnugadu-2.0.ebuild,v 1.4 2004/06/24 22:52:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/gnugadu-2.0.ebuild,v 1.5 2004/06/27 16:31:32 spock Exp $
IUSE="debug tlen esd oss xosd arts jabber perl"
@@ -30,6 +30,10 @@ src_compile() {
myconf="--with-gui --with-gadu --with-remote --with-docklet_system_tray --with-docklet_dockapp --with-sms --with-update --with-external"
# use spell && myconf="${myconf} --with-gtkspell"
+ if [ `use arts` ]; then
+ myconf="${myconf} --with-arts --with-arts-prefix=`artsc-config --arts-prefix`"
+ fi
+
econf ${myconf} \
`use_enable debug` \
`use_with oss` \