summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-01-26 22:51:57 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-01-26 22:51:57 +0000
commitf762d376f683da15407a899eadbab04e19b046c6 (patch)
tree9e485a04ec76b98658f03d587cc706c8c8ece454 /net-im/imcom
parentunmask metalog. works well :) (diff)
downloadgentoo-2-f762d376f683da15407a899eadbab04e19b046c6.tar.gz
gentoo-2-f762d376f683da15407a899eadbab04e19b046c6.tar.bz2
gentoo-2-f762d376f683da15407a899eadbab04e19b046c6.zip
jabber client (cli), initial ebuild
Diffstat (limited to 'net-im/imcom')
-rw-r--r--net-im/imcom/files/digest-imcom-0.921
-rw-r--r--net-im/imcom/imcom-0.92.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/net-im/imcom/files/digest-imcom-0.92 b/net-im/imcom/files/digest-imcom-0.92
new file mode 100644
index 000000000000..de1bb731400b
--- /dev/null
+++ b/net-im/imcom/files/digest-imcom-0.92
@@ -0,0 +1 @@
+MD5 a2b3147092566211a555966039d743c2 imcom-0.92.tar.gz 225280
diff --git a/net-im/imcom/imcom-0.92.ebuild b/net-im/imcom/imcom-0.92.ebuild
new file mode 100644
index 000000000000..f689e72d279d
--- /dev/null
+++ b/net-im/imcom/imcom-0.92.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bart Verwilst <verwilst@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-im/imcom/imcom-0.92.ebuild,v 1.1 2002/01/26 22:51:57 verwilst Exp $
+
+S=${WORKDIR}/${P}
+
+DEPEND=">=dev-lang/python-2.2
+ >=dev-python/PyXML-0.7"
+
+SRC_URI="http://imcom.floobin.cx/files/${P}.tar.gz"
+HOMEPAGE="http://imcom.floobin.cx"
+DESCRIPTION="Python commandline Jabber Client"
+
+src_install() {
+
+ cd ${S}
+ mkdir -p ${D}/usr/bin
+ mkdir -p ${D}/usr/share/imcom
+ mkdir -p ${D}/usr/share/imcom/docs
+ cp AutoStatus.API CONTRIBUTORS LICENSE README README.autostatus TODO WHATSNEW ${D}/usr/share/imcom/docs
+ cp docs/* ${D}/usr/share/imcom/docs
+ cp *.py ${D}/usr/share/imcom
+ mv imcom imcom.orig
+ sed -e 's:/usr/local/share:/usr/share:' imcom.orig | cat > imcom
+ chmod 755 imcom
+ cp imcom ${D}/usr/bin
+
+}