summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2009-07-25 19:42:22 +0000
committerMark Loeser <halcy0n@gentoo.org>2009-07-25 19:42:22 +0000
commit10b206dc74d466857d306edc2b5233c6208ea2c5 (patch)
tree347ca56cf6ef6495db40e79191d227a81c8f3194 /net-im/kadu
parentPunt BMPx (diff)
downloadgentoo-2-10b206dc74d466857d306edc2b5233c6208ea2c5.tar.gz
gentoo-2-10b206dc74d466857d306edc2b5233c6208ea2c5.tar.bz2
gentoo-2-10b206dc74d466857d306edc2b5233c6208ea2c5.zip
Add patch to fix compilation with gcc-4.4; bug #276510
(Portage version: 2.2_rc33-r1/cvs/Linux i686)
Diffstat (limited to 'net-im/kadu')
-rw-r--r--net-im/kadu/ChangeLog6
-rw-r--r--net-im/kadu/files/kadu-0.6.5.2-gcc44.patch34
-rw-r--r--net-im/kadu/kadu-0.6.5.2-r2.ebuild3
3 files changed, 41 insertions, 2 deletions
diff --git a/net-im/kadu/ChangeLog b/net-im/kadu/ChangeLog
index 53060a9fbb3f..0f2e19dcbd2e 100644
--- a/net-im/kadu/ChangeLog
+++ b/net-im/kadu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/kadu
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kadu/ChangeLog,v 1.77 2009/06/05 17:45:33 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kadu/ChangeLog,v 1.78 2009/07/25 19:42:22 halcy0n Exp $
+
+ 25 Jul 2009; Mark Loeser <halcy0n@gentoo.org> kadu-0.6.5.2-r2.ebuild,
+ +files/kadu-0.6.5.2-gcc44.patch:
+ Add patch to fix compilation with gcc-4.4; bug #276510
05 Jun 2009; Theo Chatzimichos <tampakrap@gentoo.org> kadu-0.6.5.1.ebuild,
kadu-0.6.5.2.ebuild, kadu-0.6.5.2-r2.ebuild:
diff --git a/net-im/kadu/files/kadu-0.6.5.2-gcc44.patch b/net-im/kadu/files/kadu-0.6.5.2-gcc44.patch
new file mode 100644
index 000000000000..868dd3a5165f
--- /dev/null
+++ b/net-im/kadu/files/kadu-0.6.5.2-gcc44.patch
@@ -0,0 +1,34 @@
+--- branches/0.6.5/kadu-core/protocol.h 2009/05/14 16:31:06 6636
++++ branches/0.6.5/kadu-core/protocol.h 2009/05/14 16:32:15 6637
+@@ -4,9 +4,9 @@
+ #include <QtCore/QDateTime>
+ #include <QtCore/QObject>
+
+-#ifdef __sun__
++#if defined(__sun__ ) || defined(__linux__)
+ #include <sys/types.h>
+-#endif /* __sun__ */
++#endif /* __sun__ || __linux__ */
+
+ #ifdef _MSC_VER
+ #include "kinttypes.h"
+--- branches/0.6.5/kadu-core/protocol.h 2008/09/25 20:10:18 5602
++++ branches/0.6.5/kadu-core/protocol.h 2009/04/24 21:11:43 6584
+@@ -14,6 +14,7 @@
+
+ #include "status.h"
+ #include "usergroup.h"
++#include <stdint.h>
+
+ typedef uint32_t UinType;
+
+--- branches/0.6.5//modules/encryption/pkcs1_certificate.h 2009-07-25 15:26:05.000000000 -0400
++++ branches/0.6.5/modules/encryption/pkcs1_certificate.h 2009-07-25 15:26:27.000000000 -0400
+@@ -26,6 +26,7 @@
+ #define PKCS1_CERTIFICATE_H
+
+ #include <QtCrypto>
++#include <stdint.h>
+
+ /**
+ * PKCS#1 certificate reader/writer (implemented according to the PKCS#1 v2.1 Specification).
diff --git a/net-im/kadu/kadu-0.6.5.2-r2.ebuild b/net-im/kadu/kadu-0.6.5.2-r2.ebuild
index 4b74b2684995..7d6ade430c8d 100644
--- a/net-im/kadu/kadu-0.6.5.2-r2.ebuild
+++ b/net-im/kadu/kadu-0.6.5.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kadu/kadu-0.6.5.2-r2.ebuild,v 1.2 2009/06/05 17:45:33 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kadu/kadu-0.6.5.2-r2.ebuild,v 1.3 2009/07/25 19:42:22 halcy0n Exp $
EAPI="2"
inherit base cmake-utils flag-o-matic
@@ -43,6 +43,7 @@ S="${WORKDIR}/${PN}"
PATCHES=(
"${FILESDIR}/libgsm-ugly-code.patch"
+ "${FILESDIR}/${P}-gcc44.patch"
)
# set given .config variable to =m or =y