summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-12-25 16:41:21 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-12-25 16:41:21 +0000
commitfe0c77964a9f7b591776f4f8752f471e420d2c15 (patch)
tree693dc2cd9419abd0bba51c2311b21d1ae40196e0 /net-im/leechcraft-azoth
parentBump LeechCraft to 0.5.90, thanks to 0xd34df00d (diff)
downloadgentoo-2-fe0c77964a9f7b591776f4f8752f471e420d2c15.tar.gz
gentoo-2-fe0c77964a9f7b591776f4f8752f471e420d2c15.tar.bz2
gentoo-2-fe0c77964a9f7b591776f4f8752f471e420d2c15.zip
Bump LeechCraft to 0.5.90, thanks to 0xd34df00d
(Portage version: 2.1.11.38/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'net-im/leechcraft-azoth')
-rw-r--r--net-im/leechcraft-azoth/ChangeLog8
-rw-r--r--net-im/leechcraft-azoth/leechcraft-azoth-0.5.90.ebuild87
2 files changed, 94 insertions, 1 deletions
diff --git a/net-im/leechcraft-azoth/ChangeLog b/net-im/leechcraft-azoth/ChangeLog
index 863317ebaafc..12f2a887901e 100644
--- a/net-im/leechcraft-azoth/ChangeLog
+++ b/net-im/leechcraft-azoth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/leechcraft-azoth
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/leechcraft-azoth/ChangeLog,v 1.38 2012/12/19 07:56:01 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/leechcraft-azoth/ChangeLog,v 1.39 2012/12/25 16:41:21 maksbotan Exp $
+
+*leechcraft-azoth-0.5.90 (25 Dec 2012)
+
+ 25 Dec 2012; Maxim Koltsov <maksbotan@gentoo.org>
+ +leechcraft-azoth-0.5.90.ebuild:
+ Bump LeechCraft to 0.5.90, thanks to 0xd34df00d
19 Dec 2012; Maxim Koltsov <maksbotan@gentoo.org>
-leechcraft-azoth-0.5.70.ebuild, -leechcraft-azoth-0.5.75-r1.ebuild,
diff --git a/net-im/leechcraft-azoth/leechcraft-azoth-0.5.90.ebuild b/net-im/leechcraft-azoth/leechcraft-azoth-0.5.90.ebuild
new file mode 100644
index 000000000000..1b96ce9626d1
--- /dev/null
+++ b/net-im/leechcraft-azoth/leechcraft-azoth-0.5.90.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/leechcraft-azoth/leechcraft-azoth-0.5.90.ebuild,v 1.1 2012/12/25 16:41:21 maksbotan Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="Azoth, the modular IM client for LeechCraft."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug astrality +acetamide +adiumstyles +autoidler +autopaste +birthdaynotifier
+ +chathistory +crypt +depester +embedmedia +herbicide +hili +isterique
+ +juick +keeso +lastseen +metacontacts media +msn +latex +nativeemoticons
+ +otroid +p100q +spell shx +standardstyles +xmpp +xtazy"
+
+DEPEND="~net-misc/leechcraft-core-${PV}
+ x11-libs/qt-webkit:4
+ x11-libs/qt-multimedia:4
+ autoidler? ( x11-libs/libXScrnSaver )
+ astrality? ( net-libs/telepathy-qt )
+ otroid? ( net-libs/libotr )
+ media? ( x11-libs/qt-multimedia:4 )
+ msn? ( net-libs/libmsn )
+ spell? ( app-text/hunspell )
+ xmpp? ( =net-libs/qxmpp-0.7* media-libs/speex )
+ xtazy? ( x11-libs/qt-dbus:4 )
+ crypt? ( app-crypt/qca app-crypt/qca-gnupg )"
+RDEPEND="${DEPEND}
+ astrality? (
+ net-im/telepathy-mission-control
+ net-voip/telepathy-haze
+ )
+ latex? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )"
+
+REQUIRED_USE="|| ( standardstyles adiumstyles )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable crypt CRYPT)
+ $(cmake-utils_use_enable acetamide AZOTH_ACETAMIDE)
+ $(cmake-utils_use_enable adiumstyles AZOTH_ADIUMSTYLES)
+ $(cmake-utils_use_enable astrality AZOTH_ASTRALITY)
+ $(cmake-utils_use_enable autoidler AZOTH_AUTOIDLER)
+ $(cmake-utils_use_enable autopaste AZOTH_AUTOPASTE)
+ $(cmake-utils_use_enable birthdaynotifier AZOTH_BIRTHDAYNOTIFIER)
+ $(cmake-utils_use_enable chathistory AZOTH_CHATHISTORY)
+ $(cmake-utils_use_enable depester AZOTH_DEPESTER)
+ $(cmake-utils_use_enable embedmedia AZOTH_EMBEDMEDIA)
+ $(cmake-utils_use_enable herbicide AZOTH_HERBICIDE)
+ $(cmake-utils_use_enable hili AZOTH_HILI)
+ $(cmake-utils_use_enable isterique AZOTH_ISTERIQUE)
+ $(cmake-utils_use_enable juick AZOTH_JUICK)
+ $(cmake-utils_use_enable keeso AZOTH_KEESO)
+ $(cmake-utils_use_enable lastseen AZOTH_LASTSEEN)
+ $(cmake-utils_use_enable metacontacts AZOTH_LASTSEEN)
+ $(cmake-utils_use_enable media MEDIACALLS)
+ $(cmake-utils_use_enable latex AZOTH_MODNOK)
+ $(cmake-utils_use_enable msn AZOTH_ZHEET)
+ $(cmake-utils_use_enable nativeemoticons AZOTH_NATIVEEMOTICONS)
+ $(cmake-utils_use_enable otroid AZOTH_OTROID)
+ $(cmake-utils_use_enable p100q AZOTH_P100Q)
+ $(cmake-utils_use_enable spell AZOTH_ROSENTHAL)
+ $(cmake-utils_use_enable shx AZOTH_SHX)
+ $(cmake-utils_use_enable standardstyles AZOTH_STANDARDSTYLES)
+ $(cmake-utils_use_enable xmpp AZOTH_XOOX)
+ $(cmake-utils_use_enable xtazy AZOTH_XTAZY)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if use spell; then
+ elog "You have enabled the Azoth Rosenthal plugin for"
+ elog "spellchecking. It uses Hunspell/Myspell dictionaries,"
+ elog "so install the ones for languages you use to enable"
+ elog "spellchecking."
+ fi
+}