summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2010-05-06 11:31:20 +0000
committerWolfram Schlich <wschlich@gentoo.org>2010-05-06 11:31:20 +0000
commite9211912d0b8dbeb921219f0ab9ea9b624ae5223 (patch)
tree87ded42e7f616d3cb8352bf7dc76af78a66c5654 /net-im/mcabber
parentFix building with GCC 4.5+ wrt #318585 by Kacper Kowalik. (diff)
downloadgentoo-2-e9211912d0b8dbeb921219f0ab9ea9b624ae5223.tar.gz
gentoo-2-e9211912d0b8dbeb921219f0ab9ea9b624ae5223.tar.bz2
gentoo-2-e9211912d0b8dbeb921219f0ab9ea9b624ae5223.zip
version bump, removed some old versions
(Portage version: 2.2_rc60/cvs/Linux i686)
Diffstat (limited to 'net-im/mcabber')
-rw-r--r--net-im/mcabber/ChangeLog10
-rw-r--r--net-im/mcabber/mcabber-0.10.0.ebuild (renamed from net-im/mcabber/mcabber-0.9.9-r1.ebuild)31
-rw-r--r--net-im/mcabber/mcabber-0.9.6.ebuild94
-rw-r--r--net-im/mcabber/mcabber-0.9.9.ebuild94
4 files changed, 24 insertions, 205 deletions
diff --git a/net-im/mcabber/ChangeLog b/net-im/mcabber/ChangeLog
index 28714e630203..4c5093500a71 100644
--- a/net-im/mcabber/ChangeLog
+++ b/net-im/mcabber/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/mcabber
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/ChangeLog,v 1.48 2009/11/05 07:47:04 wschlich Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/ChangeLog,v 1.49 2010/05/06 11:31:20 wschlich Exp $
+
+*mcabber-0.10.0 (06 May 2010)
+
+ 06 May 2010; Wolfram Schlich <wschlich@gentoo.org> -mcabber-0.9.6.ebuild,
+ -mcabber-0.9.9.ebuild, -mcabber-0.9.9-r1.ebuild, +mcabber-0.10.0.ebuild:
+ version bump, removed some old versions
*mcabber-0.9.10 (04 Nov 2009)
diff --git a/net-im/mcabber/mcabber-0.9.9-r1.ebuild b/net-im/mcabber/mcabber-0.10.0.ebuild
index a8ea975e5d69..8f13bb17ce55 100644
--- a/net-im/mcabber/mcabber-0.9.9-r1.ebuild
+++ b/net-im/mcabber/mcabber-0.10.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/mcabber-0.9.9-r1.ebuild,v 1.7 2009/09/30 17:32:23 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/mcabber-0.10.0.ebuild,v 1.1 2010/05/06 11:31:20 wschlich Exp $
+
+EAPI="2"
inherit flag-o-matic
@@ -10,7 +12,7 @@ SRC_URI="http://mcabber.com/files/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 ~mips ppc ppc64 sparc x86"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="crypt otr spell ssl"
@@ -20,8 +22,9 @@ for i in ${LANGS}; do
IUSE="${IUSE} linguas_${i}"
done;
-RDEPEND="ssl? ( >=dev-libs/openssl-0.9.7-r1 )
+RDEPEND="ssl? ( net-libs/loudmouth[ssl] )
crypt? ( >=app-crypt/gpgme-1.0.0 )
+ >=net-libs/loudmouth-1.4.3
otr? ( >=net-libs/libotr-3.1.0 )
spell? ( app-text/aspell )
>=dev-libs/glib-2.0.0
@@ -30,15 +33,21 @@ RDEPEND="ssl? ( >=dev-libs/openssl-0.9.7-r1 )
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-src_compile() {
+src_prepare() {
use crypt && append-flags -D_FILE_OFFSET_BITS=64 # bug #277888
+ append-flags -fno-strict-aliasing
+}
+
+src_configure() {
econf \
+ --enable-modules \
$(use_enable crypt gpgme) \
$(use_enable otr) \
$(use_enable spell aspell) \
- $(use_with ssl) \
|| die "econf failed"
+}
+src_compile() {
emake || die "emake failed"
}
@@ -58,7 +67,7 @@ src_install() {
# contrib generic scripts
exeinto /usr/share/${PN}/scripts
- doexe "${S}"/contrib/*.{pl,py,rb}
+ doexe "${S}"/contrib/*.{pl,py}
# contrib event scripts
exeinto /usr/share/${PN}/scripts/events
@@ -78,14 +87,6 @@ pkg_postinst() {
elog
elog "Then edit ~/.mcabber/mcabberrc with your favorite editor."
elog
- elog "As of MCabber version 0.8.2, there is also a wizard script"
- elog "with which you can create all necessary configuration options."
- elog "To use it, simply execute the following command (please note that you need"
- elog "to have dev-lang/ruby installed for it to work!):"
- elog
- elog " ${ROOT}usr/share/${PN}/scripts/mcwizz.rb"
- elog
- elog
elog "See the CONFIGURATION FILE and FILES sections of the mcabber"
elog "manual page (section 1) for more information."
elog
diff --git a/net-im/mcabber/mcabber-0.9.6.ebuild b/net-im/mcabber/mcabber-0.9.6.ebuild
deleted file mode 100644
index cef5a83bbf79..000000000000
--- a/net-im/mcabber/mcabber-0.9.6.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/mcabber-0.9.6.ebuild,v 1.7 2008/05/17 15:53:16 tester Exp $
-
-DESCRIPTION="A small Jabber console client with various features, like MUC, SSL, PGP"
-HOMEPAGE="http://www.lilotux.net/~mikael/mcabber/"
-SRC_URI="http://www.lilotux.net/~mikael/${PN}/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~mips ppc ppc64 sparc x86"
-
-IUSE="crypt otr spell ssl"
-
-LANGS="de en fr nl pl uk ru"
-# localized help versions are installed only, when LINGUAS var is set
-for i in ${LANGS}; do
- IUSE="${IUSE} linguas_${i}"
-done;
-
-RDEPEND="ssl? ( >=dev-libs/openssl-0.9.7-r1 )
- crypt? ( >=app-crypt/gpgme-1.0.0 )
- otr? ( >=net-libs/libotr-3.1.0 )
- spell? ( app-text/aspell )
- >=dev-libs/glib-2.0.0
- sys-libs/ncurses"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_compile() {
- econf \
- $(use_enable crypt gpgme) \
- $(use_enable otr) \
- $(use_enable spell aspell) \
- $(use_with ssl) \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die "make install failed"
- # clean unneeded language documentation
- for i in ${LANGS}; do
- ! use linguas_${i} && rm -rf "${D}"/usr/share/${PN}/help/${i}
- done
-
- dodoc AUTHORS ChangeLog NEWS README TODO mcabberrc.example
- dodoc doc/README_PGP.txt
-
- # contrib themes
- insinto /usr/share/${PN}/themes
- doins "${S}"/contrib/themes/*
-
- # contrib generic scripts
- exeinto /usr/share/${PN}/scripts
- doexe "${S}"/contrib/*.{pl,py,rb}
-
- # contrib event scripts
- exeinto /usr/share/${PN}/scripts/events
- doexe "${S}"/contrib/events/*
-}
-
-pkg_postinst() {
- elog
- elog "MCabber requires you to create a subdirectory .mcabber in your home"
- elog "directory and to place a configuration file there."
- elog "An example mcabberrc was installed as part of the documentation."
- elog "To create a new mcabberrc based on the example mcabberrc, execute the"
- elog "following commands:"
- elog
- elog " mkdir -p ~/.mcabber"
- elog " bzcat ${ROOT}usr/share/doc/${PF}/mcabberrc.example.bz2 >~/.mcabber/mcabberrc"
- elog
- elog "Then edit ~/.mcabber/mcabberrc with your favorite editor."
- elog
- elog "As of MCabber version 0.8.2, there is also a wizard script"
- elog "with which you can create all necessary configuration options."
- elog "To use it, simply execute the following command (please note that you need"
- elog "to have dev-lang/ruby installed for it to work!):"
- elog
- elog " ${ROOT}usr/share/${PN}/scripts/mcwizz.rb"
- elog
- elog
- elog "See the CONFIGURATION FILE and FILES sections of the mcabber"
- elog "manual page (section 1) for more information."
- elog
- elog "From version 0.9.0 on, MCabber supports PGP encryption of messages."
- elog "See README_PGP.txt for details."
- elog
- elog "Check out ${ROOT}usr/share/${PN} for contributed themes and event scripts."
- elog
-}
diff --git a/net-im/mcabber/mcabber-0.9.9.ebuild b/net-im/mcabber/mcabber-0.9.9.ebuild
deleted file mode 100644
index 9f39d1bb29c8..000000000000
--- a/net-im/mcabber/mcabber-0.9.9.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/mcabber-0.9.9.ebuild,v 1.2 2008/12/17 21:06:41 maekke Exp $
-
-DESCRIPTION="A small Jabber console client with various features, like MUC, SSL, PGP"
-HOMEPAGE="http://www.lilotux.net/~mikael/mcabber/"
-SRC_URI="http://www.lilotux.net/~mikael/${PN}/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~mips ~ppc ~ppc64 ~sparc x86"
-
-IUSE="crypt otr spell ssl"
-
-LANGS="de en fr nl pl uk ru"
-# localized help versions are installed only, when LINGUAS var is set
-for i in ${LANGS}; do
- IUSE="${IUSE} linguas_${i}"
-done;
-
-RDEPEND="ssl? ( >=dev-libs/openssl-0.9.7-r1 )
- crypt? ( >=app-crypt/gpgme-1.0.0 )
- otr? ( >=net-libs/libotr-3.1.0 )
- spell? ( app-text/aspell )
- >=dev-libs/glib-2.0.0
- sys-libs/ncurses"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_compile() {
- econf \
- $(use_enable crypt gpgme) \
- $(use_enable otr) \
- $(use_enable spell aspell) \
- $(use_with ssl) \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die "make install failed"
- # clean unneeded language documentation
- for i in ${LANGS}; do
- ! use linguas_${i} && rm -rf "${D}"/usr/share/${PN}/help/${i}
- done
-
- dodoc AUTHORS ChangeLog NEWS README TODO mcabberrc.example
- dodoc doc/README_PGP.txt
-
- # contrib themes
- insinto /usr/share/${PN}/themes
- doins "${S}"/contrib/themes/*
-
- # contrib generic scripts
- exeinto /usr/share/${PN}/scripts
- doexe "${S}"/contrib/*.{pl,py,rb}
-
- # contrib event scripts
- exeinto /usr/share/${PN}/scripts/events
- doexe "${S}"/contrib/events/*
-}
-
-pkg_postinst() {
- elog
- elog "MCabber requires you to create a subdirectory .mcabber in your home"
- elog "directory and to place a configuration file there."
- elog "An example mcabberrc was installed as part of the documentation."
- elog "To create a new mcabberrc based on the example mcabberrc, execute the"
- elog "following commands:"
- elog
- elog " mkdir -p ~/.mcabber"
- elog " bzcat ${ROOT}usr/share/doc/${PF}/mcabberrc.example.bz2 >~/.mcabber/mcabberrc"
- elog
- elog "Then edit ~/.mcabber/mcabberrc with your favorite editor."
- elog
- elog "As of MCabber version 0.8.2, there is also a wizard script"
- elog "with which you can create all necessary configuration options."
- elog "To use it, simply execute the following command (please note that you need"
- elog "to have dev-lang/ruby installed for it to work!):"
- elog
- elog " ${ROOT}usr/share/${PN}/scripts/mcwizz.rb"
- elog
- elog
- elog "See the CONFIGURATION FILE and FILES sections of the mcabber"
- elog "manual page (section 1) for more information."
- elog
- elog "From version 0.9.0 on, MCabber supports PGP encryption of messages."
- elog "See README_PGP.txt for details."
- elog
- elog "Check out ${ROOT}usr/share/${PN} for contributed themes and event scripts."
- elog
-}