summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2012-05-22 13:57:32 +0000
committerJeremy Olexa <darkside@gentoo.org>2012-05-22 13:57:32 +0000
commitf7d48850080168f06c6cba852844ff5f42daa786 (patch)
tree2f262471214773e8fcbc3c9fb2efdf08db73287a /net-im/pidgin
parentVersion bump, bug 417079 - SA49261. (diff)
downloadgentoo-2-f7d48850080168f06c6cba852844ff5f42daa786.tar.gz
gentoo-2-f7d48850080168f06c6cba852844ff5f42daa786.tar.bz2
gentoo-2-f7d48850080168f06c6cba852844ff5f42daa786.zip
Import Gentoo Prefix mods. KEYWORDS, deps, offset paths to configure, bug 415509
(Portage version: 2.1.10.60/cvs/Linux x86_64)
Diffstat (limited to 'net-im/pidgin')
-rw-r--r--net-im/pidgin/ChangeLog7
-rw-r--r--net-im/pidgin/pidgin-2.10.3-r100.ebuild17
-rw-r--r--net-im/pidgin/pidgin-2.10.3.ebuild17
3 files changed, 24 insertions, 17 deletions
diff --git a/net-im/pidgin/ChangeLog b/net-im/pidgin/ChangeLog
index fb92f35f309a..4ca8b48d99d8 100644
--- a/net-im/pidgin/ChangeLog
+++ b/net-im/pidgin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/pidgin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.276 2012/05/06 18:57:00 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.277 2012/05/22 13:57:32 darkside Exp $
+
+ 22 May 2012; Jeremy Olexa <darkside@gentoo.org> pidgin-2.10.3.ebuild,
+ pidgin-2.10.3-r100.ebuild:
+ Import Gentoo Prefix mods. KEYWORDS, deps, offset paths to configure, bug
+ 415509
06 May 2012; Mark Loeser <halcy0n@gentoo.org> pidgin-2.10.3.ebuild:
Stable for ppc64; bug #408117
diff --git a/net-im/pidgin/pidgin-2.10.3-r100.ebuild b/net-im/pidgin/pidgin-2.10.3-r100.ebuild
index 22cbab3f62bb..0031ee875d17 100644
--- a/net-im/pidgin/pidgin-2.10.3-r100.ebuild
+++ b/net-im/pidgin/pidgin-2.10.3-r100.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.10.3-r100.ebuild,v 1.2 2012/05/04 06:22:11 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.10.3-r100.ebuild,v 1.3 2012/05/22 13:57:32 darkside Exp $
EAPI=4
@@ -13,10 +13,11 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
IUSE="dbus debug doc eds gadu gnutls +gstreamer +gtk idn meanwhile"
IUSE+=" networkmanager nls perl silc tcl tk spell sasl ncurses"
IUSE+=" groupwise prediction python +xscreensaver zephyr zeroconf" # mono"
+IUSE+=" aqua"
# dbus requires python to generate C code for dbus bindings (thus DEPEND only).
# finch uses libgnt that links with libpython - {R,}DEPEND. But still there is
@@ -31,7 +32,7 @@ RDEPEND="
dbus? ( <dev-lang/python-3 )
python? ( <dev-lang/python-3 ) )
gtk? (
- >=x11-libs/gtk+-2.10:2
+ >=x11-libs/gtk+-2.10:2[aqua=]
x11-libs/libSM
xscreensaver? ( x11-libs/libXScrnSaver )
spell? ( >=app-text/gtkspell-2.0.2:2 )
@@ -159,8 +160,8 @@ src_configure() {
if use gnutls; then
einfo "Disabling NSS, using GnuTLS"
myconf+=" --enable-nss=no --enable-gnutls=yes"
- myconf+=" --with-gnutls-includes=/usr/include/gnutls"
- myconf+=" --with-gnutls-libs=/usr/$(get_libdir)"
+ myconf+=" --with-gnutls-includes=${EPREFIX}/usr/include/gnutls"
+ myconf+=" --with-gnutls-libs=${EPREFIX}/usr/$(get_libdir)"
else
einfo "Disabling GnuTLS, using NSS"
myconf+=" --enable-gnutls=no --enable-nss=yes"
@@ -197,10 +198,10 @@ src_configure() {
$(use_enable networkmanager nm) \
$(use_enable zeroconf avahi) \
$(use_enable idn) \
- --with-system-ssl-certs="/etc/ssl/certs/" \
+ --with-system-ssl-certs="${EPREFIX}/etc/ssl/certs/" \
--with-dynamic-prpls="${DYNAMIC_PRPLS}" \
--disable-mono \
- --x-includes=/usr/include/X11 \
+ --x-includes="${EPREFIX}"/usr/include/X11 \
${myconf}
#$(use_enable mono) \
}
@@ -212,7 +213,7 @@ src_install() {
# implementations that are not complient with new hicolor theme yet, #323355
local pixmapdir
for d in 16 22 32 48; do
- pixmapdir=${D}/usr/share/pixmaps/pidgin/tray/hicolor/${d}x${d}/actions
+ pixmapdir=${ED}/usr/share/pixmaps/pidgin/tray/hicolor/${d}x${d}/actions
mkdir "${pixmapdir}" || die
pushd "${pixmapdir}" >/dev/null || die
for f in ../status/*; do
diff --git a/net-im/pidgin/pidgin-2.10.3.ebuild b/net-im/pidgin/pidgin-2.10.3.ebuild
index 976108f2d7c6..81af0465eb55 100644
--- a/net-im/pidgin/pidgin-2.10.3.ebuild
+++ b/net-im/pidgin/pidgin-2.10.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.10.3.ebuild,v 1.8 2012/05/06 18:57:00 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.10.3.ebuild,v 1.9 2012/05/22 13:57:32 darkside Exp $
EAPI=4
@@ -13,10 +13,11 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
IUSE="dbus debug doc eds gadu gnutls +gstreamer +gtk idn meanwhile"
IUSE+=" networkmanager nls perl silc tcl tk spell sasl ncurses"
IUSE+=" groupwise prediction python +xscreensaver zephyr zeroconf" # mono"
+IUSE+=" aqua"
# dbus requires python to generate C code for dbus bindings (thus DEPEND only).
# finch uses libgnt that links with libpython - {R,}DEPEND. But still there is
@@ -31,7 +32,7 @@ RDEPEND="
dbus? ( <dev-lang/python-3 )
python? ( <dev-lang/python-3 ) )
gtk? (
- >=x11-libs/gtk+-2.10:2
+ >=x11-libs/gtk+-2.10:2[aqua=]
x11-libs/libSM
xscreensaver? ( x11-libs/libXScrnSaver )
spell? ( >=app-text/gtkspell-2.0.2:2 )
@@ -157,8 +158,8 @@ src_configure() {
if use gnutls; then
einfo "Disabling NSS, using GnuTLS"
myconf+=" --enable-nss=no --enable-gnutls=yes"
- myconf+=" --with-gnutls-includes=/usr/include/gnutls"
- myconf+=" --with-gnutls-libs=/usr/$(get_libdir)"
+ myconf+=" --with-gnutls-includes=${EPREFIX}/usr/include/gnutls"
+ myconf+=" --with-gnutls-libs=${EPREFIX}/usr/$(get_libdir)"
else
einfo "Disabling GnuTLS, using NSS"
myconf+=" --enable-gnutls=no --enable-nss=yes"
@@ -195,10 +196,10 @@ src_configure() {
$(use_enable networkmanager nm) \
$(use_enable zeroconf avahi) \
$(use_enable idn) \
- --with-system-ssl-certs="/etc/ssl/certs/" \
+ --with-system-ssl-certs="${EPREFIX}/etc/ssl/certs/" \
--with-dynamic-prpls="${DYNAMIC_PRPLS}" \
--disable-mono \
- --x-includes=/usr/include/X11 \
+ --x-includes="${EPREFIX}"/usr/include/X11 \
${myconf}
#$(use_enable mono) \
}
@@ -210,7 +211,7 @@ src_install() {
# implementations that are not complient with new hicolor theme yet, #323355
local pixmapdir
for d in 16 22 32 48; do
- pixmapdir=${D}/usr/share/pixmaps/pidgin/tray/hicolor/${d}x${d}/actions
+ pixmapdir=${ED}/usr/share/pixmaps/pidgin/tray/hicolor/${d}x${d}/actions
mkdir "${pixmapdir}" || die
pushd "${pixmapdir}" >/dev/null || die
for f in ../status/*; do