summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-12-06 14:11:05 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-12-06 14:11:05 +0000
commit6f3fe7131c49318cd5fa5b40b6f9ac48043f354f (patch)
tree8145bde87aae702ff29e440caee629d7c5508bff /net-im/psi
parentcleaned up a very ugly ebuild, hopefully fixed a problem with online help fil... (diff)
downloadgentoo-2-6f3fe7131c49318cd5fa5b40b6f9ac48043f354f.tar.gz
gentoo-2-6f3fe7131c49318cd5fa5b40b6f9ac48043f354f.tar.bz2
gentoo-2-6f3fe7131c49318cd5fa5b40b6f9ac48043f354f.zip
added patch that now shows "Gentoo Linux" as OS instead of "Linux" :o)
Diffstat (limited to 'net-im/psi')
-rw-r--r--net-im/psi/ChangeLog6
-rw-r--r--net-im/psi/files/gen2-branding-0.8.7.patch11
-rw-r--r--net-im/psi/psi-0.8.7.ebuild11
3 files changed, 26 insertions, 2 deletions
diff --git a/net-im/psi/ChangeLog b/net-im/psi/ChangeLog
index fb65b014a9d8..21b437130223 100644
--- a/net-im/psi/ChangeLog
+++ b/net-im/psi/ChangeLog
@@ -1,12 +1,16 @@
# ChangeLog for net-im/psi
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/psi/ChangeLog,v 1.8 2002/11/01 14:08:28 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/ChangeLog,v 1.9 2002/12/06 14:11:05 verwilst Exp $
+
+ 6 Dec 2002; Bart Verwilst <verwilst@gentoo.org> :
+ Added a patch that shows "Gentoo Linux" as OS instead of "Linux" :o)
*psi-0.8.7 (1 Nov 2002); Bart Verwilst <verwilst@gentoo.org>
1 Nov 2002; Bart Verwilst <verwilst@gentoo.org> :
Added ppc keywords
+
*psi-0.8.6 (9 July 2002)
28 Oct 2002; Mike Frysinger <vapier@gentoo.org> :
diff --git a/net-im/psi/files/gen2-branding-0.8.7.patch b/net-im/psi/files/gen2-branding-0.8.7.patch
new file mode 100644
index 000000000000..f7a3c640ee91
--- /dev/null
+++ b/net-im/psi/files/gen2-branding-0.8.7.patch
@@ -0,0 +1,11 @@
+--- psiaccount.cpp.orig 2002-12-06 15:00:19.000000000 +0100
++++ psiaccount.cpp 2002-12-06 14:59:50.000000000 +0100
+@@ -139,7 +139,7 @@
+
+ // create Jabber::Client
+ d->client = new Client;
+- d->client->setOSName(getOSName());
++ d->client->setOSName("Gentoo Linux");
+ d->client->setTimeZone(getTZString(), getTZOffset());
+ d->client->setClientName(PROG_NAME);
+ d->client->setClientVersion(PROG_VERSION);
diff --git a/net-im/psi/psi-0.8.7.ebuild b/net-im/psi/psi-0.8.7.ebuild
index 1a82201dd533..54a4a7376ecb 100644
--- a/net-im/psi/psi-0.8.7.ebuild
+++ b/net-im/psi/psi-0.8.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/psi/psi-0.8.7.ebuild,v 1.3 2002/11/04 17:52:02 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/psi-0.8.7.ebuild,v 1.4 2002/12/06 14:11:05 verwilst Exp $
IUSE="ssl"
@@ -18,6 +18,15 @@ KEYWORDS="x86 ppc"
DEPEND=">=x11-libs/qt-3
ssl? ( >=dev-libs/openssl-0.9.6c )"
+src_unpack() {
+
+ unpack ${P}.tar.bz2
+ unpack qssl-${QV}.tar.bz2
+ cd ${S}/src
+ patch -p0 < ${FILESDIR}/gen2-branding-0.8.7.patch
+
+}
+
src_compile() {
./configure --prefix=/usr || die