summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-09-02 09:48:27 +0000
committerPacho Ramos <pacho@gentoo.org>2014-09-02 09:48:27 +0000
commit190ae1afbfc7081f7ce2a439835a1c5a7b2f7fe6 (patch)
tree13088cf80face6fc42af72d637275e7f8b6b911a /net-im/telepathy-logger
parentbump; add deps for testsuite, tidy (diff)
downloadgentoo-2-190ae1afbfc7081f7ce2a439835a1c5a7b2f7fe6.tar.gz
gentoo-2-190ae1afbfc7081f7ce2a439835a1c5a7b2f7fe6.tar.bz2
gentoo-2-190ae1afbfc7081f7ce2a439835a1c5a7b2f7fe6.zip
Version bump
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-im/telepathy-logger')
-rw-r--r--net-im/telepathy-logger/ChangeLog7
-rw-r--r--net-im/telepathy-logger/telepathy-logger-0.8.1.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/net-im/telepathy-logger/ChangeLog b/net-im/telepathy-logger/ChangeLog
index 172ba54e4128..81d4ecab981a 100644
--- a/net-im/telepathy-logger/ChangeLog
+++ b/net-im/telepathy-logger/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/telepathy-logger
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/telepathy-logger/ChangeLog,v 1.64 2014/08/05 18:34:06 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/telepathy-logger/ChangeLog,v 1.65 2014/09/02 09:48:27 pacho Exp $
+
+*telepathy-logger-0.8.1 (02 Sep 2014)
+
+ 02 Sep 2014; Pacho Ramos <pacho@gentoo.org> +telepathy-logger-0.8.1.ebuild:
+ Version bump
05 Aug 2014; Manuel Rüger <mrueg@gentoo.org> telepathy-logger-0.4.0-r1.ebuild,
telepathy-logger-0.6.0.ebuild, telepathy-logger-0.8.0.ebuild:
diff --git a/net-im/telepathy-logger/telepathy-logger-0.8.1.ebuild b/net-im/telepathy-logger/telepathy-logger-0.8.1.ebuild
new file mode 100644
index 000000000000..1b2f04575851
--- /dev/null
+++ b/net-im/telepathy-logger/telepathy-logger-0.8.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/telepathy-logger/telepathy-logger-0.8.1.ebuild,v 1.1 2014/09/02 09:48:27 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit gnome2 python-any-r1 virtualx
+
+DESCRIPTION="Telepathy Logger is a session daemon that should be activated whenever telepathy is being used"
+HOMEPAGE="http://telepathy.freedesktop.org/wiki/Logger"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=sys-apps/dbus-1.1
+ >=dev-libs/dbus-glib-0.82
+ >=net-libs/telepathy-glib-0.19.2[introspection?]
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-db/sqlite:3
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ >=dev-util/gtk-doc-am-1.10
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # --enable-debug needed due https://bugs.freedesktop.org/show_bug.cgi?id=83390
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --enable-debug \
+ --enable-public-extensions \
+ --disable-coding-style-checks \
+ --disable-Werror \
+ --disable-static
+}
+
+src_test() {
+ Xemake check
+}