summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-07-02 13:40:41 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-07-02 13:40:41 +0000
commit42ef615cc61900a246505a461885033e981aabcb (patch)
treec3dd3cddf22692fce906ae09dec2fb34ecff6d1e /net-im/twittare/twittare-0.7.42.ebuild
parentMask =sys-apps/portage-2.2.00.13734, does merge in reverse order with --nodeps. (diff)
downloadgentoo-2-42ef615cc61900a246505a461885033e981aabcb.tar.gz
gentoo-2-42ef615cc61900a246505a461885033e981aabcb.tar.bz2
gentoo-2-42ef615cc61900a246505a461885033e981aabcb.zip
Patch to compile with glibc-2.10 and gcc-4.4. Fixes bug 276204
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-im/twittare/twittare-0.7.42.ebuild')
-rw-r--r--net-im/twittare/twittare-0.7.42.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/net-im/twittare/twittare-0.7.42.ebuild b/net-im/twittare/twittare-0.7.42.ebuild
index bde130a56555..ff4e3b4dc43d 100644
--- a/net-im/twittare/twittare-0.7.42.ebuild
+++ b/net-im/twittare/twittare-0.7.42.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/twittare/twittare-0.7.42.ebuild,v 1.1 2009/05/10 11:35:02 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/twittare/twittare-0.7.42.ebuild,v 1.2 2009/07/02 13:40:40 hwoarang Exp $
EAPI="2"
@@ -20,10 +20,15 @@ DEPEND="x11-libs/qt-core:4
x11-libs/libnotify"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}/${PN}-gcc-4.4-glibc-2.10.patch"
+)
+
src_prepare() {
# fix LDFLAGS issue
sed -i "s/-fpic/${LDFLAGS}\ -fpic/" "${S}"/libtwnotification/makefile || die "sed failed"
sed -i "s/-shared/${LDFLAGS}\ -shared/" "${S}"/libtwnotification/makefile || die "sed failed"
+ qt4_src_prepare
}
src_configure() {