summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2013-03-18 15:55:08 +0000
committerHanno Böck <hanno@gentoo.org>2013-03-18 15:55:08 +0000
commit33c224cf1770706a5ccdfb42b41b6a6dcc2fd5fb (patch)
tree76da410bd62c5adea0b5f71186a8abc295fb5047 /net-im
parentremove unnecessary epunt_cxx (bug #462156) (diff)
downloadgentoo-2-33c224cf1770706a5ccdfb42b41b6a6dcc2fd5fb.tar.gz
gentoo-2-33c224cf1770706a5ccdfb42b41b6a6dcc2fd5fb.tar.bz2
gentoo-2-33c224cf1770706a5ccdfb42b41b6a6dcc2fd5fb.zip
Add checkpath for /var/run, fix python code (#315115), EAPI 5-port, replace dosed with sed.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0xA5880072BBB51E42)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/pyicq-t/ChangeLog11
-rw-r--r--net-im/pyicq-t/files/pyicq-t-0.8-initd-r124
-rw-r--r--net-im/pyicq-t/pyicq-t-0.8.1.5-r1.ebuild78
3 files changed, 111 insertions, 2 deletions
diff --git a/net-im/pyicq-t/ChangeLog b/net-im/pyicq-t/ChangeLog
index f8e76dd96ca6..566df6cc0d31 100644
--- a/net-im/pyicq-t/ChangeLog
+++ b/net-im/pyicq-t/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/pyicq-t
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/ChangeLog,v 1.21 2011/08/21 17:41:16 hanno Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/ChangeLog,v 1.22 2013/03/18 15:55:08 hanno Exp $
+
+*pyicq-t-0.8.1.5-r1 (18 Mar 2013)
+
+ 18 Mar 2013; Hanno Boeck <hanno@gentoo.org> +pyicq-t-0.8.1.5-r1.ebuild,
+ +files/pyicq-t-0.8-initd-r1:
+ Add checkpath for /var/run, fix python code (#315115), EAPI 5-port, replace
+ dosed with sed.
21 Aug 2011; Hanno Boeck <hanno@gentoo.org> files/pyicq-t-0.8-initd:
Avoid warnings with baselayout 2 / openrc / start-stop-daemon, --chuid is
diff --git a/net-im/pyicq-t/files/pyicq-t-0.8-initd-r1 b/net-im/pyicq-t/files/pyicq-t-0.8-initd-r1
new file mode 100644
index 000000000000..bd099b501340
--- /dev/null
+++ b/net-im/pyicq-t/files/pyicq-t-0.8-initd-r1
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/files/pyicq-t-0.8-initd-r1,v 1.1 2013/03/18 15:55:08 hanno Exp $
+
+depend() {
+ need net
+ use jabber-server
+}
+
+start() {
+ ebegin "Starting ICQ Jabber Transport"
+ checkpath -q -d -m 0755 -o jabber:jabber /var/run/jabber/
+ start-stop-daemon --start --pidfile /var/run/jabber/pyicq-t.pid -u jabber -g jabber \
+ --exec INSPATH/pyicq-t.py -- \
+ -b -c /etc/jabber/pyicq-t.xml -l /var/log/jabber/pyicq-t.log
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ICQ Jabber Transport"
+ start-stop-daemon --stop --quiet --pidfile /var/run/jabber/pyicq-t.pid
+ eend $?
+}
diff --git a/net-im/pyicq-t/pyicq-t-0.8.1.5-r1.ebuild b/net-im/pyicq-t/pyicq-t-0.8.1.5-r1.ebuild
new file mode 100644
index 000000000000..449fe251ac75
--- /dev/null
+++ b/net-im/pyicq-t/pyicq-t-0.8.1.5-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/pyicq-t-0.8.1.5-r1.ebuild,v 1.1 2013/03/18 15:55:08 hanno Exp $
+
+EAPI="5"
+PYTHON_DEPEND="2"
+inherit eutils python
+
+MY_P="${P/pyicq-t/pyicqt}"
+
+DESCRIPTION="Python based jabber transport for ICQ"
+HOMEPAGE="http://code.google.com/p/pyicqt/"
+SRC_URI="http://pyicqt.googlecode.com/files/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="webinterface"
+
+DEPEND="net-im/jabber-base"
+RDEPEND="${DEPEND}
+ >=dev-python/twisted-2.2.0
+ >=dev-python/twisted-words-0.1.0
+ >=dev-python/twisted-web-0.5.0
+ webinterface? ( >=dev-python/nevow-0.4.1 )
+ >=dev-python/imaging-1.1"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-python26-warnings.diff"
+}
+
+src_install() {
+ local inspath
+
+ inspath=$(python_get_sitedir)/${PN}
+ insinto ${inspath}
+ doins -r data src tools
+ newins PyICQt.py ${PN}.py
+
+ insinto /etc/jabber
+ newins config_example.xml ${PN}.xml
+ fperms 600 /etc/jabber/${PN}.xml
+ fowners jabber:jabber /etc/jabber/${PN}.xml
+ fperms 755 "$(python_get_sitedir)/${PN}/pyicq-t.py"
+ sed -i \
+ -e "s:<spooldir>[^\<]*</spooldir>:<spooldir>/var/spool/jabber</spooldir>:" \
+ -e "s:<pid>[^\<]*</pid>:<pid>/var/run/jabber/${PN}.pid</pid>:" \
+ "${ED}/etc/jabber/${PN}.xml"
+
+ newinitd "${FILESDIR}/${PN}-0.8-initd-r1" ${PN}
+ sed -i -e "s:INSPATH:${inspath}:" "${ED}/etc/init.d/${PN}"
+ python_convert_shebangs ${PYTHON_ABI} "${ED}$(python_get_sitedir)/${PN}/pyicq-t.py"
+}
+
+pkg_postinst() {
+ python_mod_optimize ${PN}
+
+ elog "A sample configuration file has been installed in /etc/jabber/${PN}.xml."
+ elog "Please edit it and the configuration of your Jabber server to match."
+
+ ewarn "If you are storing user accounts in MySQL and are upgrading from a "
+ ewarn "version older than 0.8.1, then you will need to run the following "
+ ewarn "command to create some new tables:"
+ ewarn " mysql -u user_name -p pyicqt < $(python_get_sitedir)/${PN}/tools/db-setup.mysql"
+
+ elog "These instructions along with a list of new config variables are "
+ elog "available at: http://code.google.com/p/pyicqt/wiki/Upgrade"
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${PN}
+}