summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2009-09-30 19:52:53 +0000
committerDominik Kapusta <ayoy@gentoo.org>2009-09-30 19:52:53 +0000
commit91ae4700515608420221fd7a6f48b79c95a48144 (patch)
treeeeec78b2721e56ff667446e05e09ae3fa88553eb /net-im
parentamd64 stable wrt #282290 (diff)
downloadgentoo-2-91ae4700515608420221fd7a6f48b79c95a48144.tar.gz
gentoo-2-91ae4700515608420221fd7a6f48b79c95a48144.tar.bz2
gentoo-2-91ae4700515608420221fd7a6f48b79c95a48144.zip
Version bump, introduced qt-dbus dependency and removed oauth from IUSE
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/qtwitter/ChangeLog7
-rw-r--r--net-im/qtwitter/qtwitter-0.9.1.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/net-im/qtwitter/ChangeLog b/net-im/qtwitter/ChangeLog
index fc60592592a9..48b32d7a562d 100644
--- a/net-im/qtwitter/ChangeLog
+++ b/net-im/qtwitter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/qtwitter
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/ChangeLog,v 1.15 2009/09/20 07:46:21 ayoy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/ChangeLog,v 1.16 2009/09/30 19:52:53 ayoy Exp $
+
+*qtwitter-0.9.1 (30 Sep 2009)
+
+ 30 Sep 2009; Dominik Kapusta <ayoy@gentoo.org> +qtwitter-0.9.1.ebuild:
+ Version bump, introduced qt-dbus dependency and removed oauth from IUSE
20 Sep 2009; Dominik Kapusta <ayoy@gentoo.org> qtwitter-0.9.0.ebuild,
+files/qtwitter-0.9.0-no-oauth-fix.patch, metadata.xml:
diff --git a/net-im/qtwitter/qtwitter-0.9.1.ebuild b/net-im/qtwitter/qtwitter-0.9.1.ebuild
new file mode 100644
index 000000000000..fd211d89127a
--- /dev/null
+++ b/net-im/qtwitter/qtwitter-0.9.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/qtwitter-0.9.1.ebuild,v 1.1 2009/09/30 19:52:53 ayoy Exp $
+
+EAPI="2"
+
+inherit qt4
+
+DESCRIPTION="A Qt-based microblogging client"
+HOMEPAGE="http://www.qt-apps.org/content/show.php/qTwitter?content=99087"
+SRC_URI="http://files.ayoy.net/qtwitter/release/${PV}/src/${P}-src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND=">=x11-libs/qt-gui-4.5:4
+ >=x11-libs/qt-dbus-4.5:4
+ >=dev-libs/qoauth-1.0"
+RDEPEND="${DEPEND}"
+
+QTWITTER_LANGS="nb_NO pt_BR"
+QTWITTER_NOLONGLANGS="ca_ES cs_CZ de_DE es_ES fr_FR it_IT ja_JP pl_PL"
+
+for L in $QTWITTER_LANGS; do
+ IUSE="$IUSE linguas_$L"
+done
+for L in $QTWITTER_NOLONGLANGS; do
+ IUSE="$IUSE linguas_${L%_*}"
+done
+
+src_prepare() {
+ qt4_src_prepare
+ echo "CONFIG += nostrip" >> "${S}"/${PN}.pro
+
+ local langs=
+ for lingua in $LINGUAS; do
+ if has $lingua $QTWITTER_LANGS; then
+ langs="$langs loc/${PN}_${lingua}.ts"
+ else
+ for a in $QTWITTER_NOLONGLANGS; do
+ if [[ $lingua == ${a%_*} ]]; then
+ langs="$langs loc/${PN}_${a}.ts"
+ fi
+ done
+ fi
+ done
+
+ # remove translations and add only the selected ones
+ sed -i -e '/^ *loc.*\.ts/d' \
+ -e "/^TRANSLATIONS/s:loc.*:${langs}:" \
+ qtwitter-app/qtwitter-app.pro || die "sed failed"
+ # fix insecure runpaths
+ sed -i -e '/-Wl,-rpath,\$\${TOP}/d' \
+ qtwitter-app/qtwitter-app.pro || die "sed failed"
+
+ sed -i "s!\(\$\${INSTALL_PREFIX}\)/lib!\1/$(get_libdir)!" \
+ twitterapi/twitterapi.pro urlshortener/urlshortener.pro || die "sed failed"
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc README CHANGELOG || die "dodoc failed"
+}