summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-05-16 03:34:45 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-05-16 03:34:45 +0000
commita97a193ec738dcefc516065865a2ae318950d4c0 (patch)
tree804dde6c3d4eb9ed588371876df4d74979a77916 /net-im
parentAdd ~x86-fbsd. #412915 (diff)
downloadgentoo-2-a97a193ec738dcefc516065865a2ae318950d4c0.tar.gz
gentoo-2-a97a193ec738dcefc516065865a2ae318950d4c0.tar.bz2
gentoo-2-a97a193ec738dcefc516065865a2ae318950d4c0.zip
Fixed build against newer ant using jdk-7. Thanks to Matt McAdoo for the fix (bug #415619).
(Portage version: 2.2.0_alpha104_p20/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/openfire/ChangeLog7
-rw-r--r--net-im/openfire/files/openfire-3.7.1-buildxml-jdk7.patch30
-rw-r--r--net-im/openfire/openfire-3.7.1.ebuild5
3 files changed, 39 insertions, 3 deletions
diff --git a/net-im/openfire/ChangeLog b/net-im/openfire/ChangeLog
index 24c2a05d4f1e..ca1381812e44 100644
--- a/net-im/openfire/ChangeLog
+++ b/net-im/openfire/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/openfire
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/openfire/ChangeLog,v 1.43 2012/03/18 18:39:22 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/openfire/ChangeLog,v 1.44 2012/05/16 03:34:45 slyfox Exp $
+
+ 16 May 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/openfire-3.7.1-buildxml-jdk7.patch, openfire-3.7.1.ebuild:
+ Fixed build against newer ant using jdk-7. Thanks to Matt McAdoo for the fix
+ (bug #415619).
18 Mar 2012; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #118003.
diff --git a/net-im/openfire/files/openfire-3.7.1-buildxml-jdk7.patch b/net-im/openfire/files/openfire-3.7.1-buildxml-jdk7.patch
new file mode 100644
index 000000000000..fbc4aff81390
--- /dev/null
+++ b/net-im/openfire/files/openfire-3.7.1-buildxml-jdk7.patch
@@ -0,0 +1,30 @@
+Fixes failure when rebuilding build.xml with new ant:
+
+ * Applying buildxml.patch ...
+ * Applying buildxml-ant.patch ...
+>>> Source unpacked in /var/tmp/portage/net-im/openfire-3.7.1/work
+>>> Compiling source in /var/tmp/portage/net-im/openfire-3.7.1/work/openfire_src ...
+Rewriting attributes
+Rewriting ./build/build.xml
+Rewriting ./src/test/throttletest/build/build.xml
+Rewriting ./src/plugins/kraken/build/build.xml
+ * Using following ANT_TASKS: ant-contrib
+Buildfile: openfire-3.7.1/work/openfire_src/build/build.xml
+
+init:
+
+BUILD FAILED
+openfire-3.7.1/work/openfire_src/build/build.xml:221: Must use JDK 1.5.x or higher to build Openfire
+
+Gentoo-bug: https://bugs.gentoo.org/415619
+Author: Matt McAdoo
+--- build/build.xml 2012-05-15 21:15:53.849153950 -0500
++++ build/build.xml 2012-05-15 21:16:23.628271564 -0500
+@@ -234,6 +234,7 @@
+ <or>
+ <contains string="${ant.java.version}" substring="1.5"/>
+ <contains string="${ant.java.version}" substring="1.6"/>
++ <contains string="${ant.java.version}" substring="1.7"/>
+ </or>
+ </not>
+ </condition>
diff --git a/net-im/openfire/openfire-3.7.1.ebuild b/net-im/openfire/openfire-3.7.1.ebuild
index b79687ee9255..f61de9c1d803 100644
--- a/net-im/openfire/openfire-3.7.1.ebuild
+++ b/net-im/openfire/openfire-3.7.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/openfire/openfire-3.7.1.ebuild,v 1.1 2011/10/28 12:15:37 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/openfire/openfire-3.7.1.ebuild,v 1.2 2012/05/16 03:34:45 slyfox Exp $
inherit eutils java-pkg-2 java-ant-2
@@ -44,6 +44,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/buildxml.patch
epatch "${FILESDIR}"/buildxml-ant.patch
+ epatch "${FILESDIR}"/${P}-buildxml-jdk7.patch
# TODO should replace jars in build/lib with ones packaged by us -nichoj
}