summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2011-07-01 02:54:41 +0000
committerNathan Phillip Brink <binki@gentoo.org>2011-07-01 02:54:41 +0000
commitf47dc5ab44ff44116d15cc0e00968a4a45af964f (patch)
tree73608e416778c487ec192aa37320d5048537b3fd /net-irc/epic4/files
parentAdd patch from upstream for crypt linking #357249 by J.Taimr. (diff)
downloadgentoo-2-f47dc5ab44ff44116d15cc0e00968a4a45af964f.tar.gz
gentoo-2-f47dc5ab44ff44116d15cc0e00968a4a45af964f.tar.bz2
gentoo-2-f47dc5ab44ff44116d15cc0e00968a4a45af964f.zip
Bump to epic4-2.10.1, with gentoo-prefix support and EAPI=4 and some build fixes.
(Portage version: 2.2.0_alpha41-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/epic4/files')
-rw-r--r--net-irc/epic4/files/epic4-2.10.1-make-recursion.patch10
-rw-r--r--net-irc/epic4/files/epic4-2.10.1-perl.patch54
2 files changed, 64 insertions, 0 deletions
diff --git a/net-irc/epic4/files/epic4-2.10.1-make-recursion.patch b/net-irc/epic4/files/epic4-2.10.1-make-recursion.patch
new file mode 100644
index 000000000000..68d7e4c460b6
--- /dev/null
+++ b/net-irc/epic4/files/epic4-2.10.1-make-recursion.patch
@@ -0,0 +1,10 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -210,6 +210,6 @@
+ $(RM) Makefile source/Makefile include/sig.inc config.status config.cache config.log include/defs.h source/info.c.sh
+
+ depend:
+- (cd source;make depend)
++ (cd source;$(MAKE) depend)
+
+ # This is the end of the file.
diff --git a/net-irc/epic4/files/epic4-2.10.1-perl.patch b/net-irc/epic4/files/epic4-2.10.1-perl.patch
new file mode 100644
index 000000000000..ce41d153abc6
--- /dev/null
+++ b/net-irc/epic4/files/epic4-2.10.1-perl.patch
@@ -0,0 +1,54 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+Subject: Fix broken perl detection somewhat.
+
+--- a/configure.in
++++ b/configure.in
+@@ -636,25 +636,27 @@
+ dnl
+
+ AC_MSG_CHECKING(whether to support Perl)
+-AC_ARG_WITH(perl,
+-[ --with-perl[=PATH] Compile with perl support.],
+-[ test -z "$withval" && withval=yes ],
+-)
+-test "xno" != "x$withval" && for base in $withval /usr/local /usr /
+-do
+- FOUND=
+- for ext in so a dll ; do
+- test -r $base/lib/libperl.$ext && FOUND=1
+- test -r $base/libperl.$ext && FOUND=1
+- done
+- test -n "$FOUND" || continue
+- AC_MSG_RESULT(yes)
+- LIBS="$LIBS `perl -MExtUtils::Embed -e ldopts`"
+- PERLDOTOH="perl.o"
+- AC_DEFINE(PERL)
+- break
+-done
+-test -z "$PERLDOTOH" && AC_MSG_RESULT(no)
++AC_ARG_WITH([perl],
++ [AS_HELP_STRING([--with-perl[=PATH]], [Compile with perl support.])],
++ [],
++ [with_perl=maybe])
++AS_IF([test "xno" != "x$with_perl"],
++ [
++ PERL_LIBS="`perl -MExtUtils::Embed -e ldopts`"
++ AS_IF([test -n "$PERL_LIBS"],
++ [
++ AC_MSG_RESULT([yes])
++ LIBS="$LIBS $PERL_LIBS"
++ AC_DEFINE([PERL], [], [Define if perl support should be compiled])
++ PERLDOTOH="perl.o"
++ ],
++ [
++ AC_MSG_RESULT([no])
++ AS_IF([test "x$with_perl" != "xmaybe"],
++ [AC_MSG_ERROR([You specified --with-perl, but I was unable to find libperl])])
++ ])
++ ])
++
+ withval=''
+
+ dnl ----------------------------------------------------------
+
+Diff finished. Thu Jun 30 22:15:26 2011