summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-01-14 03:59:50 +0000
committerMike Frysinger <vapier@gentoo.org>2009-01-14 03:59:50 +0000
commitc9ec36741accd7abdcc3353e5c11d8d55ff3ab53 (patch)
tree7c1b5f5d2d88a0c86ec432024add068c8669ad85 /net-irc/ezbounce
parentFix building with newer glibc #248100 by Diego E. Pettenò. (diff)
downloadgentoo-2-c9ec36741accd7abdcc3353e5c11d8d55ff3ab53.tar.gz
gentoo-2-c9ec36741accd7abdcc3353e5c11d8d55ff3ab53.tar.bz2
gentoo-2-c9ec36741accd7abdcc3353e5c11d8d55ff3ab53.zip
Fix building with glibc-2.8 #251445 by Diego E. Pettenò.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'net-irc/ezbounce')
-rw-r--r--net-irc/ezbounce/ChangeLog8
-rw-r--r--net-irc/ezbounce/ezbounce-1.99.14.ebuild15
-rw-r--r--net-irc/ezbounce/files/ezbounce-1.99.14-build.patch34
3 files changed, 51 insertions, 6 deletions
diff --git a/net-irc/ezbounce/ChangeLog b/net-irc/ezbounce/ChangeLog
index 6caefc6540b1..e745f2ab4e21 100644
--- a/net-irc/ezbounce/ChangeLog
+++ b/net-irc/ezbounce/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/ezbounce
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/ezbounce/ChangeLog,v 1.16 2008/08/23 01:13:11 cardoe Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ezbounce/ChangeLog,v 1.17 2009/01/14 03:59:50 vapier Exp $
+
+ 14 Jan 2009; Mike Frysinger <vapier@gentoo.org>
+ +files/ezbounce-1.99.14-build.patch, ezbounce-1.99.14.ebuild:
+ Fix building with glibc-2.8 #251445 by Diego E. Pettenò.
23 Aug 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/net-irc/ezbounce/ezbounce-1.99.14.ebuild b/net-irc/ezbounce/ezbounce-1.99.14.ebuild
index 59576f959957..528697377f70 100644
--- a/net-irc/ezbounce/ezbounce-1.99.14.ebuild
+++ b/net-irc/ezbounce/ezbounce-1.99.14.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/ezbounce/ezbounce-1.99.14.ebuild,v 1.1 2008/06/06 09:30:45 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ezbounce/ezbounce-1.99.14.ebuild,v 1.2 2009/01/14 03:59:50 vapier Exp $
inherit eutils
-DESCRIPTION="ezbounce is a small IRC bouncer"
+DESCRIPTION="a small IRC bouncer"
HOMEPAGE="http://www.linuxftw.com/ezbounce/"
SRC_URI="http://www.linuxftw.com/${PN}/files/${P}.tar.gz"
@@ -18,8 +18,15 @@ DEPEND=">=net-misc/mdidentd-1.04c
ssl? ( dev-libs/openssl )
boost? ( dev-libs/boost )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch #251445
+}
+
src_compile() {
- econf $(use_with ssl) \
+ econf \
+ $(use_with ssl) \
$(use_with boost) \
|| die
emake CXX_OPTIMIZATIONS="${CXXFLAGS}" || die
diff --git a/net-irc/ezbounce/files/ezbounce-1.99.14-build.patch b/net-irc/ezbounce/files/ezbounce-1.99.14-build.patch
new file mode 100644
index 000000000000..7998fe335e6b
--- /dev/null
+++ b/net-irc/ezbounce/files/ezbounce-1.99.14-build.patch
@@ -0,0 +1,34 @@
+http://bugs.gentoo.org/251445
+
+--- include/fs/file_system.h
++++ include/fs/file_system.h
+@@ -12,6 +12,7 @@
+
+ #include <vector>
+ #include <cstring>
++#include <limits.h>
+ #include "util/hash.h"
+ #include "fs/fwd.h"
+ #include "fs/entry_data.h"
+--- src/io/filters.cc
++++ src/io/filters.cc
+@@ -10,6 +10,8 @@
+
+ #include "autoconf.h"
+
++#include <cstring>
++
+ #include "io/filters.h"
+ #include "debug.h"
+
+--- src/main.cc
++++ src/main.cc
+@@ -191,7 +191,7 @@
+ /* Write out pid-file if needed */
+ const string& pidfile = proxy->config().get<string>(proxy_config::PID_FILE);
+ if (!pidfile.empty()) {
+- int f = open(pidfile.c_str(), O_CREAT | O_WRONLY);
++ int f = open(pidfile.c_str(), O_CREAT | O_WRONLY, 0644);
+ io::fdprintf(f, "%d", getpid());
+ fchmod(f, 0644);
+ close(f);