summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2007-11-12 21:47:33 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2007-11-12 21:47:33 +0000
commitbe295739c64e855991ae4cd73034ed9ff447d39f (patch)
tree974f5af8dfc5e6cec236bb3769af569ac94fc693 /net-irc/inspircd
parentamd64 stable wrt #198845 and work around broken python wrt #187826 (diff)
downloadgentoo-2-be295739c64e855991ae4cd73034ed9ff447d39f.tar.gz
gentoo-2-be295739c64e855991ae4cd73034ed9ff447d39f.tar.bz2
gentoo-2-be295739c64e855991ae4cd73034ed9ff447d39f.zip
Update init.d script from bug 194654. Bump version according to bug 198317.
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-irc/inspircd')
-rw-r--r--net-irc/inspircd/ChangeLog19
-rw-r--r--net-irc/inspircd/files/digest-inspircd-1.1.143
-rw-r--r--net-irc/inspircd/files/init.d_inspircd20
-rw-r--r--net-irc/inspircd/inspircd-1.1.14.ebuild88
4 files changed, 122 insertions, 8 deletions
diff --git a/net-irc/inspircd/ChangeLog b/net-irc/inspircd/ChangeLog
index 2ef2205867a2..e25bb22eb840 100644
--- a/net-irc/inspircd/ChangeLog
+++ b/net-irc/inspircd/ChangeLog
@@ -1,6 +1,23 @@
# ChangeLog for net-irc/inspircd
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/ChangeLog,v 1.18 2007/10/05 20:29:07 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/ChangeLog,v 1.19 2007/11/12 21:47:32 hansmi Exp $
+
+*inspircd-1.1.14 (12 Nov 2007)
+
+ 12 Nov 2007; Michael Hanselmann <hansmi@gentoo.org> files/init.d_inspircd,
+ +inspircd-1.1.14.ebuild:
+ Update init.d script from bug 194654. Bump version according to bug 198317
+ with a patch from Eugene Janusov:
+ - toolchain-funcs has been removed from inherit, because not used. Not sure
+ about multilib, leaving it
+ - IUSE moved behind KEYWORDS as in docs and skel.ebuild
+ - svn isn't actually used, so all svn stuff removed
+ - trailing slash added to HOMEPAGE
+ - SRC_URI now points to the official site, because there is no new version on
+ SourceForge
+ - --disable-interactive option added for ./configure
+ - src_compile() partly rewritten and gracefully reformatted
+ - all references to the name of the package replaced with ${PN}
*inspircd-1.1.13-r1 (05 Oct 2007)
diff --git a/net-irc/inspircd/files/digest-inspircd-1.1.14 b/net-irc/inspircd/files/digest-inspircd-1.1.14
new file mode 100644
index 000000000000..2857a38d1b1b
--- /dev/null
+++ b/net-irc/inspircd/files/digest-inspircd-1.1.14
@@ -0,0 +1,3 @@
+MD5 61c438533bd023c18599991d34ba3697 InspIRCd-1.1.14.tar.bz2 504766
+RMD160 ee48f16b0360ef2ae397d8eb5a5c36027f47cc4d InspIRCd-1.1.14.tar.bz2 504766
+SHA256 de7c3fcf15bcab3a3bd9e41233854322022cdd1e0207fdd0f26d7e608209cf39 InspIRCd-1.1.14.tar.bz2 504766
diff --git a/net-irc/inspircd/files/init.d_inspircd b/net-irc/inspircd/files/init.d_inspircd
index e7c022d921b8..6a1844a8125a 100644
--- a/net-irc/inspircd/files/init.d_inspircd
+++ b/net-irc/inspircd/files/init.d_inspircd
@@ -1,31 +1,37 @@
#!/sbin/runscript
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/files/init.d_inspircd,v 1.3 2007/07/11 08:10:47 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/files/init.d_inspircd,v 1.4 2007/11/12 21:47:33 hansmi Exp $
-opts="${opts} rehash"
+opts="${opts} rehash version"
depend() {
need net
- provide ircd
+ provide ircd
}
start() {
ebegin "Starting InspIRCd"
start-stop-daemon --start --quiet --chuid inspircd \
- --exec /usr/bin/inspircd -- \
- --logfile /var/log/inspircd/ircd.log &>/dev/null
+ --exec /usr/bin/inspircd -- \
+ --logfile /var/log/inspircd/ircd.log &> /dev/null
eend $?
}
stop() {
ebegin "Stopping InspIRCd"
- start-stop-daemon --stop --quiet --pidfile /var/run/inspircd/ircd.pid
+ start-stop-daemon --stop --quiet --exec /usr/bin/inspircd
eend $?
}
rehash() {
ebegin "Rehashing InspIRCd"
- kill -s SIGHUP $(</var/run/inspircd/ircd.pid)
+ /usr/lib/inspircd/inspircd.launcher/inspircd rehash &> /dev/null
+ eend $?
+}
+
+version() {
+ ebegin "Retrieve InspIRCd version"
+ /usr/lib/inspircd/inspircd.launcher/inspircd version
eend $?
}
diff --git a/net-irc/inspircd/inspircd-1.1.14.ebuild b/net-irc/inspircd/inspircd-1.1.14.ebuild
new file mode 100644
index 000000000000..0dde2843be35
--- /dev/null
+++ b/net-irc/inspircd/inspircd-1.1.14.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/inspircd-1.1.14.ebuild,v 1.1 2007/11/12 21:47:32 hansmi Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="InspIRCd - The Modular C++ IRC Daemon"
+HOMEPAGE="http://www.inspircd.org/"
+SRC_URI="http://www.inspircd.org/downloads/InspIRCd-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gnutls ipv6 openssl kernel_linux"
+
+DEPEND="
+ >=sys-devel/gcc-3.3.0
+ >=dev-lang/perl-5.8
+ openssl? ( >=dev-libs/openssl-0.9.7d )
+ gnutls? ( >=net-libs/gnutls-1.3.0 )"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ ebegin "Creating inspircd user and group"
+ enewgroup inspircd
+ enewuser inspircd -1 -1 -1 inspircd
+ eend ${?}
+}
+
+src_compile() {
+ local myconf="
+ --disable-interactive
+ --enable-epoll"
+
+ # ./configure doesn't know --disable-gnutls, -ipv6 and -openssl options,
+ # so should be used only --enable-like.
+ use gnutls && myconf="${myconf} $(use_enable gnutls)"
+ use ipv6 && myconf="${myconf} $(use_enable ipv6) --enable-remote-ipv6"
+ use openssl && myconf="${myconf} $(use_enable openssl)"
+
+ ./configure \
+ --prefix="/usr" \
+ --binary-dir="/usr/bin" \
+ --config-dir="/etc/${PN}" \
+ --library-dir="/usr/$(get_libdir)/${PN}" \
+ --module-dir="/usr/$(get_libdir)/${PN}/modules" \
+ ${myconf} || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ # the inspircd buildsystem does not create these, it's configure script
+ # does. so, we have to at this point to make sure they are there.
+ dodir /etc/${PN}
+ dodir /usr/include/${PN}
+ dodir /usr/$(get_libdir)/${PN}
+ dodir /usr/$(get_libdir)/${PN}/modules
+ dodir /var/log/${PN}
+
+ emake install \
+ BASE="${D}"/usr/$(get_libdir)/${PN}/inspircd.launcher \
+ BINPATH="${D}"/usr/bin \
+ CONPATH="${D}"/etc/${PN} \
+ LIBPATH="${D}"/usr/$(get_libdir)/${PN}/ \
+ MODPATH="${D}"/usr/$(get_libdir)/${PN}/modules/ \
+
+ insinto /usr/include/inspircd/
+ doins "${S}"/include/*
+
+ newinitd "${FILESDIR}"/init.d_inspircd inspircd
+}
+
+pkg_postinst() {
+ chown -R inspircd:inspircd "${ROOT}"/etc/${PN}
+ chmod 700 "${ROOT}"/etc/${PN}
+
+ chown -R inspircd:inspircd "${ROOT}"/var/log/${PN}
+ chmod 750 "${ROOT}"/var/log/${PN}
+
+ chown -R inspircd:inspircd "${ROOT}"/usr/$(get_libdir)/${PN}
+ chmod -R 755 "${ROOT}"/usr/$(get_libdir)/${PN}
+
+ chmod -R 755 "${ROOT}"/usr/bin/inspircd
+}