summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDawid Węgliński <cla@gentoo.org>2008-01-20 01:43:25 +0000
committerDawid Węgliński <cla@gentoo.org>2008-01-20 01:43:25 +0000
commit3ea7f385a2b72cb72f919466ba56f011dd5510b4 (patch)
treeb224fd5a0ec4f6fd34b3f23b6311132f0d26ad25 /net-irc/lostirc
parentVersion bump, fixes memory leaks. (diff)
downloadgentoo-2-3ea7f385a2b72cb72f919466ba56f011dd5510b4.tar.gz
gentoo-2-3ea7f385a2b72cb72f919466ba56f011dd5510b4.tar.bz2
gentoo-2-3ea7f385a2b72cb72f919466ba56f011dd5510b4.zip
Remove base.eclass, fix accessibility stuff wrt #201269. Thanks to jakub for patch.
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-irc/lostirc')
-rw-r--r--net-irc/lostirc/ChangeLog9
-rw-r--r--net-irc/lostirc/files/digest-lostirc-0.4.6-r13
-rw-r--r--net-irc/lostirc/lostirc-0.4.6-r1.ebuild42
3 files changed, 52 insertions, 2 deletions
diff --git a/net-irc/lostirc/ChangeLog b/net-irc/lostirc/ChangeLog
index c31394476bc1..7a8f4c4e9769 100644
--- a/net-irc/lostirc/ChangeLog
+++ b/net-irc/lostirc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/lostirc
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/lostirc/ChangeLog,v 1.46 2007/02/09 04:25:43 flameeyes Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/lostirc/ChangeLog,v 1.47 2008/01/20 01:43:24 cla Exp $
+
+*lostirc-0.4.6-r1 (20 Jan 2008)
+
+ 20 Jan 2008; Dawid Węgliński <cla@gentoo.org> +lostirc-0.4.6-r1.ebuild:
+ Remove base.eclass, fix accessibility stuff
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/net-irc/lostirc/files/digest-lostirc-0.4.6-r1 b/net-irc/lostirc/files/digest-lostirc-0.4.6-r1
new file mode 100644
index 000000000000..a83d5bef2dfb
--- /dev/null
+++ b/net-irc/lostirc/files/digest-lostirc-0.4.6-r1
@@ -0,0 +1,3 @@
+MD5 501cd56bc0740d599540fb415718b939 lostirc-0.4.6.tar.gz 622926
+RMD160 ffd25b350f477a1cc72138448d05e0b66ad801a9 lostirc-0.4.6.tar.gz 622926
+SHA256 50f07178d65fdbed1e85980af039cdf251ae044fee639aaeb28e3949ef6e7edd lostirc-0.4.6.tar.gz 622926
diff --git a/net-irc/lostirc/lostirc-0.4.6-r1.ebuild b/net-irc/lostirc/lostirc-0.4.6-r1.ebuild
new file mode 100644
index 000000000000..6c95fd49a90d
--- /dev/null
+++ b/net-irc/lostirc/lostirc-0.4.6-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/lostirc/lostirc-0.4.6-r1.ebuild,v 1.1 2008/01/20 01:43:24 cla Exp $
+
+inherit autotools
+
+IUSE="debug nls"
+DESCRIPTION="A simple but functional graphical IRC client"
+HOMEPAGE="http://lostirc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND=">=dev-cpp/gtkmm-2.4
+ >=dev-cpp/glibmm-2.4.4
+ =dev-libs/libsigc++-2.0*"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e 's:atkmm-1.6::' configure.ac || die "sed failed in configure.ac"
+ sed -i -e 's:@MKINSTALLDIRS@:@MKDIR_P@:' \
+ -e '/^mkinstalldirs =/s:$(SHELL)::' po/Makefile.in.in \
+ || die "sed failed in po.Makefile.in.in"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --enable-desktopfile \
+ $(use_enable debug logdebug) \
+ $(use_enable nls)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog README TODO NEWS || die "dodoc failed"
+}