summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-04-22 15:08:20 +0000
committerSven Wegener <swegener@gentoo.org>2005-04-22 15:08:20 +0000
commitb83858eb40ddbb245753f2b5a289b821764a864c (patch)
tree417d6535cb4d3d3712fbbf25433b5f4e62283280 /net-irc/rbot/rbot-0.9.7.ebuild
parentMarked stable on x86. (diff)
downloadgentoo-2-b83858eb40ddbb245753f2b5a289b821764a864c.tar.gz
gentoo-2-b83858eb40ddbb245753f2b5a289b821764a864c.tar.bz2
gentoo-2-b83858eb40ddbb245753f2b5a289b821764a864c.zip
Marked stable on x86.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-irc/rbot/rbot-0.9.7.ebuild')
-rw-r--r--net-irc/rbot/rbot-0.9.7.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/net-irc/rbot/rbot-0.9.7.ebuild b/net-irc/rbot/rbot-0.9.7.ebuild
index bbca99ebe409..0a2cdbf843b8 100644
--- a/net-irc/rbot/rbot-0.9.7.ebuild
+++ b/net-irc/rbot/rbot-0.9.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/rbot-0.9.7.ebuild,v 1.3 2005/04/18 19:27:24 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/rbot-0.9.7.ebuild,v 1.4 2005/04/22 15:08:20 swegener Exp $
DESCRIPTION="rbot is a ruby IRC bot"
HOMEPAGE="http://www.linuxbrit.co.uk/rbot/"
@@ -8,7 +8,7 @@ SRC_URI="http://www.linuxbrit.co.uk/downloads/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+KEYWORDS="x86 ~ppc ~sparc ~amd64"
IUSE="spell"
RDEPEND="virtual/ruby
@@ -20,21 +20,20 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- cd ${S}
sed -i -e s:rbotconf:/etc/rbot: ${S}/rbot.rb || die "sed failed"
}
src_install() {
- local SITERUBY=$(ruby -r rbconfig -e 'print Config::CONFIG["sitelibdir"]')
+ local SITERUBY="$(ruby -r rbconfig -e 'print Config::CONFIG["sitelibdir"]')"
- newbin rbot.rb rbot
+ newbin rbot.rb rbot || die "newbin failed"
- dodir ${SITERUBY}
- cp -a rbot ${D}/${SITERUBY} || die
+ insinto "${SITERUBY}"
+ doins -r rbot || die "doins failed"
- dodir /etc/rbot
- cp -r rbotconf/* ${D}/etc/rbot || die
+ insinto /etc/rbot
+ doins rbotconf/* || die "doins failed"
dodoc AUTHORS ChangeLog INSTALL REQUIREMENTS TODO
dohtml -r doc/*