summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-04-01 12:14:41 +0000
committerAlex Alexander <wired@gentoo.org>2011-04-01 12:14:41 +0000
commit0b28340ec5ce958902e7a44ce5d294dbfbde2143 (patch)
treeb21987bff67f47a4691e5319368523f796e9bf05 /net-irc/znc
parentfix Spinlock.h include path, wrt #361203 (diff)
downloadgentoo-2-0b28340ec5ce958902e7a44ce5d294dbfbde2143.tar.gz
gentoo-2-0b28340ec5ce958902e7a44ce5d294dbfbde2143.tar.bz2
gentoo-2-0b28340ec5ce958902e7a44ce5d294dbfbde2143.zip
version bump
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/znc')
-rw-r--r--net-irc/znc/ChangeLog8
-rw-r--r--net-irc/znc/files/znc-0.098-modpython-as-needed.patch22
-rw-r--r--net-irc/znc/znc-0.098.ebuild67
3 files changed, 96 insertions, 1 deletions
diff --git a/net-irc/znc/ChangeLog b/net-irc/znc/ChangeLog
index 7d78a1124a32..c1919a852cad 100644
--- a/net-irc/znc/ChangeLog
+++ b/net-irc/znc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/znc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.48 2011/03/03 23:51:31 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.49 2011/04/01 12:14:41 wired Exp $
+
+*znc-0.098 (01 Apr 2011)
+
+ 01 Apr 2011; Alex Alexander <wired@gentoo.org> +znc-0.098.ebuild,
+ +files/znc-0.098-modpython-as-needed.patch:
+ version bump
*znc-0.096-r1 (03 Mar 2011)
diff --git a/net-irc/znc/files/znc-0.098-modpython-as-needed.patch b/net-irc/znc/files/znc-0.098-modpython-as-needed.patch
new file mode 100644
index 000000000000..02e983ed34c0
--- /dev/null
+++ b/net-irc/znc/files/znc-0.098-modpython-as-needed.patch
@@ -0,0 +1,22 @@
+fix modpython compilation with forced --as-needed
+
+--- znc-0.098-orig/modules/modpython/Makefile.inc
++++ znc-0.098/modules/modpython/Makefile.inc
+@@ -1,7 +1,7 @@
+ # vim: filetype=make
+
+ ifneq "$(PYCFG)" ""
+-PYTHONCOMMON := $(shell $(PYCFG) --includes) $(shell $(PYCFG) --ldflags)
++PYTHONCOMMON := $(shell $(PYCFG) --includes)
+ PYTHONCOMMON += -DSWIG_TYPE_TABLE=znc
+ PYTHONCOMMON += -Wno-missing-field-initializers -Wno-unused -Wno-shadow
+ PYTHONCOMMON += -Wno-missing-declarations -Wno-uninitialized
+@@ -56,7 +56,7 @@
+
+ modpython/compiler: modpython/compiler.cpp Makefile
+ $(E) Building optimizer for python files...
+- $(Q)$(CXX) $(PYTHONCOMMON) -o $@ $<
++ $(Q)$(CXX) $(PYTHONCOMMON) -o $@ $< $(shell $(PYCFG) --ldflags)
+
+ modpython_install: create_install_dir install_metadirs modpython_all
+ -for i in *.pyc; do \
diff --git a/net-irc/znc/znc-0.098.ebuild b/net-irc/znc/znc-0.098.ebuild
new file mode 100644
index 000000000000..289f71964692
--- /dev/null
+++ b/net-irc/znc/znc-0.098.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/znc-0.098.ebuild,v 1.1 2011/04/01 12:14:41 wired Exp $
+
+EAPI=2
+
+PYTHON_DEPEND="python? 3"
+inherit base python
+
+DESCRIPTION="An advanced IRC Bouncer"
+HOMEPAGE="http://znc.sourceforge.net"
+SRC_URI="http://znc.in/releases/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="ares debug extras ipv6 perl python ssl sasl tcl"
+
+RDEPEND="
+ ares? ( >=net-dns/c-ares-1.5 )
+ perl? ( dev-lang/perl )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ tcl? ( dev-lang/tcl )
+"
+DEPEND="
+ dev-util/pkgconfig
+ perl? ( dev-lang/swig )
+ python? ( dev-lang/swig )
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${P}-modpython-as-needed.patch" )
+
+pkg_setup() {
+ use python && python_set_active_version 3
+ use python && python_pkg_setup
+}
+
+src_configure() {
+ use python && local pyconf="=python-config-$(python_get_version)"
+
+ econf \
+ $(use_enable ares c-ares) \
+ $(use_enable debug) \
+ $(use_enable extras extra) \
+ $(use_enable ipv6) \
+ $(use_enable perl) \
+ $(use_enable python "python${pyconf}") \
+ $(use_enable sasl) \
+ $(use_enable ssl openssl) \
+ $(use_enable tcl tcl) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed."
+ dodoc AUTHORS README.md || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog
+ elog "Run 'znc --makeconf' as the user you want to run ZNC as"
+ elog "to make a configuration file"
+ elog "If you are using SSL you should also run 'znc --makepem'"
+ elog
+}