summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-03-03 23:51:31 +0000
committerAlex Alexander <wired@gentoo.org>2011-03-03 23:51:31 +0000
commite58a925a4b9f9f46b0858884f61c50f46ecdd276 (patch)
tree5dad9f9899c88e6308b89cd4b534a03246c2002b /net-irc/znc
parentRevbump installing libmumble symlink fixing bug #356525, thanks to Daniel Tro... (diff)
downloadgentoo-2-e58a925a4b9f9f46b0858884f61c50f46ecdd276.tar.gz
gentoo-2-e58a925a4b9f9f46b0858884f61c50f46ecdd276.tar.bz2
gentoo-2-e58a925a4b9f9f46b0858884f61c50f46ecdd276.zip
added upstream fix for the clearbuffersonmsg module that makes it ignore user joins and client logins, making it more useful.
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/znc')
-rw-r--r--net-irc/znc/ChangeLog9
-rw-r--r--net-irc/znc/files/znc-0.096-clearbuffersonmsg-fix.patch42
-rw-r--r--net-irc/znc/znc-0.096-r1.ebuild59
3 files changed, 109 insertions, 1 deletions
diff --git a/net-irc/znc/ChangeLog b/net-irc/znc/ChangeLog
index fbf4bcad6a6e..7d78a1124a32 100644
--- a/net-irc/znc/ChangeLog
+++ b/net-irc/znc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/znc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.47 2011/02/21 07:44:44 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.48 2011/03/03 23:51:31 wired Exp $
+
+*znc-0.096-r1 (03 Mar 2011)
+
+ 03 Mar 2011; Alex Alexander <wired@gentoo.org> +znc-0.096-r1.ebuild,
+ +files/znc-0.096-clearbuffersonmsg-fix.patch:
+ added upstream fix for the clearbuffersonmsg module that makes it ignore user
+ joins and client logins, making it more useful.
21 Feb 2011; Alex Alexander <wired@gentoo.org>
-files/znc-0.090-null-pointer-dereference-fix.patch,
diff --git a/net-irc/znc/files/znc-0.096-clearbuffersonmsg-fix.patch b/net-irc/znc/files/znc-0.096-clearbuffersonmsg-fix.patch
new file mode 100644
index 000000000000..23a8384ee0ca
--- /dev/null
+++ b/net-irc/znc/files/znc-0.096-clearbuffersonmsg-fix.patch
@@ -0,0 +1,42 @@
+From ddd302fbf549bac9cbd9b6675b145ddf0a802aa7 Mon Sep 17 00:00:00 2001
+From: cflakes <cflakes@726aef4b-f618-498e-8847-2d620e286838>
+Date: Sun, 23 Jan 2011 21:12:12 +0000
+Subject: [PATCH] clearbuffersonmsg module in znc-extra: removed OnUserJoin and OnClientLogin hooks. This means that those events will no longer clear the buffer and thereby make the module more useful. You can now e.g. use it to get all the benefits of KeepBuffer = true, but still have the buffer cleared whenever you do something (we assume that doing something means you have read all previous messages).
+
+https://github.com/znc/znc/commit/ddd302fbf549bac9cbd9b6675b145ddf0a802aa7
+---
+ modules/extra/clearbufferonmsg.cpp | 11 -----------
+ 1 files changed, 0 insertions(+), 11 deletions(-)
+
+diff --git a/modules/extra/clearbufferonmsg.cpp b/modules/extra/clearbufferonmsg.cpp
+index f0248b9..5ed6be7 100644
+--- a/modules/extra/clearbufferonmsg.cpp
++++ b/modules/extra/clearbufferonmsg.cpp
+@@ -51,11 +51,6 @@ public:
+ return CONTINUE;
+ }
+
+- virtual EModRet OnUserJoin(CString& sChannel, CString& sKey) {
+- ClearAllBuffers();
+- return CONTINUE;
+- }
+-
+ virtual EModRet OnUserPart(CString& sChannel, CString& sMessage) {
+ ClearAllBuffers();
+ return CONTINUE;
+@@ -65,12 +60,6 @@ public:
+ ClearAllBuffers();
+ return CONTINUE;
+ }
+-
+- virtual void OnClientLogin() {
+- ClearAllBuffers();
+- }
+-
+- // No OnClientDisconnect(), disconnect could be coming from e.g. a timeout
+ };
+
+ MODULEDEFS(CClearBufferOnMsgMod, "Clear all channel buffers whenever the user does something")
+--
+1.7.0.2
+
diff --git a/net-irc/znc/znc-0.096-r1.ebuild b/net-irc/znc/znc-0.096-r1.ebuild
new file mode 100644
index 000000000000..7f1c3582312f
--- /dev/null
+++ b/net-irc/znc/znc-0.096-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/znc-0.096-r1.ebuild,v 1.1 2011/03/03 23:51:31 wired Exp $
+
+EAPI=2
+
+inherit base
+
+DESCRIPTION="An advanced IRC Bouncer"
+HOMEPAGE="http://znc.sourceforge.net"
+SRC_URI="http://znc.in/releases/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="ares debug extras ipv6 perl ssl sasl tcl"
+
+RDEPEND="
+ ares? ( >=net-dns/c-ares-1.5 )
+ perl? ( dev-lang/perl )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ tcl? ( dev-lang/tcl )
+"
+DEPEND="
+ dev-util/pkgconfig
+ perl? ( dev-lang/swig )
+ ${RDEPEND}
+"
+PATCHES=(
+ # https://github.com/znc/znc/commit/ddd302fbf549bac9cbd9b6675b145ddf0a802aa7
+ "${FILESDIR}"/"${P}"-clearbuffersonmsg-fix.patch
+)
+
+src_configure() {
+ econf \
+ $(use_enable ares c-ares) \
+ $(use_enable debug) \
+ $(use_enable extras extra) \
+ $(use_enable ipv6) \
+ $(use_enable perl) \
+ $(use_enable sasl) \
+ $(use_enable ssl openssl) \
+ $(use_enable tcl tcl) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed."
+ dodoc AUTHORS README || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog
+ elog "Run 'znc --makeconf' as the user you want to run ZNC as"
+ elog "to make a configuration file"
+ elog "If you are using SSL you should also run 'znc --makepem'"
+ elog
+}