summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2006-10-19 23:46:22 +0000
committerMarkus Ullmann <jokey@gentoo.org>2006-10-19 23:46:22 +0000
commit26652b6260aaa2ddebdc18347ce717fed4a25edc (patch)
treeb5431d99e4a649573c8059bbd104c503ecd17d76 /net-irc
parentDepend on 1.1.2 version of flac, as the 1.1.3 version changes API. (diff)
downloadgentoo-2-26652b6260aaa2ddebdc18347ce717fed4a25edc.tar.gz
gentoo-2-26652b6260aaa2ddebdc18347ce717fed4a25edc.tar.bz2
gentoo-2-26652b6260aaa2ddebdc18347ce717fed4a25edc.zip
Fixing GCC4 wrt bug #140482 thanks to Ahmed Ammar for the patch
(Portage version: 2.1.2_pre3-r4)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchatosd/ChangeLog6
-rw-r--r--net-irc/xchatosd/files/digest-xchatosd-5.192
-rw-r--r--net-irc/xchatosd/files/xchatosd-5.19-gcc4.patch26
-rw-r--r--net-irc/xchatosd/xchatosd-5.19.ebuild3
4 files changed, 35 insertions, 2 deletions
diff --git a/net-irc/xchatosd/ChangeLog b/net-irc/xchatosd/ChangeLog
index 9b11e0f2c233..20224b7bc0a2 100644
--- a/net-irc/xchatosd/ChangeLog
+++ b/net-irc/xchatosd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/xchatosd
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchatosd/ChangeLog,v 1.19 2006/02/19 17:32:47 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchatosd/ChangeLog,v 1.20 2006/10/19 23:46:22 jokey Exp $
+
+ 19 Oct 2006; Markus Ullmann <jokey@gentoo.org>
+ +files/xchatosd-5.19-gcc4.patch, xchatosd-5.19.ebuild:
+ Fixing GCC4 wrt bug #140482 thanks to Ahmed Ammar for the patch
19 Feb 2006; Sven Wegener <swegener@gentoo.org> xchatosd-5.19.ebuild:
xchat-gnome and xchat are currently no longer compatible.
diff --git a/net-irc/xchatosd/files/digest-xchatosd-5.19 b/net-irc/xchatosd/files/digest-xchatosd-5.19
index ff846e84be3f..fe44f016218b 100644
--- a/net-irc/xchatosd/files/digest-xchatosd-5.19
+++ b/net-irc/xchatosd/files/digest-xchatosd-5.19
@@ -1 +1,3 @@
MD5 d95091553dc19e32aefb03ec46ab641d xchatosd-5.19.tar.gz 10778
+RMD160 dc5c1aa226144cf77c1039d7f86112cdd3e3cb76 xchatosd-5.19.tar.gz 10778
+SHA256 664c769a01fa52226b8a8dd45ee28f26caf8dc4d4ecf88f5d66623f701480f6f xchatosd-5.19.tar.gz 10778
diff --git a/net-irc/xchatosd/files/xchatosd-5.19-gcc4.patch b/net-irc/xchatosd/files/xchatosd-5.19-gcc4.patch
new file mode 100644
index 000000000000..cba347224e63
--- /dev/null
+++ b/net-irc/xchatosd/files/xchatosd-5.19-gcc4.patch
@@ -0,0 +1,26 @@
+--- xchatosd-5.19/my_xosd.h.orig 2006-07-15 14:12:55.000000000 +0100
++++ xchatosd-5.19/my_xosd.h 2006-07-15 14:13:04.000000000 +0100
+@@ -8,8 +8,8 @@
+
+ class XOsd {
+ public:
+- XOsd::XOsd(int);
+- XOsd::~XOsd();
++ XOsd(int);
++ ~XOsd();
+ int setPos(string);
+ int setVOffset(int);
+ int setHOffset(int);
+--- xchatosd-5.19/xchatosd_conf.h.orig 2006-07-15 14:05:09.000000000 +0100
++++ xchatosd-5.19/xchatosd_conf.h 2006-07-15 14:05:40.000000000 +0100
+@@ -11,8 +11,8 @@
+
+ class XOsdConf {
+ public:
+- XOsdConf::XOsdConf();
+- XOsdConf::~XOsdConf();
++ XOsdConf();
++ ~XOsdConf();
+ int read(string);
+ int write(string);
+ int getiValue(string);
diff --git a/net-irc/xchatosd/xchatosd-5.19.ebuild b/net-irc/xchatosd/xchatosd-5.19.ebuild
index 8fa0c98ebc31..b6c9469e5e54 100644
--- a/net-irc/xchatosd/xchatosd-5.19.ebuild
+++ b/net-irc/xchatosd/xchatosd-5.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchatosd/xchatosd-5.19.ebuild,v 1.4 2006/02/19 17:32:47 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchatosd/xchatosd-5.19.ebuild,v 1.5 2006/10/19 23:46:22 jokey Exp $
inherit toolchain-funcs flag-o-matic
@@ -23,6 +23,7 @@ src_unpack() {
# We have our own include file in /usr/include/xchat
einfo "Updating xchat-plugin.h from /usr/include/xchat/xchat-plugin.h"
cp -f "${ROOT}"/usr/include/xchat/xchat-plugin.h "${S}"/xchat-plugin.h
+ epatch "${FILESDIR}/${P}-gcc4.patch"
}
src_compile() {