summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2007-07-11 08:10:47 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2007-07-11 08:10:47 +0000
commit3705d8365847d6efe8b5b2ce2e9d5e18bbfd63e6 (patch)
treec5c321711e2e72c352475e225c06989bcfa315ed /net-irc
parentMore cleanup. (diff)
downloadgentoo-2-3705d8365847d6efe8b5b2ce2e9d5e18bbfd63e6.tar.gz
gentoo-2-3705d8365847d6efe8b5b2ce2e9d5e18bbfd63e6.tar.bz2
gentoo-2-3705d8365847d6efe8b5b2ce2e9d5e18bbfd63e6.zip
Use --logfile, bug 181243.
(Portage version: 2.1.2.9)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/inspircd/ChangeLog8
-rw-r--r--net-irc/inspircd/files/digest-inspircd-1.1.8-r13
-rw-r--r--net-irc/inspircd/files/init.d_inspircd6
-rw-r--r--net-irc/inspircd/inspircd-1.1.8-r1.ebuild79
4 files changed, 93 insertions, 3 deletions
diff --git a/net-irc/inspircd/ChangeLog b/net-irc/inspircd/ChangeLog
index f2df4dc187a2..73e0f20cef77 100644
--- a/net-irc/inspircd/ChangeLog
+++ b/net-irc/inspircd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/inspircd
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/ChangeLog,v 1.11 2007/07/10 19:20:45 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/ChangeLog,v 1.12 2007/07/11 08:10:47 hansmi Exp $
+
+*inspircd-1.1.8-r1 (11 Jul 2007)
+
+ 11 Jul 2007; Michael Hanselmann <hansmi@gentoo.org> files/init.d_inspircd,
+ +inspircd-1.1.8-r1.ebuild:
+ Use --logfile, bug 181243.
10 Jul 2007; Michael Hanselmann <hansmi@gentoo.org> files/init.d_inspircd:
Add "provide ircd".
diff --git a/net-irc/inspircd/files/digest-inspircd-1.1.8-r1 b/net-irc/inspircd/files/digest-inspircd-1.1.8-r1
new file mode 100644
index 000000000000..e4eebbd838de
--- /dev/null
+++ b/net-irc/inspircd/files/digest-inspircd-1.1.8-r1
@@ -0,0 +1,3 @@
+MD5 4ca1b55574e8d4abd86bbd2a6637dd2e InspIRCd-1.1.8.tar.bz2 484273
+RMD160 6e3b0c9b480fc523998f63cb9c4b033a5fd8ca0f InspIRCd-1.1.8.tar.bz2 484273
+SHA256 cf65aaf23d04dfe08770580bf095a6b7c7ae3051abdfeda7cd2fab1548626616 InspIRCd-1.1.8.tar.bz2 484273
diff --git a/net-irc/inspircd/files/init.d_inspircd b/net-irc/inspircd/files/init.d_inspircd
index b2555088e4e3..e7c022d921b8 100644
--- a/net-irc/inspircd/files/init.d_inspircd
+++ b/net-irc/inspircd/files/init.d_inspircd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/files/init.d_inspircd,v 1.2 2007/07/10 19:20:45 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/files/init.d_inspircd,v 1.3 2007/07/11 08:10:47 hansmi Exp $
opts="${opts} rehash"
@@ -12,7 +12,9 @@ depend() {
start() {
ebegin "Starting InspIRCd"
- start-stop-daemon --start --quiet --chuid inspircd --exec /usr/bin/inspircd &> /dev/null
+ start-stop-daemon --start --quiet --chuid inspircd \
+ --exec /usr/bin/inspircd -- \
+ --logfile /var/log/inspircd/ircd.log &>/dev/null
eend $?
}
diff --git a/net-irc/inspircd/inspircd-1.1.8-r1.ebuild b/net-irc/inspircd/inspircd-1.1.8-r1.ebuild
new file mode 100644
index 000000000000..0d1eda164992
--- /dev/null
+++ b/net-irc/inspircd/inspircd-1.1.8-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/inspircd-1.1.8-r1.ebuild,v 1.1 2007/07/11 08:10:47 hansmi Exp $
+
+inherit eutils toolchain-funcs multilib # subversion
+
+IUSE="openssl gnutls ipv6 kernel_linux"
+
+DESCRIPTION="InspIRCd - The Modular C++ IRC Daemon"
+HOMEPAGE="http://www.inspircd.org"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+RDEPEND="
+ >=sys-devel/gcc-3.3.0
+ >=dev-lang/perl-5.8
+ openssl? ( >=dev-libs/openssl-0.9.7d )
+ gnutls? ( >=net-libs/gnutls-1.3.0 )"
+DEPEND="${RDEPEND}"
+SRC_URI="mirror://sourceforge/${PN}/InspIRCd-${PV}.tar.bz2"
+#ESVN_REPO_URI="http://svn.inspircd.org/repository/trunk/inspircd"
+#ESVN_PROJECT="inspircd"
+
+S="${WORKDIR}/inspircd"
+
+pkg_setup() {
+ enewgroup inspircd
+ enewuser inspircd -1 -1 -1 inspircd
+}
+
+src_compile() {
+ local myconf=""
+
+ # Write a configuration file
+ # we don't use econf.
+ USE_SSL="$(use_enable openssl)"
+ use gnutls && USE_SSL="$(use_enable gnutls)"
+ USE_SOCKET_ENGINE="--enable-epoll"
+ ./configure $(use_enable ipv6) --enable-remote-ipv6 ${USE_SSL} \
+ ${USE_SOCKET_ENGINE} \
+ --prefix="/usr/$(get_libdir)/inspircd" \
+ --config-dir="/etc/inspircd" --bin-dir="/usr/bin" \
+ --library-dir="/usr/$(get_libdir)/inspircd" \
+ --module-dir="/usr/$(get_libdir)/inspircd/modules" \
+ || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ # the inspircd buildsystem does not create these, it's configure script
+ # does. so, we have to at this point to make sure they are there.
+ dodir /usr/$(get_libdir)/inspircd
+ dodir /usr/$(get_libdir)/inspircd/modules
+ dodir /etc/inspircd
+ dodir /var/log/inspircd
+
+ emake install \
+ LIBPATH="${D}/usr/$(get_libdir)/inspircd/" \
+ MODPATH="${D}/usr/$(get_libdir)/inspircd/modules/" \
+ CONPATH="${D}/etc/inspircd" \
+ BINPATH="${D}/usr/bin" \
+ BASE="${D}/usr/$(get_libdir)/inspircd/inspircd.launcher"
+
+ newinitd "${FILESDIR}"/init.d_inspircd inspircd
+}
+
+pkg_postinst() {
+ chown -R inspircd:inspircd "${ROOT}"/etc/inspircd
+ chmod 700 "${ROOT}"/etc/inspircd
+
+ chmod 750 "${ROOT}"/var/log/inspircd
+ chown -R inspircd:inspircd "${ROOT}"/var/log/inspircd
+
+ chown -R inspircd:inspircd "${ROOT}"/usr/$(get_libdir)/inspircd
+ chmod -R 755 "${ROOT}"/usr/$(get_libdir)/inspircd
+
+ chmod -R 755 "${ROOT}"/usr/bin/inspircd
+}