summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-10-10 12:06:29 +0000
committerAli Polatel <hawking@gentoo.org>2008-10-10 12:06:29 +0000
commit3c4c97364b4fc206a62829a4b7c4cc41f864c8d1 (patch)
tree9861ccf646010be98b6d1e39554af920185b8dba /net-irc
parentconfigure needed no fixing. (diff)
downloadgentoo-2-3c4c97364b4fc206a62829a4b7c4cc41f864c8d1.tar.gz
gentoo-2-3c4c97364b4fc206a62829a4b7c4cc41f864c8d1.tar.bz2
gentoo-2-3c4c97364b4fc206a62829a4b7c4cc41f864c8d1.zip
Revbump. Respect {C,CXX,LD}FLAGS, bug 241030. Install docs properly. Drop old.
(Portage version: -svn/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/bip/ChangeLog9
-rw-r--r--net-irc/bip/bip-0.7.4-r1.ebuild (renamed from net-irc/bip/bip-0.7.4.ebuild)18
2 files changed, 18 insertions, 9 deletions
diff --git a/net-irc/bip/ChangeLog b/net-irc/bip/ChangeLog
index 5b79a2fcdd8c..abe32cfb0c75 100644
--- a/net-irc/bip/ChangeLog
+++ b/net-irc/bip/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/bip
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/ChangeLog,v 1.2 2008/08/31 10:05:17 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/ChangeLog,v 1.3 2008/10/10 12:06:29 hawking Exp $
+
+*bip-0.7.4-r1 (10 Oct 2008)
+
+ 10 Oct 2008; Ali Polatel <hawking@gentoo.org> -bip-0.7.4.ebuild,
+ +bip-0.7.4-r1.ebuild:
+ Revbump. Respect {C,CXX,LD}FLAGS, bug 241030. Install docs properly.
+ Drop old.
*bip-0.7.4 (31 Aug 2008)
diff --git a/net-irc/bip/bip-0.7.4.ebuild b/net-irc/bip/bip-0.7.4-r1.ebuild
index 54e85f3cd0d2..4dad7e284e53 100644
--- a/net-irc/bip/bip-0.7.4.ebuild
+++ b/net-irc/bip/bip-0.7.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/bip-0.7.4.ebuild,v 1.1 2008/08/31 10:05:17 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/bip-0.7.4-r1.ebuild,v 1.1 2008/10/10 12:06:29 hawking Exp $
DESCRIPTION="Multiuser IRC proxy with ssl support"
HOMEPAGE="http://bip.t1r.net/"
@@ -19,21 +19,23 @@ RDEPEND="${DEPEND}
src_compile() {
econf $(use_enable ssl)
# Parallel make fails.
- emake -j1 || die "emake failed"
+ # {C,CXX,LD}FLAGS aren't respected, bug 241030.
+ emake CFLAGS="${CFLAGS}" CPPFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" -j1 || die "emake failed"
}
src_install() {
- dobin src/bip src/bipmkpw
+ dobin src/bip src/bipmkpw || die "dobin failed"
- dodoc AUTHORS ChangeLog README README.floodcontrol NEWS TODO
- newdoc samples/bip.conf bip.conf.sample
- doman bip.1 bip.conf.1 bipmkpw.1
+ dodoc AUTHORS ChangeLog README NEWS TODO || die "dodoc failed"
+ newdoc samples/bip.conf bip.conf.sample || die "newdoc failed"
+ doman bip.1 bip.conf.5 bipmkpw.1 || die "doman failed"
if use vim-syntax; then
insinto /usr/share/vim/vimfiles/syntax
- doins samples/bip.vim
+ doins samples/bip.vim || die "doins failed"
insinto /usr/share/vim/vimfiles/ftdetect
- doins "${FILESDIR}"/bip.vim
+ doins "${FILESDIR}"/bip.vim || die "doins failed"
fi
}