summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2006-01-02 07:11:23 +0000
committerSven Wegener <swegener@gentoo.org>2006-01-02 07:11:23 +0000
commit448143c8a61f1aab18f3cec51800bf58e6baa231 (patch)
treed9ee13d233471ea7c7e27faaee58ab95b45d5ca9 /net-irc
parentapp-admin/eselect-compiler won't be ready for 2006.0, so removing it... (diff)
downloadgentoo-2-448143c8a61f1aab18f3cec51800bf58e6baa231.tar.gz
gentoo-2-448143c8a61f1aab18f3cec51800bf58e6baa231.tar.bz2
gentoo-2-448143c8a61f1aab18f3cec51800bf58e6baa231.zip
Pull in a patch to build xchat with dbus-0.60.
(Portage version: 2.0.53)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/ChangeLog8
-rw-r--r--net-irc/xchat/files/2.6.0-dbus-0.60-support.patch16
-rw-r--r--net-irc/xchat/xchat-2.6.0.ebuild5
3 files changed, 25 insertions, 4 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 374fa3766760..d7bd31049ffb 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/xchat
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.188 2005/12/26 06:41:59 josejx Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.189 2006/01/02 07:11:23 swegener Exp $
+
+ 02 Jan 2006; Sven Wegener <swegener@gentoo.org>
+ +files/2.6.0-dbus-0.60-support.patch, xchat-2.6.0.ebuild:
+ Pull in a patch to build xchat with dbus-0.60.
26 Dec 2005; Joseph Jezak <josejx@gentoo.org> xchat-2.4.5-r1.ebuild:
Marked ppc stable for bug #109744.
diff --git a/net-irc/xchat/files/2.6.0-dbus-0.60-support.patch b/net-irc/xchat/files/2.6.0-dbus-0.60-support.patch
new file mode 100644
index 000000000000..ac562e7e41e8
--- /dev/null
+++ b/net-irc/xchat/files/2.6.0-dbus-0.60-support.patch
@@ -0,0 +1,16 @@
+--- plugins/dbus/dbus-plugin.c.orig 2006-01-02 07:03:53.323758200 +0000
++++ plugins/dbus/dbus-plugin.c 2006-01-02 07:03:29.542130167 +0000
+@@ -152,7 +152,12 @@
+
+ if (!dbus_g_proxy_call (bus_proxy, "RequestName", &error,
+ G_TYPE_STRING, DBUS_SERVICE,
+- G_TYPE_UINT, DBUS_NAME_FLAG_PROHIBIT_REPLACEMENT,
++ G_TYPE_UINT,
++#if (DBUS_VERSION_MAJOR == 0) && (DBUS_VERSION_MINOR >= 60)
++ DBUS_NAME_FLAG_DO_NOT_QUEUE,
++#else
++ DBUS_NAME_FLAG_PROHIBIT_REPLACEMENT,
++#endif
+ G_TYPE_INVALID,
+ G_TYPE_UINT, &request_name_result,
+ G_TYPE_INVALID))
diff --git a/net-irc/xchat/xchat-2.6.0.ebuild b/net-irc/xchat/xchat-2.6.0.ebuild
index bae2d72ce89a..93aefde7b2ec 100644
--- a/net-irc/xchat/xchat-2.6.0.ebuild
+++ b/net-irc/xchat/xchat-2.6.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.6.0.ebuild,v 1.5 2005/11/05 15:10:51 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.6.0.ebuild,v 1.6 2006/01/02 07:11:23 swegener Exp $
inherit eutils versionator
@@ -38,6 +38,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/xc260-fix-fetext.diff
+ epatch "${FILESDIR}"/${PV}-dbus-0.60-support.patch
# use libdir/xchat/plugins as the plugin directory
if [ $(get_libdir) != "lib" ] ; then