summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-08-27 10:14:46 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-08-27 10:14:46 +0000
commit82f0ed193068a186fa0dca161c387aed1b308b00 (patch)
treec511b4690f8f40d341640a1d73135b6bb33d33ac /net-irc
parentnew help2man dependency (diff)
downloadgentoo-2-82f0ed193068a186fa0dca161c387aed1b308b00.tar.gz
gentoo-2-82f0ed193068a186fa0dca161c387aed1b308b00.tar.bz2
gentoo-2-82f0ed193068a186fa0dca161c387aed1b308b00.zip
Inherit git only when we have live ebuild. This allows us ebuild renaming :)
(Portage version: 2.2_rc68/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/quassel/ChangeLog6
-rw-r--r--net-irc/quassel/quassel-9999.ebuild13
2 files changed, 12 insertions, 7 deletions
diff --git a/net-irc/quassel/ChangeLog b/net-irc/quassel/ChangeLog
index ba43530d5a1f..1982d6749876 100644
--- a/net-irc/quassel/ChangeLog
+++ b/net-irc/quassel/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/quassel
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.100 2010/08/27 10:05:57 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.101 2010/08/27 10:14:46 scarabeus Exp $
+
+ 27 Aug 2010; Tomáš Chvátal <scarabeus@gentoo.org> quassel-9999.ebuild:
+ Inherit git only when we have live ebuild. This allows us ebuild renaming
+ :)
27 Aug 2010; Tomáš Chvátal <scarabeus@gentoo.org> quassel-9999.ebuild:
Actualy use eapi3 since we already have some prefix keywords.
diff --git a/net-irc/quassel/quassel-9999.ebuild b/net-irc/quassel/quassel-9999.ebuild
index e48c31eb68b4..c290937d9685 100644
--- a/net-irc/quassel/quassel-9999.ebuild
+++ b/net-irc/quassel/quassel-9999.ebuild
@@ -1,13 +1,17 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-9999.ebuild,v 1.47 2010/08/27 10:05:57 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-9999.ebuild,v 1.48 2010/08/27 10:14:46 scarabeus Exp $
EAPI=3
-inherit cmake-utils eutils git
-
EGIT_REPO_URI="git://git.quassel-irc.org/quassel.git"
EGIT_BRANCH="master"
+[[ "${PV}" == "9999" ]] && GIT_ECLASS="git"
+
+QT_MINIMAL="4.6.0"
+KDE_MINIMAL="4.4"
+
+inherit cmake-utils eutils ${GIT_ECLASS}
DESCRIPTION="Qt4/KDE4 IRC client suppporting a remote daemon for 24/7 connectivity."
HOMEPAGE="http://quassel-irc.org/"
@@ -17,9 +21,6 @@ KEYWORDS=""
SLOT="0"
IUSE="ayatana crypt dbus debug kde monolithic phonon postgres +server +ssl webkit X"
-QT_MINIMAL="4.6.0"
-KDE_MINIMAL="4.4"
-
SERVER_RDEPEND="
crypt? ( app-crypt/qca:2 )
!postgres? ( >=x11-libs/qt-sql-${QT_MINIMAL}:4[sqlite] dev-db/sqlite[threadsafe] )