summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé María Alonso <nimiux@gentoo.org>2013-02-19 22:33:07 +0000
committerJosé María Alonso <nimiux@gentoo.org>2013-02-19 22:33:07 +0000
commitfcb1fbe8a379e041a23b9ea3af1d7d7eb8eb7cba (patch)
treee6263607a95ceeef0f6adc0114c106fa72a9015f /net-irc
parentVersion bump to latest stable release (diff)
downloadgentoo-2-fcb1fbe8a379e041a23b9ea3af1d7d7eb8eb7cba.tar.gz
gentoo-2-fcb1fbe8a379e041a23b9ea3af1d7d7eb8eb7cba.tar.bz2
gentoo-2-fcb1fbe8a379e041a23b9ea3af1d7d7eb8eb7cba.zip
Move to EAPI5. Add pcre, posix and tre flags wrt bug #457654
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key D628E536)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/inspircd/ChangeLog8
-rw-r--r--net-irc/inspircd/inspircd-2.0.10-r1.ebuild102
-rw-r--r--net-irc/inspircd/metadata.xml3
3 files changed, 112 insertions, 1 deletions
diff --git a/net-irc/inspircd/ChangeLog b/net-irc/inspircd/ChangeLog
index 45813995f886..4a54fdda7071 100644
--- a/net-irc/inspircd/ChangeLog
+++ b/net-irc/inspircd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/inspircd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/ChangeLog,v 1.69 2013/02/19 15:11:07 nimiux Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/ChangeLog,v 1.70 2013/02/19 22:33:07 nimiux Exp $
+
+*inspircd-2.0.10-r1 (19 Feb 2013)
+
+ 19 Feb 2013; Chema Alonso <nimiux@gentoo.org> +inspircd-2.0.10-r1.ebuild,
+ metadata.xml:
+ Move to EAPI5. Add pcre, posix and tre flags wrt bug #457654
19 Feb 2013; Chema Alonso <nimiux@gentoo.org>
-files/inspircd-2.0.8-fix-path-builds.patch, -files/inspircd-2.0.8-init,
diff --git a/net-irc/inspircd/inspircd-2.0.10-r1.ebuild b/net-irc/inspircd/inspircd-2.0.10-r1.ebuild
new file mode 100644
index 000000000000..a1cef338f364
--- /dev/null
+++ b/net-irc/inspircd/inspircd-2.0.10-r1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/inspircd-2.0.10-r1.ebuild,v 1.1 2013/02/19 22:33:07 nimiux Exp $
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Inspire IRCd - The Stable, High-Performance Modular IRCd"
+HOMEPAGE="http://inspircd.github.com/"
+SRC_URI="http://www.github.com/inspircd/inspircd/archive/v${PV}.tar.gz ->
+${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="geoip gnutls ipv6 ldap mysql pcre posix postgres sqlite ssl tre"
+
+RDEPEND="
+ dev-lang/perl
+ ssl? ( dev-libs/openssl )
+ geoip? ( dev-libs/geoip )
+ gnutls? ( net-libs/gnutls dev-libs/libgcrypt )
+ ldap? ( net-nds/openldap )
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql-server )
+ pcre? ( dev-libs/libpcre )
+ sqlite? ( >=dev-db/sqlite-3.0 )
+ tre? ( dev-libs/tre )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_prepare() {
+ # Patch the inspircd launcher with the inspircd user
+ sed -i -e "s/@UID@/${PN}/" "${S}/make/template/${PN}" || die
+
+ epatch "${FILESDIR}/${P}-fix-path-builds.patch"
+}
+
+src_configure() {
+ local extras=""
+
+ use geoip && extras="${extras}m_geoip.cpp,"
+ use ldap && extras="${extras}m_ldapauth.cpp,m_ldapoper.cpp,"
+ use mysql && extras="${extras}m_mysql.cpp,"
+ use pcre && extras="${extras}m_regex_pcre.cpp,"
+ use posix && extras="${extras}m_regex_posix.cpp,"
+ use postgres && extras="${extras}m_pgsql.cpp,"
+ use sqlite && extras="${extras}m_sqlite3.cpp,"
+ use tre && extras="${extras}m_regex_tre.cpp,"
+
+ if [ -n "${extras}" ]; then
+ ./configure --disable-interactive --enable-extras=${extras}
+ fi
+
+ ./configure \
+ --with-cc="$(tc-getCXX)" \
+ --disable-interactive \
+ --prefix="/usr/$(get_libdir)/${PN}" \
+ --config-dir="/etc/${PN}" \
+ --data-dir="/var/lib/${PN}/data" \
+ --log-dir="/var/log/${PN}" \
+ --binary-dir="/usr/bin" \
+ --module-dir="/usr/$(get_libdir)/${PN}/modules" \
+ $(use_enable ssl openssl) $(use_enable gnutls) \
+ $(use_enable ipv6)
+}
+
+src_compile() {
+ emake V=1 LDFLAGS="${LDFLAGS}" CXXFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ emake INSTUID=${PN} \
+ BINPATH="${D}/usr/bin" \
+ BASE="${D}/usr/$(get_libdir)/${PN}/inspircd.launcher" \
+ MODPATH="${D}/usr/$(get_libdir)/${PN}/modules/" \
+ CONPATH="${D}/etc/${PN}" install
+
+ insinto "/usr/include/${PN}"
+ doins include/*
+
+ diropts -o"${PN}" -g"${PN}" -m0700
+ dodir "/var/lib/${PN}"
+ dodir "/var/lib/${PN}/data"
+
+ newinitd "${FILESDIR}/${P}-init" "${PN}"
+ keepdir "/var/log/${PN}"/
+}
+
+pkg_postinst() {
+ elog "Before starting ${PN} the first time, you should create"
+ elog "the /etc/${PN}/${PN}.conf file."
+ elog "You can find example configuration files under /etc/${PN}"
+ elog "Read the ${PN}.conf.example file carefully before "
+ elog "(re)starting the service."
+ elog
+}
diff --git a/net-irc/inspircd/metadata.xml b/net-irc/inspircd/metadata.xml
index bbaab833285b..eb2ec7557702 100644
--- a/net-irc/inspircd/metadata.xml
+++ b/net-irc/inspircd/metadata.xml
@@ -26,8 +26,11 @@
<flag name="ipv6">Enable support for IP version 6</flag>
<flag name="ldap">Enable LDAP support</flag>
<flag name="mysql">Enable MySQL database backend</flag>
+ <flag name="pcre">Adds support for Perl Compatible Regular Expressions</flag>
+ <flag name="posix">Adds support for POSIX-compatible functions</flag>
<flag name="postgres">Enable PostgreSQL database backend</flag>
<flag name="sqlite">Enable Sqlite database backend</flag>
<flag name="ssl">Enable SSL support</flag>
+ <flag name="tre">Enable support for TRE, a lightweight, robust, and efficient POSIX compliant regexp matching library</flag>
</use>
</pkgmetadata>