summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-09-19 20:30:16 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-09-19 20:30:16 +0000
commit0dd86e491e3f158136f716063690fd154b46e61c (patch)
tree78b702b0b998951b5239901a26dc8e46df2c6a6b /net-libs/gnutls/gnutls-1.4.4-r1.ebuild
parentFixing Manifest/digests due to bug #147628. (diff)
downloadgentoo-2-0dd86e491e3f158136f716063690fd154b46e61c.tar.gz
gentoo-2-0dd86e491e3f158136f716063690fd154b46e61c.tar.bz2
gentoo-2-0dd86e491e3f158136f716063690fd154b46e61c.zip
fixed selflink patch thanks to Alon Bar-Lev in bug #147800
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'net-libs/gnutls/gnutls-1.4.4-r1.ebuild')
-rw-r--r--net-libs/gnutls/gnutls-1.4.4-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-libs/gnutls/gnutls-1.4.4-r1.ebuild b/net-libs/gnutls/gnutls-1.4.4-r1.ebuild
new file mode 100644
index 000000000000..a1ba86883039
--- /dev/null
+++ b/net-libs/gnutls/gnutls-1.4.4-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-1.4.4-r1.ebuild,v 1.1 2006/09/19 20:30:16 dragonheart Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="A TLS 1.0 and SSL 3.0 implementation for the GNU project"
+HOMEPAGE="http://www.gnutls.org/"
+SRC_URI="http://josefsson.org/gnutls/releases/${P}.tar.bz2"
+
+# GPL-2 for the gnutls-extras library and LGPL for the gnutls library.
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="zlib doc"
+
+RDEPEND=">=dev-libs/libgcrypt-1.2.2
+ >=app-crypt/opencdk-0.5.5
+ zlib? ( >=sys-libs/zlib-1.1 )
+ virtual/libc
+ >=dev-libs/lzo-2
+ dev-libs/libgpg-error
+ >=dev-libs/libtasn1-0.3.4
+ sys-devel/gettext"
+#>=sys-devel/gettext-0.14.5" autoconf indicates this version but it works
+# without it
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ doc? ( dev-util/gtk-doc )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-selflink.patch
+ elibtoolize
+ eautomake
+}
+
+src_compile() {
+ local myconf=""
+
+ econf \
+ $(use_with zlib) \
+ --without-included-minilzo \
+ --without-included-opencdk \
+ $(use_enable doc gtk-doc) \
+ ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS \
+ README THANKS doc/TODO
+
+ if use doc ; then
+ dodoc doc/README.autoconf doc/tex/gnutls.ps
+ docinto examples
+ dodoc doc/examples/*.c
+ fi
+}