summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-03-16 22:49:41 +0000
committerTim Harder <radhermit@gentoo.org>2012-03-16 22:49:41 +0000
commit80cd8de2086a0450167a113088c9cfd462cf1444 (patch)
treeda80c485061a2e8d853f7a9e092ac32a69a89c53 /net-libs/gnutls
parentMoved from my overlay. Bug #338804. Thanks to Florian Knodt <f.knodt@yotaweb.... (diff)
downloadgentoo-2-80cd8de2086a0450167a113088c9cfd462cf1444.tar.gz
gentoo-2-80cd8de2086a0450167a113088c9cfd462cf1444.tar.bz2
gentoo-2-80cd8de2086a0450167a113088c9cfd462cf1444.zip
Version bump.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/gnutls')
-rw-r--r--net-libs/gnutls/ChangeLog7
-rw-r--r--net-libs/gnutls/gnutls-2.12.18.ebuild126
2 files changed, 132 insertions, 1 deletions
diff --git a/net-libs/gnutls/ChangeLog b/net-libs/gnutls/ChangeLog
index 30f36dc22326..602ed48ea43a 100644
--- a/net-libs/gnutls/ChangeLog
+++ b/net-libs/gnutls/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gnutls
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.337 2012/03/16 21:33:48 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.338 2012/03/16 22:49:41 radhermit Exp $
+
+*gnutls-2.12.18 (16 Mar 2012)
+
+ 16 Mar 2012; Tim Harder <radhermit@gentoo.org> +gnutls-2.12.18.ebuild:
+ Version bump.
16 Mar 2012; Tim Harder <radhermit@gentoo.org> gnutls-2.12.17.ebuild:
Keyword newer version for ~ppc64 as well.
diff --git a/net-libs/gnutls/gnutls-2.12.18.ebuild b/net-libs/gnutls/gnutls-2.12.18.ebuild
new file mode 100644
index 000000000000..8aaa4dba42df
--- /dev/null
+++ b/net-libs/gnutls/gnutls-2.12.18.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.12.18.ebuild,v 1.1 2012/03/16 22:49:41 radhermit Exp $
+
+EAPI=4
+
+inherit autotools libtool eutils
+
+DESCRIPTION="A TLS 1.2 and SSL 3.0 implementation for the GNU project"
+HOMEPAGE="http://www.gnutls.org/"
+
+if [[ "${PV}" == *pre* ]]; then
+ SRC_URI="http://daily.josefsson.org/${P%.*}/${P%.*}-${PV#*pre}.tar.gz"
+else
+ MINOR_VERSION="${PV#*.}"
+ MINOR_VERSION="${MINOR_VERSION%%.*}"
+ if [[ $((MINOR_VERSION % 2)) == 0 ]]; then
+ #SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+ else
+ SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.bz2"
+ fi
+ unset MINOR_VERSION
+fi
+
+# LGPL-2.1 for libgnutls library and GPL-3 for libgnutls-extra library.
+LICENSE="GPL-3 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="bindist +cxx doc examples guile lzo +nettle nls pkcs11 static-libs test zlib"
+
+RDEPEND=">=dev-libs/libtasn1-0.3.4
+ guile? ( >=dev-scheme/guile-1.8[networking] )
+ nettle? ( >=dev-libs/nettle-2.1[gmp] )
+ !nettle? ( >=dev-libs/libgcrypt-1.4.0 )
+ nls? ( virtual/libintl )
+ pkcs11? ( app-crypt/p11-kit )
+ zlib? ( >=sys-libs/zlib-1.2.3.1 )
+ !bindist? ( lzo? ( >=dev-libs/lzo-2 ) )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ doc? ( dev-util/gtk-doc )
+ nls? ( sys-devel/gettext )
+ test? ( app-misc/datefudge )"
+
+S="${WORKDIR}/${P%_pre*}"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS doc/TODO )
+
+pkg_setup() {
+ if use lzo && use bindist; then
+ ewarn "lzo support is disabled for binary distribution of GnuTLS due to licensing issues."
+ fi
+}
+
+src_prepare() {
+ # tests/suite directory is not distributed.
+ sed -i -e 's|AC_CONFIG_FILES(\[tests/suite/Makefile\])|:|' \
+ configure.ac || die
+
+ sed -i -e 's/imagesdir = $(infodir)/imagesdir = $(htmldir)/' \
+ doc/Makefile.am || die
+
+ local dir
+ for dir in m4 lib/m4 libextra/m4; do
+ rm -f "${dir}/lt"* "${dir}/libtool.m4"
+ done
+ find . -name ltmain.sh -exec rm {} \;
+
+ # support user patches
+ epatch_user
+
+ for dir in . lib libextra; do
+ pushd "${dir}" > /dev/null
+ eautoreconf
+ popd > /dev/null
+ done
+
+ # Use sane .so versioning on FreeBSD.
+ elibtoolize
+}
+
+src_configure() {
+ local myconf
+ use bindist && myconf="--without-lzo" || myconf="$(use_with lzo)"
+ [[ "${VALGRIND_TESTS}" != "1" ]] && myconf+=" --disable-valgrind-tests"
+
+ econf \
+ --htmldir=/usr/share/doc/${P}/html \
+ $(use_enable cxx) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable doc gtk-doc-pdf) \
+ $(use_enable guile) \
+ $(use_with !nettle libgcrypt) \
+ $(use_enable nls) \
+ $(use_with pkcs11 p11-kit) \
+ $(use_enable static-libs static) \
+ $(use_with zlib) \
+ ${myconf}
+}
+
+src_test() {
+ if has_version dev-util/valgrind && [[ ${VALGRIND_TESTS} != 1 ]]; then
+ elog
+ elog "You can set VALGRIND_TESTS=\"1\" to enable Valgrind tests."
+ elog
+ fi
+
+ default
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ if use doc; then
+ dodoc doc/gnutls.{pdf,ps}
+ dohtml doc/gnutls.html
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc doc/examples/*.c
+ fi
+}