summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-10-19 07:40:28 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-10-19 07:40:28 +0000
commit540918434ca6cab2d8e2746579e8f03beb400f68 (patch)
tree9c3d9294f0dc778aadcf5bc95809263acc20ce2e /net-libs/libhttpd-persistent/libhttpd-persistent-1.3p-r8.ebuild
parentStable on amd64. (Manifest recommit) (diff)
downloadgentoo-2-540918434ca6cab2d8e2746579e8f03beb400f68.tar.gz
gentoo-2-540918434ca6cab2d8e2746579e8f03beb400f68.tar.bz2
gentoo-2-540918434ca6cab2d8e2746579e8f03beb400f68.zip
Removing old versions. Using toolchain-funs eclass now where it works.
Diffstat (limited to 'net-libs/libhttpd-persistent/libhttpd-persistent-1.3p-r8.ebuild')
-rw-r--r--net-libs/libhttpd-persistent/libhttpd-persistent-1.3p-r8.ebuild26
1 files changed, 20 insertions, 6 deletions
diff --git a/net-libs/libhttpd-persistent/libhttpd-persistent-1.3p-r8.ebuild b/net-libs/libhttpd-persistent/libhttpd-persistent-1.3p-r8.ebuild
index 7bd5ec0e2636..f5d7ebd8709c 100644
--- a/net-libs/libhttpd-persistent/libhttpd-persistent-1.3p-r8.ebuild
+++ b/net-libs/libhttpd-persistent/libhttpd-persistent-1.3p-r8.ebuild
@@ -1,18 +1,22 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libhttpd-persistent/libhttpd-persistent-1.3p-r8.ebuild,v 1.2 2004/09/22 17:50:23 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libhttpd-persistent/libhttpd-persistent-1.3p-r8.ebuild,v 1.3 2004/10/19 07:40:28 eradicator Exp $
IUSE=""
+inherit toolchain-funcs
+
MY_P="libhttpd-1.3p-h"
S="${WORKDIR}/libhttpd-1.3-persistent-h"
DESCRIPTION="libhttpd-persistent is a modified version of David Hughes' libhttpd."
HOMEPAGE="http://www.deleet.de/projekte/daap/daapd/"
SRC_URI="http://www.deleet.de/projekte/daap/daapd/${MY_P}.tgz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc amd64 sparc"
+
DEPEND=""
src_compile() {
@@ -22,19 +26,29 @@ src_compile() {
cd ${S}/src
CFILES="protocol.c api.c version.c ip_acl.c select.c"
+ LOFILES=${CFILES//.c/.lo}
OFILES=${CFILES//.c/.o}
for FILE in ${CFILES}; do
- echo g++ ${CFLAGS} -D_OS_UNIX -fPIC -c ${FILE}
- g++ ${CFLAGS} -D_OS_UNIX -fPIC -c ${FILE} || die
+ echo $(tc-getCXX) ${CFLAGS} -D_OS_UNIX -c ${FILE} -o ${FILE//.c/.o}
+ $(tc-getCXX) ${CFLAGS} -D_OS_UNIX -c ${FILE} -o ${FILE//.c/.o} || die
+ echo $(tc-getCXX) ${CFLAGS} -D_OS_UNIX -fPIC -c ${FILE} -o ${FILE//.c/.lo}
+ $(tc-getCXX) ${CFLAGS} -D_OS_UNIX -fPIC -c ${FILE} -o ${FILE//.c/.lo} || die
done
- echo "linking"
+# echo $(tc-getAR) rc libhttpd-persistent.a ${OFILES} || die
+# $(tc-getAR) rc libhttpd-persistent.a ${OFILES} || die
+# echo $(tc-getRANLIB) libhttpd-persistent.a || die
+# $(tc-getRANLIB) libhttpd-persistent.a || die
+ echo ar rc libhttpd-persistent.a ${OFILES} || die
ar rc libhttpd-persistent.a ${OFILES} || die
+ echo ranlib libhttpd-persistent.a || die
ranlib libhttpd-persistent.a || die
- g++ -shared -Wl,-shared,-soname,libhttpd-persistent.so \
- ${OFILES} -o libhttpd-persistent.so || die
+ echo $(tc-getCXX) -shared -Wl,-shared,-soname,libhttpd-persistent.so \
+ ${LOFILES} -o libhttpd-persistent.so || die
+ $(tc-getCXX) -shared -Wl,-shared,-soname,libhttpd-persistent.so \
+ ${LOFILES} -o libhttpd-persistent.so || die
}
src_install() {