summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-09-04 18:07:20 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-09-04 18:07:20 +0000
commit192e89de9e6db5e4b27d97df579bd48d63f0c5e7 (patch)
tree4caca95a199ce4070078783c43f254eba0eefa8b /net-libs/libktorrent
parentAdd support for cleaned /var/run on startup by Xake and i.Dark_Templar (bug #... (diff)
downloadgentoo-2-192e89de9e6db5e4b27d97df579bd48d63f0c5e7.tar.gz
gentoo-2-192e89de9e6db5e4b27d97df579bd48d63f0c5e7.tar.bz2
gentoo-2-192e89de9e6db5e4b27d97df579bd48d63f0c5e7.zip
Version bump
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libktorrent')
-rw-r--r--net-libs/libktorrent/ChangeLog8
-rw-r--r--net-libs/libktorrent/libktorrent-1.1.2.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/net-libs/libktorrent/ChangeLog b/net-libs/libktorrent/ChangeLog
index e82313dd30af..a050c4d3a508 100644
--- a/net-libs/libktorrent/ChangeLog
+++ b/net-libs/libktorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libktorrent
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libktorrent/ChangeLog,v 1.22 2011/06/01 22:21:33 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libktorrent/ChangeLog,v 1.23 2011/09/04 18:07:20 dilfridge Exp $
+
+*libktorrent-1.1.2 (04 Sep 2011)
+
+ 04 Sep 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +libktorrent-1.1.2.ebuild:
+ Version bump
01 Jun 2011; Andreas K. Huettel <dilfridge@gentoo.org>
-libktorrent-1.0.5.3.ebuild:
diff --git a/net-libs/libktorrent/libktorrent-1.1.2.ebuild b/net-libs/libktorrent/libktorrent-1.1.2.ebuild
new file mode 100644
index 000000000000..0984184208c9
--- /dev/null
+++ b/net-libs/libktorrent/libktorrent-1.1.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libktorrent/libktorrent-1.1.2.ebuild,v 1.1 2011/09/04 18:07:20 dilfridge Exp $
+
+EAPI=4
+
+KDE_SCM="git"
+if [[ ${PV} != 9999* ]]; then
+ inherit versionator
+ # upstream likes to skip that _ in beta releases
+ MY_PV="${PV/_/}"
+ KTORRENT_VERSION=$(($(get_major_version)+3)).$(get_version_component_range 2-3 ${MY_PV})
+ MY_P="${PN}-${MY_PV}"
+ KDE_HANDBOOK="optional"
+ KDE_DOC_DIRS="doc"
+
+ KDE_LINGUAS="ar ast be bg ca ca@valencia cs da de el en_GB eo es et eu
+ fi fr ga gl hi hne hr hu is it ja km ku lt lv ms nb nds nl nn oc pl
+ pt pt_BR ro ru se si sk sl sr sr@ijekavian sr@ijekavianlatin
+ sr@latin sv tr uk zh_CN zh_TW"
+ SRC_URI="http://ktorrent.org/downloads/${KTORRENT_VERSION}/${MY_P}.tar.bz2"
+ S="${WORKDIR}"/"${MY_P}"
+
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+else
+ KEYWORDS=""
+fi
+VIRTUALX_REQUIRED=test
+inherit kde4-base
+
+DESCRIPTION="A BitTorrent library based on KDE Platform"
+HOMEPAGE="http://ktorrent.org/"
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="debug"
+
+RDEPEND="
+ app-crypt/qca:2
+ dev-libs/gmp
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ sys-devel/gettext
+"
+
+src_prepare() {
+ kde4-base_src_prepare
+ # do not build non-installed example binary
+ sed -i -e '/add_subdirectory(examples)/d' CMakeLists.txt || die
+}