summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-12-16 17:30:38 +0000
committerJeroen Roovers <jer@gentoo.org>2011-12-16 17:30:38 +0000
commit7dba32baa2eaedb87c153c7f58865fff5e3212d0 (patch)
tree7daa5b6c9de6b96ec5d76ba06d454dd6fdc0c5bb /net-libs/libpcap
parentold, and actually vulnerable version which luckily never got stabilized (diff)
downloadgentoo-2-7dba32baa2eaedb87c153c7f58865fff5e3212d0.tar.gz
gentoo-2-7dba32baa2eaedb87c153c7f58865fff5e3212d0.tar.bz2
gentoo-2-7dba32baa2eaedb87c153c7f58865fff5e3212d0.zip
Version bump thanks to Michael (kensington) and Yun Zheng Hu (bug #393085).
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libpcap')
-rw-r--r--net-libs/libpcap/ChangeLog8
-rw-r--r--net-libs/libpcap/files/libpcap-1.2.0-cross-linux.patch16
-rw-r--r--net-libs/libpcap/libpcap-1.1.1-r1.ebuild7
-rw-r--r--net-libs/libpcap/libpcap-1.2.0.ebuild55
4 files changed, 80 insertions, 6 deletions
diff --git a/net-libs/libpcap/ChangeLog b/net-libs/libpcap/ChangeLog
index b540a8374362..e60a81da01e0 100644
--- a/net-libs/libpcap/ChangeLog
+++ b/net-libs/libpcap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libpcap
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/ChangeLog,v 1.158 2011/12/11 15:52:28 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/ChangeLog,v 1.159 2011/12/16 17:30:38 jer Exp $
+
+*libpcap-1.2.0 (16 Dec 2011)
+
+ 16 Dec 2011; Jeroen Roovers <jer@gentoo.org> libpcap-1.1.1-r1.ebuild,
+ +libpcap-1.2.0.ebuild, +files/libpcap-1.2.0-cross-linux.patch:
+ Version bump thanks to Michael (kensington) and Yun Zheng Hu (bug #393085).
11 Dec 2011; Raúl Porcel <armin76@gentoo.org> libpcap-1.1.1-r1.ebuild:
alpha/ia64/m68k/s390/sh/sparc stable wrt #385875
diff --git a/net-libs/libpcap/files/libpcap-1.2.0-cross-linux.patch b/net-libs/libpcap/files/libpcap-1.2.0-cross-linux.patch
new file mode 100644
index 000000000000..81eddcc395d1
--- /dev/null
+++ b/net-libs/libpcap/files/libpcap-1.2.0-cross-linux.patch
@@ -0,0 +1,16 @@
+--- a/libpcap-1.2.0/configure.in
++++ b/libpcap-1.2.0/configure.in
+@@ -291,7 +291,12 @@
+ dnl XXX This could be done for cross-compiling, but for now it's not.
+ dnl
+ if test -z "$with_pcap" && test "$cross_compiling" = yes; then
+- AC_MSG_ERROR(pcap type not determined when cross-compiling; use --with-pcap=...)
++ if test -z "$with_pcap" ; then
++ case $host in
++ *-linux*) with_pcap="linux";;
++ *) AC_MSG_ERROR(pcap type not determined when cross-compiling; use --with-pcap=...);;
++ esac
++ fi
+ fi
+ AC_ARG_WITH(pcap,
+ AC_HELP_STRING([--with-pcap=TYPE],[use packet capture TYPE]))
diff --git a/net-libs/libpcap/libpcap-1.1.1-r1.ebuild b/net-libs/libpcap/libpcap-1.1.1-r1.ebuild
index 367b2eee997e..c88a8edf8ba2 100644
--- a/net-libs/libpcap/libpcap-1.1.1-r1.ebuild
+++ b/net-libs/libpcap/libpcap-1.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/libpcap-1.1.1-r1.ebuild,v 1.12 2011/12/11 15:52:28 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/libpcap-1.1.1-r1.ebuild,v 1.13 2011/12/16 17:30:38 jer Exp $
EAPI=4
inherit autotools eutils multilib toolchain-funcs
@@ -24,10 +24,7 @@ DEPEND="${RDEPEND}
DOCS=( CREDITS CHANGES VERSION TODO README{,.dag,.linux,.macosx,.septel} )
src_prepare() {
- epatch \
- "${FILESDIR}/${PN}-1.1-cross-linux.patch" \
- "${FILESDIR}/${P}-ignore-ENODEV.patch"
-
+ epatch "${FILESDIR}/${P}-cross-linux.patch"
eautoreconf
}
diff --git a/net-libs/libpcap/libpcap-1.2.0.ebuild b/net-libs/libpcap/libpcap-1.2.0.ebuild
new file mode 100644
index 000000000000..0da4be3e7def
--- /dev/null
+++ b/net-libs/libpcap/libpcap-1.2.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/libpcap-1.2.0.ebuild,v 1.1 2011/12/16 17:30:38 jer Exp $
+
+EAPI=4
+inherit autotools eutils multilib toolchain-funcs
+
+DESCRIPTION="A system-independent library for user-level network packet capture"
+HOMEPAGE="http://www.tcpdump.org/"
+SRC_URI="http://www.tcpdump.org/release/${P}.tar.gz
+ http://www.jp.tcpdump.org/release/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="bluetooth ipv6 libnl static-libs"
+
+RDEPEND="bluetooth? ( net-wireless/bluez )
+ libnl? ( dev-libs/libnl )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/yacc"
+
+DOCS=( CREDITS CHANGES VERSION TODO README{,.dag,.linux,.macosx,.septel} )
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-cross-linux.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable ipv6) \
+ $(use_with libnl) \
+ $(use_enable bluetooth)
+}
+
+src_compile() {
+ emake all shared
+}
+
+src_install() {
+ default
+
+ # remove static libraries (--disable-static does not work)
+ if ! use static-libs; then
+ find "${ED}" -name '*.a' -exec rm {} + || die
+ fi
+
+ # We need this to build pppd on G/FBSD systems
+ if [[ "${USERLAND}" == "BSD" ]]; then
+ insinto /usr/include
+ doins pcap-int.h
+ fi
+}