summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 17:54:56 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 17:54:56 +0000
commitb7ea79d82dff9ee7c32f17c096c49ad35a2585c5 (patch)
treef61f828eba557670a6d6a7f3cb53fc28c896dde4 /net-libs/libzapojit
parentVersion bump for Gnome 3.8 (diff)
downloadgentoo-2-b7ea79d82dff9ee7c32f17c096c49ad35a2585c5.tar.gz
gentoo-2-b7ea79d82dff9ee7c32f17c096c49ad35a2585c5.tar.bz2
gentoo-2-b7ea79d82dff9ee7c32f17c096c49ad35a2585c5.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-libs/libzapojit')
-rw-r--r--net-libs/libzapojit/ChangeLog7
-rw-r--r--net-libs/libzapojit/libzapojit-0.0.3.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/net-libs/libzapojit/ChangeLog b/net-libs/libzapojit/ChangeLog
index 16d8464ba622..9e7f496497c1 100644
--- a/net-libs/libzapojit/ChangeLog
+++ b/net-libs/libzapojit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libzapojit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libzapojit/ChangeLog,v 1.8 2013/02/02 23:05:18 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libzapojit/ChangeLog,v 1.9 2013/03/28 17:54:56 pacho Exp $
+
+*libzapojit-0.0.3 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org> +libzapojit-0.0.3.ebuild:
+ Version bump for Gnome 3.8
02 Feb 2013; Agostino Sarubbo <ago@gentoo.org> libzapojit-0.0.2.ebuild:
Add ~arm, wrt bug #449220
diff --git a/net-libs/libzapojit/libzapojit-0.0.3.ebuild b/net-libs/libzapojit/libzapojit-0.0.3.ebuild
new file mode 100644
index 000000000000..50b2a6e0588e
--- /dev/null
+++ b/net-libs/libzapojit/libzapojit-0.0.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libzapojit/libzapojit-0.0.3.ebuild,v 1.1 2013/03/28 17:54:56 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+#GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="GLib/GObject wrapper for the SkyDrive and Hotmail REST APIs"
+HOMEPAGE="http://git.gnome.org/browse/libzapojit"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=net-libs/libsoup-2.38:2.4
+ dev-libs/json-glib
+ net-libs/rest
+ net-libs/gnome-online-accounts
+
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0 )"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.11
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# eautoreconf needs:
+# gnome-base/gnome-common:3
+
+src_configure() {
+ G2CONF="${G2CONF}
+ --enable-compile-warnings=minimum
+ --disable-static
+ $(use_enable introspection)"
+ gnome2_src_configure
+}
+
+src_install() {
+ gnome2_src_install
+ # Drop self-installed documentation
+ rm -r "${ED}"/usr/share/doc/libzapojit/ || die
+}