summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-10-03 17:11:19 +0000
committerMarinus Schraal <foser@gentoo.org>2003-10-03 17:11:19 +0000
commitae940dbeab4f93fa8f1bf51818fd6d112272dda5 (patch)
tree6087b689ebf1d083d540c468c4b054d3a9e6a539 /net-libs/loudmouth/loudmouth-0.14.ebuild
parentnew version (diff)
downloadgentoo-2-ae940dbeab4f93fa8f1bf51818fd6d112272dda5.tar.gz
gentoo-2-ae940dbeab4f93fa8f1bf51818fd6d112272dda5.tar.bz2
gentoo-2-ae940dbeab4f93fa8f1bf51818fd6d112272dda5.zip
new version
Diffstat (limited to 'net-libs/loudmouth/loudmouth-0.14.ebuild')
-rw-r--r--net-libs/loudmouth/loudmouth-0.14.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-libs/loudmouth/loudmouth-0.14.ebuild b/net-libs/loudmouth/loudmouth-0.14.ebuild
new file mode 100644
index 000000000000..249a5093cbf3
--- /dev/null
+++ b/net-libs/loudmouth/loudmouth-0.14.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/loudmouth-0.14.ebuild,v 1.1 2003/10/03 17:11:15 foser Exp $
+
+inherit gnome2
+
+DESCRIPTION="Lightweight C Jabber library"
+HOMEPAGE="http://www.imendio.com/projects/loudmouth/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="doc ssl"
+
+RDEPEND=">=dev-libs/glib-2
+ ssl? ( net-libs/gnutls )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.0 )"
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README"
+
+use ssl \
+ && G2CONF="${G2CONF} --with-ssl" \
+ || G2CONF="${G2CONF} --without-ssl"
+