summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-12-19 21:07:33 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-12-19 21:07:33 +0000
commit654486c457504831e177160a55921dbaa258b446 (patch)
tree6e0746e839dea16fbdc999d02af342bea6b45392 /net-libs/rb_libtorrent
parentVersion bump (diff)
downloadgentoo-2-654486c457504831e177160a55921dbaa258b446.tar.gz
gentoo-2-654486c457504831e177160a55921dbaa258b446.tar.bz2
gentoo-2-654486c457504831e177160a55921dbaa258b446.zip
Version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'net-libs/rb_libtorrent')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog8
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-1.0.3.ebuild81
2 files changed, 88 insertions, 1 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index bb99b53a2a98..6b3f0f2923cc 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.181 2014/11/15 08:33:02 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.182 2014/12/19 21:07:33 hwoarang Exp $
+
+*rb_libtorrent-1.0.3 (19 Dec 2014)
+
+ 19 Dec 2014; Markos Chandras <hwoarang@gentoo.org>
+ +rb_libtorrent-1.0.3.ebuild:
+ Version bump
*rb_libtorrent-0.16.17-r1 (15 Nov 2014)
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-1.0.3.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-1.0.3.ebuild
new file mode 100644
index 000000000000..fae4d93d61ec
--- /dev/null
+++ b/net-libs/rb_libtorrent/rb_libtorrent-1.0.3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-1.0.3.ebuild,v 1.1 2014/12/19 21:07:33 hwoarang Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="threads"
+
+inherit multilib python-r1
+
+MY_P=${P/rb_/}
+MY_P=${MY_P/torrent/torrent-rasterbar}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
+SRC_URI="mirror://sourceforge/libtorrent/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples python ssl static-libs test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND=">=dev-libs/boost-1.53:=[threads]
+ >=sys-devel/libtool-2.2
+ sys-libs/zlib
+ examples? ( !net-p2p/mldonkey )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/boost[python,${PYTHON_USEDEP}]
+ )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ use python && python_copy_sources
+}
+
+src_configure() {
+ local myconf=(
+ --disable-silent-rules # bug 441842
+ $(use_enable debug)
+ $(use_enable test tests)
+ $(use_enable examples)
+ $(use_enable ssl encryption)
+ $(use_enable static-libs static)
+ --with-boost-libdir=/usr/$(get_libdir)
+ )
+
+ use debug && myconf+=( --enable-logging=verbose )
+
+ econf "${myconf[@]}" --disable-python-binding
+ if use python; then
+ python_configure() {
+ run_in_build_dir econf "${myconf[@]}" --enable-python-binding --with-boost-python=boost_python-${EPYTHON#python}
+ }
+
+ python_foreach_impl python_configure
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use python; then
+ python_install() {
+ emake -C "${BUILD_DIR}"/bindings/python \
+ DESTDIR="${D}" install
+ }
+
+ python_foreach_impl python_install
+ fi
+
+ use static-libs || find "${D}" -name '*.la' -exec rm -f {} +
+ dodoc ChangeLog AUTHORS NEWS README
+ if use doc; then
+ dohtml docs/*
+ fi
+}