summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-09-07 08:35:52 +0000
committerPacho Ramos <pacho@gentoo.org>2013-09-07 08:35:52 +0000
commit72dcb0e80cd3439a7a8b04d76f56a92035f40053 (patch)
tree4fcd6011fbdf2b007605eeeff31a5d5b904022f5 /net-libs/socket++
parentUse query-immodules from eclass to inherit fixes and changes from there (diff)
downloadgentoo-2-72dcb0e80cd3439a7a8b04d76f56a92035f40053.tar.gz
gentoo-2-72dcb0e80cd3439a7a8b04d76f56a92035f40053.tar.bz2
gentoo-2-72dcb0e80cd3439a7a8b04d76f56a92035f40053.zip
Fix failing test due gcc-4.7 (#424305 by Sean Santos)
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-libs/socket++')
-rw-r--r--net-libs/socket++/ChangeLog7
-rw-r--r--net-libs/socket++/files/socket++-1.12.12-gcc47.patch20
-rw-r--r--net-libs/socket++/socket++-1.12.12-r1.ebuild5
3 files changed, 28 insertions, 4 deletions
diff --git a/net-libs/socket++/ChangeLog b/net-libs/socket++/ChangeLog
index ed4795d09ea1..05e1807bb4df 100644
--- a/net-libs/socket++/ChangeLog
+++ b/net-libs/socket++/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/socket++
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/socket++/ChangeLog,v 1.16 2013/04/17 17:59:50 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/socket++/ChangeLog,v 1.17 2013/09/07 08:35:52 pacho Exp $
+
+ 07 Sep 2013; Pacho Ramos <pacho@gentoo.org>
+ +files/socket++-1.12.12-gcc47.patch, socket++-1.12.12-r1.ebuild:
+ Fix failing test due gcc-4.7 (#424305 by Sean Santos)
17 Apr 2013; Ulrich Müller <ulm@gentoo.org> socket++-1.12.12-r1.ebuild:
Fix LICENSE and add bindist restriction, bug 465274.
@@ -66,4 +70,3 @@
+socket++-1.12.10.ebuild:
Initial import, ebuild written by me. Requested in bug #52980 by Vidvandre
<vidvandre@linuxmail.org>
-
diff --git a/net-libs/socket++/files/socket++-1.12.12-gcc47.patch b/net-libs/socket++/files/socket++-1.12.12-gcc47.patch
new file mode 100644
index 000000000000..62a62b090041
--- /dev/null
+++ b/net-libs/socket++/files/socket++-1.12.12-gcc47.patch
@@ -0,0 +1,20 @@
+--- test/thostnames.C~ 2004-06-29 08:47:52.000000000 +0200
++++ test/thostnames.C 2013-09-07 10:30:24.159157101 +0200
+@@ -23,7 +23,7 @@
+ {
+ public:
+ test () : iosockinet (sockbuf::sock_stream) {
+- cout << "Constructor rdbuf: " << (unsigned int) rdbuf() << endl;
++ cout << "Constructor rdbuf: " << (size_t) rdbuf() << endl;
+ }
+ };
+
+@@ -39,7 +39,7 @@
+ }
+
+ sio.rdbuf()->setname ("Testsocket");
+- cout << "rdbuf: " << (unsigned int) sio.rdbuf() << "\n";
++ cout << "rdbuf: " << (size_t) sio.rdbuf() << "\n";
+ cout << "socketname: " << sio.rdbuf()->getname() << endl;
+
+ try {
diff --git a/net-libs/socket++/socket++-1.12.12-r1.ebuild b/net-libs/socket++/socket++-1.12.12-r1.ebuild
index 0674b02206f9..104244ed2729 100644
--- a/net-libs/socket++/socket++-1.12.12-r1.ebuild
+++ b/net-libs/socket++/socket++-1.12.12-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/socket++/socket++-1.12.12-r1.ebuild,v 1.9 2013/04/17 17:59:50 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/socket++/socket++-1.12.12-r1.ebuild,v 1.10 2013/09/07 08:35:52 pacho Exp $
-inherit autotools
+inherit autotools eutils
DESCRIPTION="C++ Socket Library"
HOMEPAGE="http://www.linuxhacker.at/socketxx/"
@@ -21,6 +21,7 @@ RDEPEND=""
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc47.patch"
eautoreconf
}