summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-02-07 18:18:51 +0000
committerPacho Ramos <pacho@gentoo.org>2011-02-07 18:18:51 +0000
commit63fca7dc773c89fb05f6da717b82cd8fb14de383 (patch)
tree737ed3cf83a48e508e2fe8a6fcf5adfb43bac72a /net-libs/telepathy-glib
parentVersion bump via perl-bump experimental tool. (diff)
downloadgentoo-2-63fca7dc773c89fb05f6da717b82cd8fb14de383.tar.gz
gentoo-2-63fca7dc773c89fb05f6da717b82cd8fb14de383.tar.bz2
gentoo-2-63fca7dc773c89fb05f6da717b82cd8fb14de383.zip
Version bump with important bugfixes (like some crashers), add gnome to metadata as talked between us since empathy relies on this.
(Portage version: 2.1.9.36/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/telepathy-glib')
-rw-r--r--net-libs/telepathy-glib/ChangeLog9
-rw-r--r--net-libs/telepathy-glib/metadata.xml1
-rw-r--r--net-libs/telepathy-glib/telepathy-glib-0.12.7.ebuild61
3 files changed, 70 insertions, 1 deletions
diff --git a/net-libs/telepathy-glib/ChangeLog b/net-libs/telepathy-glib/ChangeLog
index 4abb8cf30b0c..c4ed1d408e79 100644
--- a/net-libs/telepathy-glib/ChangeLog
+++ b/net-libs/telepathy-glib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/telepathy-glib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.61 2011/01/27 14:20:06 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.62 2011/02/07 18:18:51 pacho Exp $
+
+*telepathy-glib-0.12.7 (07 Feb 2011)
+
+ 07 Feb 2011; Pacho Ramos <pacho@gentoo.org> +telepathy-glib-0.12.7.ebuild,
+ metadata.xml:
+ Version bump with important bugfixes (like some crashers), add gnome to
+ metadata as talked between us since empathy relies on this.
26 Jan 2011; Kacper Kowalik <xarthisius@gentoo.org>
telepathy-glib-0.12.5.ebuild:
diff --git a/net-libs/telepathy-glib/metadata.xml b/net-libs/telepathy-glib/metadata.xml
index 0a84fc951f34..1bef2fe27933 100644
--- a/net-libs/telepathy-glib/metadata.xml
+++ b/net-libs/telepathy-glib/metadata.xml
@@ -1,6 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <herd>gnome</herd>
<herd>voip</herd>
<maintainer>
<email>peper@gentoo.org</email>
diff --git a/net-libs/telepathy-glib/telepathy-glib-0.12.7.ebuild b/net-libs/telepathy-glib/telepathy-glib-0.12.7.ebuild
new file mode 100644
index 000000000000..976e94186c1d
--- /dev/null
+++ b/net-libs/telepathy-glib/telepathy-glib-0.12.7.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/telepathy-glib-0.12.7.ebuild,v 1.1 2011/02/07 18:18:51 pacho Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+
+inherit python
+
+DESCRIPTION="GLib bindings for the Telepathy D-Bus protocol."
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +introspection +vala"
+
+RDEPEND=">=dev-libs/glib-2.24
+ >=dev-libs/dbus-glib-0.82
+ introspection? ( >=dev-libs/gobject-introspection-0.6.14 )
+ vala? (
+ dev-lang/vala:0.10[vapigen]
+ >=dev-libs/gobject-introspection-0.9.6 )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/pkgconfig-0.21"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure() {
+ local myconf
+
+ if use vala; then
+ myconf="--enable-introspection
+ VALAC=$(type -p valac-0.10)
+ VAPIGEN=$(type -p vapigen-0.10)"
+ fi
+
+ econf \
+ $(use_enable debug backtrace) \
+ $(use_enable debug handle-leak-debug) \
+ $(use_enable introspection) \
+ $(use_enable vala vala-bindings) \
+ ${myconf}
+}
+
+src_test() {
+ if ! dbus-launch emake -j1 check; then
+ die "Make check failed. See above for details."
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}