summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-07-15 16:55:51 +0000
committerJohannes Huber <johu@gentoo.org>2012-07-15 16:55:51 +0000
commit2a36414d49c5868cdf2b5295ca278d023365ae68 (patch)
tree73638688fe8a37c09a069d819ac56bb2d6d4c146 /net-libs/telepathy-qt
parentalpha/ia64/sh/sparc stable wrt #410611 (diff)
downloadgentoo-2-2a36414d49c5868cdf2b5295ca278d023365ae68.tar.gz
gentoo-2-2a36414d49c5868cdf2b5295ca278d023365ae68.tar.bz2
gentoo-2-2a36414d49c5868cdf2b5295ca278d023365ae68.zip
Version bump.
(Portage version: 2.2.0_alpha118/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/telepathy-qt')
-rw-r--r--net-libs/telepathy-qt/ChangeLog7
-rw-r--r--net-libs/telepathy-qt/telepathy-qt-0.9.3.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/net-libs/telepathy-qt/ChangeLog b/net-libs/telepathy-qt/ChangeLog
index 3804d9204e38..41aed7fd6441 100644
--- a/net-libs/telepathy-qt/ChangeLog
+++ b/net-libs/telepathy-qt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/telepathy-qt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt/ChangeLog,v 1.11 2012/07/12 11:01:26 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt/ChangeLog,v 1.12 2012/07/15 16:55:51 johu Exp $
+
+*telepathy-qt-0.9.3 (15 Jul 2012)
+
+ 15 Jul 2012; Johannes Huber <johu@gentoo.org> +telepathy-qt-0.9.3.ebuild:
+ Version bump.
*telepathy-qt-0.9.2 (12 Jul 2012)
diff --git a/net-libs/telepathy-qt/telepathy-qt-0.9.3.ebuild b/net-libs/telepathy-qt/telepathy-qt-0.9.3.ebuild
new file mode 100644
index 000000000000..32d90b0e0825
--- /dev/null
+++ b/net-libs/telepathy-qt/telepathy-qt-0.9.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt/telepathy-qt-0.9.3.ebuild,v 1.1 2012/07/15 16:55:51 johu Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.5"
+inherit python base cmake-utils
+
+DESCRIPTION="Qt4 bindings for the Telepathy D-Bus protocol"
+HOMEPAGE="http://telepathy.freedesktop.org/"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug farsight farstream test"
+
+RDEPEND="
+ x11-libs/qt-core:4
+ x11-libs/qt-dbus:4
+ farsight? (
+ net-libs/telepathy-farsight
+ )
+ farstream? (
+ >=net-libs/telepathy-farstream-0.2.2
+ >=net-libs/telepathy-glib-0.17.5
+ )
+ !net-libs/telepathy-qt4
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ dev-libs/dbus-glib
+ dev-libs/glib
+ dev-python/dbus-python
+ x11-libs/qt-test:4
+ )
+"
+
+REQUIRED_USE="farsight? ( !farstream )"
+
+DOCS=( AUTHORS ChangeLog HACKING NEWS README )
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable farsight)
+ $(cmake-utils_use_enable farstream)
+ $(cmake-utils_use_enable debug DEBUG_OUTPUT)
+ $(cmake-utils_use_enable test TESTS)
+ -DENABLE_EXAMPLES=OFF
+ )
+ cmake-utils_src_configure
+}