summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-06-21 10:14:04 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-06-21 10:14:04 +0000
commit7b249bca772bd7a9b985f3ed2db70be6e8b6cb38 (patch)
treecf654ca6c5e3c6d20cb0679833c9d1c6583386fb /net-libs/telepathy-qt
parentFix build with GCC 4.7, wrt bug #421689. (diff)
downloadgentoo-2-7b249bca772bd7a9b985f3ed2db70be6e8b6cb38.tar.gz
gentoo-2-7b249bca772bd7a9b985f3ed2db70be6e8b6cb38.tar.bz2
gentoo-2-7b249bca772bd7a9b985f3ed2db70be6e8b6cb38.zip
Fix build with GCC 4.7 by backporting upstream patch. Fixes bug #421921.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/telepathy-qt')
-rw-r--r--net-libs/telepathy-qt/ChangeLog6
-rw-r--r--net-libs/telepathy-qt/files/telepathy-qt-0.9.1-gcc-4.7.patch52
-rw-r--r--net-libs/telepathy-qt/telepathy-qt-0.9.1.ebuild7
3 files changed, 62 insertions, 3 deletions
diff --git a/net-libs/telepathy-qt/ChangeLog b/net-libs/telepathy-qt/ChangeLog
index 748394e9c34e..f7233daa1b5b 100644
--- a/net-libs/telepathy-qt/ChangeLog
+++ b/net-libs/telepathy-qt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/telepathy-qt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt/ChangeLog,v 1.6 2012/05/05 02:54:26 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt/ChangeLog,v 1.7 2012/06/21 10:14:04 kensington Exp $
+
+ 21 Jun 2012; Michael Palimaka <kensington@gentoo.org>
+ +files/telepathy-qt-0.9.1-gcc-4.7.patch, telepathy-qt-0.9.1.ebuild:
+ Fix build with GCC 4.7 by backporting upstream patch. Fixes bug #421921.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> telepathy-qt-0.8.0.ebuild,
telepathy-qt-0.9.0.ebuild, telepathy-qt-0.9.1.ebuild:
diff --git a/net-libs/telepathy-qt/files/telepathy-qt-0.9.1-gcc-4.7.patch b/net-libs/telepathy-qt/files/telepathy-qt-0.9.1-gcc-4.7.patch
new file mode 100644
index 000000000000..248e0d5a0d88
--- /dev/null
+++ b/net-libs/telepathy-qt/files/telepathy-qt-0.9.1-gcc-4.7.patch
@@ -0,0 +1,52 @@
+From b2632998374b45af488b6c3a5a6fe330d23bb799 Mon Sep 17 00:00:00 2001
+From: George Kiagiadakis <george.kiagiadakis@collabora.com>
+Date: Wed, 02 May 2012 14:34:47 +0000
+Subject: Use quintptr instead of intptr_t.
+
+This fixes FTBFS with gcc-4.7, which requires <stdint.h> to be
+included for intptr_t to be available. However, since stdint.h
+is not part of the C++03 standard, it is better to use Qt's types.
+
+Reviewed-by: Andre Moreira Magalhaes (andrunko) <andre.magalhaes@collabora.co.uk>
+
+diff --git a/TelepathyQt/client-registrar.cpp b/TelepathyQt/client-registrar.cpp
+index 1b6c1e4..6ed9932 100644
+--- a/TelepathyQt/client-registrar.cpp
++++ b/TelepathyQt/client-registrar.cpp
+@@ -888,7 +888,7 @@ bool ClientRegistrar::registerClient(const AbstractClientPtr &client,
+ .arg(mPriv->bus.baseService()
+ .replace(QLatin1String(":"), QLatin1String("_"))
+ .replace(QLatin1String("."), QLatin1String("_")))
+- .arg((intptr_t) client.data(), 0, 16));
++ .arg((quintptr) client.data(), 0, 16));
+ }
+
+ if (mPriv->services.contains(busName) ||
+diff --git a/TelepathyQt/stream-tube-client.cpp b/TelepathyQt/stream-tube-client.cpp
+index f22384c..9716a34 100644
+--- a/TelepathyQt/stream-tube-client.cpp
++++ b/TelepathyQt/stream-tube-client.cpp
+@@ -211,7 +211,7 @@ struct TP_QT_NO_EXPORT StreamTubeClient::Private
+ .arg(registrar->dbusConnection().baseService()
+ .replace(QLatin1Char(':'), QLatin1Char('_'))
+ .replace(QLatin1Char('.'), QLatin1Char('_')))
+- .arg((intptr_t) this, 0, 16);
++ .arg((quintptr) this, 0, 16);
+ }
+ }
+
+diff --git a/TelepathyQt/stream-tube-server.cpp b/TelepathyQt/stream-tube-server.cpp
+index e1791df..8aaaff4 100644
+--- a/TelepathyQt/stream-tube-server.cpp
++++ b/TelepathyQt/stream-tube-server.cpp
+@@ -307,7 +307,7 @@ struct StreamTubeServer::Private
+ .arg(registrar->dbusConnection().baseService()
+ .replace(QLatin1Char(':'), QLatin1Char('_'))
+ .replace(QLatin1Char('.'), QLatin1Char('_')))
+- .arg((intptr_t) this, 0, 16);
++ .arg((quintptr) this, 0, 16);
+ }
+ }
+
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/net-libs/telepathy-qt/telepathy-qt-0.9.1.ebuild b/net-libs/telepathy-qt/telepathy-qt-0.9.1.ebuild
index 677f9a900730..6e30f3e67967 100644
--- a/net-libs/telepathy-qt/telepathy-qt-0.9.1.ebuild
+++ b/net-libs/telepathy-qt/telepathy-qt-0.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt/telepathy-qt-0.9.1.ebuild,v 1.2 2012/05/05 02:54:26 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt/telepathy-qt-0.9.1.ebuild,v 1.3 2012/06/21 10:14:04 kensington Exp $
EAPI=4
@@ -43,7 +43,10 @@ DEPEND="${RDEPEND}
REQUIRED_USE="farsight? ( !farstream )"
-PATCHES=( "${FILESDIR}/${P}-automagicness.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-automagicness.patch"
+ "${FILESDIR}/${P}-gcc-4.7.patch"
+)
DOCS=( AUTHORS ChangeLog HACKING NEWS README )
pkg_setup() {