summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-12-26 12:50:25 +0000
committerAlin Năstac <mrness@gentoo.org>2005-12-26 12:50:25 +0000
commitb8844a7ca72eca15743344bcbdfddeac907a3c4f (patch)
tree5f8ed90aab9c8e31a70b7c046ffffb508b03f92e /net-libs/wvstreams
parentoggvorbis Cleanup (diff)
downloadgentoo-2-b8844a7ca72eca15743344bcbdfddeac907a3c4f.tar.gz
gentoo-2-b8844a7ca72eca15743344bcbdfddeac907a3c4f.tar.bz2
gentoo-2-b8844a7ca72eca15743344bcbdfddeac907a3c4f.zip
Fix compilation error on 64-bit arches (#116704)
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'net-libs/wvstreams')
-rw-r--r--net-libs/wvstreams/ChangeLog6
-rw-r--r--net-libs/wvstreams/Manifest13
-rw-r--r--net-libs/wvstreams/files/wvstreams-4.2.1-ptr2int-cast.patch11
-rw-r--r--net-libs/wvstreams/wvstreams-4.2.1.ebuild3
4 files changed, 20 insertions, 13 deletions
diff --git a/net-libs/wvstreams/ChangeLog b/net-libs/wvstreams/ChangeLog
index 3f0e38e4fa47..c1db7b993624 100644
--- a/net-libs/wvstreams/ChangeLog
+++ b/net-libs/wvstreams/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/wvstreams
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.75 2005/12/24 19:14:22 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.76 2005/12/26 12:50:25 mrness Exp $
+
+ 26 Dec 2005; Alin Nastac <mrness@gentoo.org>
+ +files/wvstreams-4.2.1-ptr2int-cast.patch, wvstreams-4.2.1.ebuild:
+ Fix compilation error on 64-bit arches (#116704).
*wvstreams-4.2.1 (24 Dec 2005)
diff --git a/net-libs/wvstreams/Manifest b/net-libs/wvstreams/Manifest
index af9a5a55dd56..8a37683974d9 100644
--- a/net-libs/wvstreams/Manifest
+++ b/net-libs/wvstreams/Manifest
@@ -1,8 +1,5 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 e6ad89da209df1e31e319fb9133a5d5c wvstreams-4.0.2-r2.ebuild 2598
-MD5 0e03241b00bb6182f776bc336d1e4755 wvstreams-4.2.1.ebuild 2433
+MD5 f318014e97a1597e02d9e91a55acd3e8 wvstreams-4.2.1.ebuild 2521
MD5 e594922148c5a6f7087f083cf392e55c wvstreams-4.0.2-r1.ebuild 2558
MD5 7ad8d90f51029182dfd4708c548a8870 ChangeLog 11560
MD5 227de7f678ad662524292836709de75f metadata.xml 313
@@ -20,12 +17,6 @@ MD5 b65b1449a0bc6ff06e8c843b37717f05 files/wvstreams-4.0.2-speex-const.patch 951
MD5 62675720135a871a7332b3a924a6c0f9 files/wvstreams-4.2.1-wireless-user.patch 466
MD5 fe54c7dbb4770aad4ef9a5dcb44106ec files/wvstreams-4.2.1-linux-serial.patch 1649
MD5 0b5b1b03e323747aa3ce30492fe18cc1 files/wvstreams-4.0.2-tcl_8_4.patch 1022
+MD5 b44c2e240e03736bc5acc41ce7069455 files/wvstreams-4.2.1-ptr2int-cast.patch 356
MD5 6448ad9ded98b10b600e0b3386d2c4bf files/wvstreams-4.0.2-gcc41.patch 698
MD5 189d6997246f2943d43b5c18d0a78163 files/wvstreams-4.0.2-external-xplc.patch 1659
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDrZ4tNSP4Vda7IdsRAvgZAJ4uC1OsDjEAe00NNaiEel+CwOEZjwCghrhq
-pTOMD+Et4qe28DuoWYUyeP4=
-=Tdov
------END PGP SIGNATURE-----
diff --git a/net-libs/wvstreams/files/wvstreams-4.2.1-ptr2int-cast.patch b/net-libs/wvstreams/files/wvstreams-4.2.1-ptr2int-cast.patch
new file mode 100644
index 000000000000..7faf9441f4a5
--- /dev/null
+++ b/net-libs/wvstreams/files/wvstreams-4.2.1-ptr2int-cast.patch
@@ -0,0 +1,11 @@
+diff -Nru wvstreams-4.2.1.orig/utils/wvhash.cc wvstreams-4.2.1/utils/wvhash.cc
+--- wvstreams-4.2.1.orig/utils/wvhash.cc 2005-11-17 22:45:07.000000000 +0200
++++ wvstreams-4.2.1/utils/wvhash.cc 2005-12-26 14:31:40.882751000 +0200
+@@ -30,6 +30,6 @@
+
+ unsigned WvHash(const void *p)
+ {
+- return reinterpret_cast<unsigned>(p);
++ return (unsigned)p;
+ }
+
diff --git a/net-libs/wvstreams/wvstreams-4.2.1.ebuild b/net-libs/wvstreams/wvstreams-4.2.1.ebuild
index 5659f6359493..66e2f3a23ea5 100644
--- a/net-libs/wvstreams/wvstreams-4.2.1.ebuild
+++ b/net-libs/wvstreams/wvstreams-4.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.2.1.ebuild,v 1.1 2005/12/24 19:14:22 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.2.1.ebuild,v 1.2 2005/12/26 12:50:25 mrness Exp $
inherit eutils autotools
@@ -33,6 +33,7 @@ src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${P}-gcc41.patch
+ epatch ${FILESDIR}/${P}-ptr2int-cast.patch #fix compilation error on non-32-bit arches
epatch ${FILESDIR}/${P}-linux-serial.patch
epatch ${FILESDIR}/${P}-wireless-user.patch