summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-11-19 20:12:09 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-11-19 20:12:09 +0000
commit944c6e3aa5a290b66c962a2ddc11100d82defd7d (patch)
treeae00d64c636d0fb03c59cf511e4705e4edc12f66 /net-libs/xrootd
parentUse eclass function for the registering of ntp provider (#489044 by Kirill El... (diff)
downloadgentoo-2-944c6e3aa5a290b66c962a2ddc11100d82defd7d.tar.gz
gentoo-2-944c6e3aa5a290b66c962a2ddc11100d82defd7d.tar.bz2
gentoo-2-944c6e3aa5a290b66c962a2ddc11100d82defd7d.zip
Version bump
(Portage version: 2.2.7-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'net-libs/xrootd')
-rw-r--r--net-libs/xrootd/ChangeLog8
-rw-r--r--net-libs/xrootd/metadata.xml11
-rw-r--r--net-libs/xrootd/xrootd-3.3.4.ebuild (renamed from net-libs/xrootd/xrootd-3.3.1.ebuild)13
3 files changed, 21 insertions, 11 deletions
diff --git a/net-libs/xrootd/ChangeLog b/net-libs/xrootd/ChangeLog
index ae28f5ee0575..f3077c9451d2 100644
--- a/net-libs/xrootd/ChangeLog
+++ b/net-libs/xrootd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/xrootd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/xrootd/ChangeLog,v 1.14 2013/06/04 15:51:34 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/xrootd/ChangeLog,v 1.15 2013/11/19 20:12:09 bicatali Exp $
+
+*xrootd-3.3.4 (19 Nov 2013)
+
+ 19 Nov 2013; Sébastien Fabbro <bicatali@gentoo.org> +xrootd-3.3.4.ebuild,
+ -xrootd-3.3.1.ebuild, metadata.xml:
+ Version bump
*xrootd-3.3.2 (04 Jun 2013)
diff --git a/net-libs/xrootd/metadata.xml b/net-libs/xrootd/metadata.xml
index b629e537dcfd..604e38963b68 100644
--- a/net-libs/xrootd/metadata.xml
+++ b/net-libs/xrootd/metadata.xml
@@ -3,11 +3,12 @@
<pkgmetadata>
<herd>sci-physics</herd>
<longdescription lang="en">
- XROOTD software framework is a fully generic suite for fast, low latency and
- scalable data access, which can serve natively any kind of data, organized as
- a hierarchical filesystem-like namespace, based on the concept of directory.
- It is usually used with <pkg>sci-physics/root</pkg> and its PROOF facilities
- for cluster computing in high energy physics.
+ XROOTD software framework is a fully generic suite for fast, low latency
+ and scalable data access, which can serve natively any kind of data,
+ organized as a hierarchical filesystem-like namespace, based on the
+ concept of directory.
+ It is usually used with <pkg>sci-physics/root</pkg> and its PROOF
+ facilities for cluster computing in high energy physics.
</longdescription>
<use>
<flag name="fuse">Enable the <pkg>sys-fs/fuse</pkg> filesystem driver</flag>
diff --git a/net-libs/xrootd/xrootd-3.3.1.ebuild b/net-libs/xrootd/xrootd-3.3.4.ebuild
index 4ca919d553e4..fb29bc6c8bcb 100644
--- a/net-libs/xrootd/xrootd-3.3.1.ebuild
+++ b/net-libs/xrootd/xrootd-3.3.4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/xrootd/xrootd-3.3.1.ebuild,v 1.1 2013/03/23 15:22:10 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/xrootd/xrootd-3.3.4.ebuild,v 1.1 2013/11/19 20:12:09 bicatali Exp $
EAPI=5
-inherit cmake-utils eutils user
+inherit cmake-utils eutils user multilib
DURI="http://xrootd.slac.stanford.edu/doc/prod"
@@ -14,8 +14,8 @@ SRC_URI="${HOMEPAGE}/download/v${PV}/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc fuse kerberos perl readline ssl"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc fuse kerberos perl readline ssl test"
RDEPEND="
!<sci-physics/root-5.32[xrootd]
@@ -30,13 +30,15 @@ RDEPEND="
ssl? ( dev-libs/openssl )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen[dot] )
- perl? ( dev-lang/swig )"
+ perl? ( dev-lang/swig )
+ test? ( dev-util/cppunit )"
pkg_setup() {
enewgroup xrootd
enewuser xrootd -1 -1 "${EPREFIX}"/var/spool/xrootd xrootd
}
+
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_enable fuse)
@@ -44,6 +46,7 @@ src_configure() {
$(cmake-utils_use_enable perl)
$(cmake-utils_use_enable readline)
$(cmake-utils_use_enable ssl CRYPTO)
+ $(cmake-utils_use_enable test TESTS)
)
cmake-utils_src_configure
}