summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2010-07-11 12:30:17 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2010-07-11 12:30:17 +0000
commit694f3c0549187592b3fd27b7c3debe4eab6a9541 (patch)
tree7d0b6ee1e8f96936b0b72accc3b30ff2bbad6e27 /net-libs/xulrunner/files
parentstable x86, bug 325149 (diff)
downloadgentoo-2-694f3c0549187592b3fd27b7c3debe4eab6a9541.tar.gz
gentoo-2-694f3c0549187592b3fd27b7c3debe4eab6a9541.tar.bz2
gentoo-2-694f3c0549187592b3fd27b7c3debe4eab6a9541.zip
Add patch for ARM OS detection, bug 327783
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'net-libs/xulrunner/files')
-rw-r--r--net-libs/xulrunner/files/xulrunner-1.9.2-arm-fixes.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-libs/xulrunner/files/xulrunner-1.9.2-arm-fixes.patch b/net-libs/xulrunner/files/xulrunner-1.9.2-arm-fixes.patch
new file mode 100644
index 000000000000..a726209e6373
--- /dev/null
+++ b/net-libs/xulrunner/files/xulrunner-1.9.2-arm-fixes.patch
@@ -0,0 +1,35 @@
+Fix arm OS detection
+
+https://bugs.gentoo.org/327783
+https://bugzilla.mozilla.org/show_bug.cgi?id=577319
+---
+--- configure.in
++++ configure.in
+@@ -1424,9 +1424,11 @@
+ CPU_ARCH="$OS_TEST"
+ ;;
+
+-arm)
++arm*)
+ if test "$OS_TARGET" = "WINCE"; then
+ CPU_ARCH="$OS_TEST"
++ else
++ CPU_ARCH="arm"
+ fi
+ ;;
+ esac
+--- js/src/configure.in
++++ js/src/configure.in
+@@ -1162,9 +1162,11 @@
+ CPU_ARCH="$OS_TEST"
+ ;;
+
+-arm)
++arm*)
+ if test "$OS_TARGET" = "WINCE"; then
+ CPU_ARCH="$OS_TEST"
++ else
++ CPU_ARCH="arm"
+ fi
+ ;;
+ esac