summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-05-09 03:29:16 +0000
committerJeroen Roovers <jer@gentoo.org>2013-05-09 03:29:16 +0000
commit0674c2cfb49eee8cb681ace4be9cde3754fd2e90 (patch)
tree2939bbb320318b103f1d247fd36a12a718867398 /net-libs
parentOld. (diff)
downloadgentoo-2-0674c2cfb49eee8cb681ace4be9cde3754fd2e90.tar.gz
gentoo-2-0674c2cfb49eee8cb681ace4be9cde3754fd2e90.tar.bz2
gentoo-2-0674c2cfb49eee8cb681ace4be9cde3754fd2e90.zip
Old.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libpcap/ChangeLog7
-rw-r--r--net-libs/libpcap/files/libpcap-1.1-cross-linux.patch30
-rw-r--r--net-libs/libpcap/files/libpcap-1.1.1-ignore-ENODEV.patch36
-rw-r--r--net-libs/libpcap/libpcap-1.1.1-r1.ebuild58
4 files changed, 6 insertions, 125 deletions
diff --git a/net-libs/libpcap/ChangeLog b/net-libs/libpcap/ChangeLog
index 20056932d22d..c6237be4c631 100644
--- a/net-libs/libpcap/ChangeLog
+++ b/net-libs/libpcap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libpcap
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/ChangeLog,v 1.182 2013/05/09 03:17:32 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/ChangeLog,v 1.183 2013/05/09 03:29:15 jer Exp $
+
+ 09 May 2013; Jeroen Roovers <jer@gentoo.org>
+ -files/libpcap-1.1-cross-linux.patch,
+ -files/libpcap-1.1.1-ignore-ENODEV.patch, -libpcap-1.1.1-r1.ebuild:
+ Old.
*libpcap-1.4.0 (09 May 2013)
diff --git a/net-libs/libpcap/files/libpcap-1.1-cross-linux.patch b/net-libs/libpcap/files/libpcap-1.1-cross-linux.patch
deleted file mode 100644
index 5a35a89022d6..000000000000
--- a/net-libs/libpcap/files/libpcap-1.1-cross-linux.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-=== modified file 'configure.in'
---- configure.in 2010-04-02 04:52:17 +0000
-+++ configure.in 2010-04-02 04:52:22 +0000
-@@ -291,7 +291,12 @@
- dnl XXX This could be done for cross-compiling, but for now it's not.
- dnl
- if test -z "$with_pcap" && test "$cross_compiling" = yes; then
-- AC_MSG_ERROR(pcap type not determined when cross-compiling; use --with-pcap=...)
-+ if test -z "$with_pcap" ; then
-+ case $host in
-+ *-linux*) with_pcap="linux";;
-+ *) AC_MSG_ERROR(pcap type not determined when cross-compiling; use --with-pcap=...);;
-+ esac
-+ fi
- fi
- AC_ARG_WITH(pcap,
- AC_HELP_STRING([--with-pcap=TYPE],[use packet capture TYPE]))
-@@ -412,8 +417,10 @@
- linux)
- AC_MSG_CHECKING(Linux kernel version)
- if test "$cross_compiling" = yes; then
-+ dnl we could check linux/version.h here, but who runs
-+ dnl versions of linux older than 2.0.x anymore to bother ?
- AC_CACHE_VAL(ac_cv_linux_vers,
-- ac_cv_linux_vers=unknown)
-+ ac_cv_linux_vers=2)
- else
- AC_CACHE_VAL(ac_cv_linux_vers,
- ac_cv_linux_vers=`uname -r 2>&1 | \
-
diff --git a/net-libs/libpcap/files/libpcap-1.1.1-ignore-ENODEV.patch b/net-libs/libpcap/files/libpcap-1.1.1-ignore-ENODEV.patch
deleted file mode 100644
index 3dcbcae95210..000000000000
--- a/net-libs/libpcap/files/libpcap-1.1.1-ignore-ENODEV.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-commit 073a8b37f97b684a34d29800400879e4e902ff63
-Author: andy-1 <andy-1@sourceforge.net>
-Date: Tue Apr 27 23:33:23 2010 -0700
-
- Ignore /sys/net/dev files if we get ENODEV for them, not just ENXIO.
-
- Both of them are indications that there's no such interface, so the file
- probably corresponds to something other than a device.
-
- Reviewed-By: Guy Harris <guy@alum.mit.edu>
-
-diff --git a/CREDITS b/CREDITS
-index 0d23783..6efc188 100644
---- a/CREDITS
-+++ b/CREDITS
-@@ -15,6 +15,7 @@ Additional people who have contributed patches:
- Alexey Kuznetsov <kuznet at ms2 dot inr dot ac dot ru>
- Alon Bar-Lev <alonbl at sourceforge dot net>
- Andrew Brown <atatat at atatdot dot net>
-+ <andy-1 at sourceforge dot net>
- Antti Kantee <pooka at netbsd dot org>
- Arien Vijn <arienvijn at sourceforge dot net>
- Arkadiusz Miskiewicz <misiek at pld dot org dot pl>
-diff --git a/pcap-linux.c b/pcap-linux.c
-index af12543..de3239a 100644
---- a/pcap-linux.c
-+++ b/pcap-linux.c
-@@ -1883,7 +1883,7 @@ scan_sys_class_net(pcap_if_t **devlistp, char *errbuf)
- */
- strncpy(ifrflags.ifr_name, name, sizeof(ifrflags.ifr_name));
- if (ioctl(fd, SIOCGIFFLAGS, (char *)&ifrflags) < 0) {
-- if (errno == ENXIO)
-+ if (errno == ENXIO || errno == ENODEV)
- continue;
- (void)snprintf(errbuf, PCAP_ERRBUF_SIZE,
- "SIOCGIFFLAGS: %.*s: %s",
diff --git a/net-libs/libpcap/libpcap-1.1.1-r1.ebuild b/net-libs/libpcap/libpcap-1.1.1-r1.ebuild
deleted file mode 100644
index 11991bc2bc3f..000000000000
--- a/net-libs/libpcap/libpcap-1.1.1-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/libpcap-1.1.1-r1.ebuild,v 1.17 2012/08/27 16:54:09 flameeyes Exp $
-
-EAPI=4
-inherit autotools eutils multilib toolchain-funcs
-
-DESCRIPTION="A system-independent library for user-level network packet capture"
-HOMEPAGE="http://www.tcpdump.org/"
-SRC_URI="http://www.tcpdump.org/release/${P}.tar.gz
- http://www.jp.tcpdump.org/release/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="bluetooth ipv6 netlink static-libs"
-
-RDEPEND="bluetooth? ( net-wireless/bluez )
- netlink? ( dev-libs/libnl:1.1 )"
-DEPEND="${RDEPEND}
- sys-devel/flex
- virtual/yacc"
-
-DOCS=( CREDITS CHANGES VERSION TODO README{,.dag,.linux,.macosx,.septel} )
-
-src_prepare() {
- epatch \
- "${FILESDIR}/${PN}-1.1-cross-linux.patch" \
- "${FILESDIR}/${P}-ignore-ENODEV.patch"
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable ipv6) \
- $(use_with netlink libnl) \
- $(use_enable bluetooth)
-}
-
-src_compile() {
- emake all shared
-}
-
-src_install() {
- default
-
- # remove static libraries (--disable-static does not work)
- if ! use static-libs; then
- find "${ED}" -name '*.a' -exec rm {} + || die
- fi
-
- # We need this to build pppd on G/FBSD systems
- if [[ "${USERLAND}" == "BSD" ]]; then
- insinto /usr/include
- doins pcap-int.h
- fi
-}