summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-08-18 20:55:51 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-08-18 20:55:51 +0000
commit34a5f511afadfe18d01abb3d9963aa893892826a (patch)
tree9d1d6dc26f8670d96a9760bde4d9895ca0d42d20 /net-libs
parentVersion bump (diff)
downloadgentoo-2-34a5f511afadfe18d01abb3d9963aa893892826a.tar.gz
gentoo-2-34a5f511afadfe18d01abb3d9963aa893892826a.tar.bz2
gentoo-2-34a5f511afadfe18d01abb3d9963aa893892826a.zip
Fixing buddy list status #239144 , documentation path, bug #241298
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/meanwhile/ChangeLog10
-rw-r--r--net-libs/meanwhile/files/meanwhile-1.0.2-presence.patch42
-rw-r--r--net-libs/meanwhile/meanwhile-1.0.2.ebuild15
3 files changed, 63 insertions, 4 deletions
diff --git a/net-libs/meanwhile/ChangeLog b/net-libs/meanwhile/ChangeLog
index 15e881d1067d..a612ec52f576 100644
--- a/net-libs/meanwhile/ChangeLog
+++ b/net-libs/meanwhile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/meanwhile
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/meanwhile/ChangeLog,v 1.49 2008/04/21 17:54:30 phreak Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/meanwhile/ChangeLog,v 1.50 2009/08/18 20:55:51 vostorga Exp $
+
+ 18 Aug 2009; Víctor Ostorga <vostorga@gentoo.org> meanwhile-1.0.2.ebuild,
+ +files/meanwhile-1.0.2-presence.patch:
+ Fixing buddy list status, patch thanks to Andreas Tarp
+ <andreas.tarp@ericsson.com> and <koquinn@gmail.com>, #239144
+ Fixing documentation path, bug #241298
21 Apr 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Fix up metadata.xml. If there's no maintainer for the package, the metadata
diff --git a/net-libs/meanwhile/files/meanwhile-1.0.2-presence.patch b/net-libs/meanwhile/files/meanwhile-1.0.2-presence.patch
new file mode 100644
index 000000000000..e01089eda91c
--- /dev/null
+++ b/net-libs/meanwhile/files/meanwhile-1.0.2-presence.patch
@@ -0,0 +1,42 @@
+# User Mikael Berthe <mikael.berthe@lilotux.net>
+# Date 1194208892 -3600
+Fix Awareness Snapshots with recent Sametime servers
+
+With recent Sametime servers there seem to be 2 bytes
+after the Snapshot Message Blocks.
+This patch tries to use the end of block offset provided
+by the server.
+
+diff -r be8d8f1d3ebc src/common.c
+--- a/src/common.c Sun Nov 04 18:48:00 2007 +0100
++++ b/src/common.c Tue Nov 06 11:46:26 2007 +0100
+@@ -878,23 +878,24 @@ gboolean mwAwareIdBlock_equal(const stru
+ /* 8.4.2.4 Snapshot */
+
+ void mwAwareSnapshot_get(struct mwGetBuffer *b, struct mwAwareSnapshot *idb) {
+- guint32 junk;
+- char *empty = NULL;
++ guint32 end_of_block;
+
+ g_return_if_fail(b != NULL);
+ g_return_if_fail(idb != NULL);
+
+- guint32_get(b, &junk);
++ guint32_get(b, &end_of_block);
+ mwAwareIdBlock_get(b, &idb->id);
+ mwString_get(b, &idb->group);
+ gboolean_get(b, &idb->online);
+-
+- g_free(empty);
+
+ if(idb->online) {
+ mwString_get(b, &idb->alt_id);
+ mwUserStatus_get(b, &idb->status);
+ mwString_get(b, &idb->name);
++ }
++
++ if( b->ptr < b->buf + end_of_block ) {
++ mwGetBuffer_advance(b, b->buf + end_of_block - b->ptr);
+ }
+ }
+
diff --git a/net-libs/meanwhile/meanwhile-1.0.2.ebuild b/net-libs/meanwhile/meanwhile-1.0.2.ebuild
index eae492c073e2..087c1bee3893 100644
--- a/net-libs/meanwhile/meanwhile-1.0.2.ebuild
+++ b/net-libs/meanwhile/meanwhile-1.0.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/meanwhile/meanwhile-1.0.2.ebuild,v 1.15 2007/07/13 07:18:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/meanwhile/meanwhile-1.0.2.ebuild,v 1.16 2009/08/18 20:55:51 vostorga Exp $
+
+inherit eutils
DESCRIPTION="Meanwhile (Sametime protocol) library"
HOMEPAGE="http://meanwhile.sourceforge.net/"
@@ -18,6 +20,15 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
doc? ( app-doc/doxygen )"
+src_unpack(){
+ unpack "${A}"
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-presence.patch" #239144
+
+ #241298
+ sed -i -e "/sampledir/ s:-doc::" samples/Makefile.in
+}
+
src_compile() {
local myconf
use doc || myconf="${myconf} --enable-doxygen=no"