summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-04-25 19:25:11 +0000
committerPacho Ramos <pacho@gentoo.org>2013-04-25 19:25:11 +0000
commit3817ea42593bc51b9f913be6defd3646a2b2a13e (patch)
tree28d62402804695061101bf66523f85ae9f11e12a /net-libs
parentFix autoreconf failures with automake-1.13 (bug #466938). (diff)
downloadgentoo-2-3817ea42593bc51b9f913be6defd3646a2b2a13e.tar.gz
gentoo-2-3817ea42593bc51b9f913be6defd3646a2b2a13e.tar.bz2
gentoo-2-3817ea42593bc51b9f913be6defd3646a2b2a13e.zip
Version bump, drop old
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libsoup/ChangeLog8
-rw-r--r--net-libs/libsoup/libsoup-2.42.2.ebuild (renamed from net-libs/libsoup/libsoup-2.42.0.ebuild)13
2 files changed, 14 insertions, 7 deletions
diff --git a/net-libs/libsoup/ChangeLog b/net-libs/libsoup/ChangeLog
index d2b25ccac969..34ead1eba1e4 100644
--- a/net-libs/libsoup/ChangeLog
+++ b/net-libs/libsoup/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libsoup
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/ChangeLog,v 1.305 2013/04/18 20:11:25 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/ChangeLog,v 1.306 2013/04/25 19:25:11 pacho Exp $
+
+*libsoup-2.42.2 (25 Apr 2013)
+
+ 25 Apr 2013; Pacho Ramos <pacho@gentoo.org> +libsoup-2.42.2.ebuild,
+ -libsoup-2.42.0.ebuild:
+ Version bump, drop old
18 Apr 2013; Pacho Ramos <pacho@gentoo.org>
+files/libsoup-2.42.1-ipv6-tests.patch, libsoup-2.42.1.ebuild:
diff --git a/net-libs/libsoup/libsoup-2.42.0.ebuild b/net-libs/libsoup/libsoup-2.42.2.ebuild
index aacdf4fcd3ff..d5427f2fb47a 100644
--- a/net-libs/libsoup/libsoup-2.42.0.ebuild
+++ b/net-libs/libsoup/libsoup-2.42.2.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.42.0.ebuild,v 1.4 2013/04/07 09:36:55 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.42.2.ebuild,v 1.1 2013/04/25 19:25:11 pacho Exp $
EAPI="5"
GCONF_DEBUG="yes"
GNOME2_LA_PUNT="yes"
PYTHON_COMPAT=( python{2_5,2_6,2_7} )
-inherit gnome2 python-any-r1
+inherit eutils gnome2 python-any-r1
DESCRIPTION="An HTTP library implementation in C"
HOMEPAGE="http://live.gnome.org/LibSoup"
@@ -17,12 +17,14 @@ SLOT="2.4"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE="debug +introspection samba ssl test"
-RDEPEND=">=dev-libs/glib-2.35.0:2
+RDEPEND="
+ >=dev-libs/glib-2.36.0:2
>=dev-libs/libxml2-2:2
dev-db/sqlite:3
>=net-libs/glib-networking-2.30.0[ssl?]
introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
- samba? ( net-fs/samba )"
+ samba? ( net-fs/samba )
+"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
>=dev-util/intltool-0.35
@@ -43,7 +45,6 @@ src_prepare() {
sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
|| die "sed failed"
fi
-
gnome2_src_prepare
}
@@ -59,5 +60,5 @@ src_configure() {
--with-gnome \
--without-apache-httpd \
$(use_enable introspection) \
- $(use_with samba ntlm-auth ${EPREFIX}/usr/bin/ntlm_auth)
+ $(use_with samba ntlm-auth '${EPREFIX}'/usr/bin/ntlm_auth)
}